<!DOCTYPE html>
<html lang="en">
	<head><script src="/gdpr/gdprscript.js?buildTime=1545430657&hasRemindMe=true&stealth=false"></script>
		<title>Debian Installation - Part 1 - LinuxAndUbuntu - Linux News | FOSS Reviews | Linux Tutorials HowTo</title><meta property="og:site_name" content="LinuxAndUbuntu - Linux News | FOSS Reviews | Linux Tutorials HowTo" />
<meta property="og:title" content="Debian Installation - Part 1" />
<meta property="og:description" content="Debian is an Operating System like Microsoft Windows 10 and OS X. It is also the mother of all operating systems when one talks about its derivatives like Ubuntu, Linux Mint, Zorin OS, etc. Debian has a cool installation setup that is quite beneficial to " />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-installation_1_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-configure-hostname-installation_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-setup-root-password_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-installation-partition-disk_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-package-manager_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-9-desktop-environment_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-9-installation-complete_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/install-debian-9-stretch-graphical-installer_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/debian-9-stretch-command-line-installation_orig.png" />
<meta property="og:image" content="https://www.facebook.com/tr?id=1622359727778105&ev=PageView&noscript=1" />
<meta property="og:url" content="http://www.linuxandubuntu.com/1/post/2018/12/debian-installation-part-1.html" />
<meta http-equiv='cache-control' content='no-cache' />
<meta name="description" content="Debian is an Operating System like Microsoft Windows 10 and OS X. It is also the mother of all operating systems when one talks about its derivatives like Ubuntu, Linux Mint, Zorin OS, etc. Debian has a cool installation setup that is quite beneficial to " />


<meta name="keywords" content="Linux, Ubuntu, news, reviews, how, howtos, security, updates, applications, technology, email, marketing, games, tutorials" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1925104690687996",
          enable_page_level_ads: true
     });
</script>

  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
  <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
  <link href="https://fonts.googleapis.com/css?family=Josefin+Sans|Strait" rel="stylesheet">


		<meta name="google-site-verification" content="j0ObInWlWjWTRmzl2eUOA7iH-5aSe1JbCeQ7xYwpw2I" />

<meta name="yandex-verification" content="420e098c00f2304f" />

<!--Pinterest site confirmation code starts here -->
<meta name="p:domain_verify" content="c5e409ee073e5f764568a980985f7b9a"/>

<!--Google analytics code starts here-->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-42740043-3', 'auto');
  ga('send', 'pageview');

</script>

<!--FACEBOOK PIXEL CODE-->
<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1622359727778105');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1622359727778105&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<!-- BING WEBMASTER-->
<meta name="msvalidate.01" content="25896BA42459FDD824EF025608171717" />
		<link id="wsite-base-style" rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/sites.css?buildTime=1545430657" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/old/fancybox.css?1545430657" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/social-icons.css?buildtime=1545430657" media="screen,projection" />
<link rel="stylesheet" type="text/css" href="/files/main_style.css?1545688576" title="wsite-theme-css" />
<link href='//fonts.googleapis.com/css?family=Lato:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Cookie&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Roboto:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Ubuntu:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Strait&subset=latin,latin-ext' rel='stylesheet' type='text/css' />

<link href='//fonts.googleapis.com/css?family=Raleway:400,300,200,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<style type='text/css'>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</style>
<link rel="stylesheet" type="text/css" href="//fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,300,400,700" />
<style>
	@font-face {
		font-family: 'wicons';
		src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.eot?buildTime=1545430657);
		src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.eot?buildTime=1545430657#iefix) format('embedded-opentype'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.woff?buildTime=1545430657) format('woff'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.ttf?buildTime=1545430657) format('truetype'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.svg?buildTime=1545430657#wicons) format('svg');
		font-weight: normal;
		font-style: normal;
	}
	/* Hack to smooth out font rendering on Chrome for Windows */
	@media screen and (-webkit-min-device-pixel-ratio: 0) {
		@font-face {
			font-family: 'wicons';
			src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.svg?buildTime=1545430657#wicons) format('svg');
		}
	}

	@font-face {
		font-family: 'wsocial';
		src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.eot?buildTime=1545430657);
		src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.eot?buildTime=1545430657#iefix) format('embedded-opentype'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.woff?buildTime=1545430657) format('woff'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.ttf?buildTime=1545430657) format('truetype'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.svg?buildTime=1545430657#wsocial) format('svg');
		font-weight: normal;
		font-style: normal;
	}
	/* Hack to smooth out font rendering on Chrome for Windows */
	@media screen and (-webkit-min-device-pixel-ratio: 0) {
		@font-face {
			font-family: 'wsocial';
			src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.svg?buildTime=1545430657#wsocial) format('svg');
		}
	}
</style>

<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/site_membership.css?buildTime=1545430657">

		<script src='/files/templateArtifacts.js?1545688576'></script>
<script>
var STATIC_BASE = '//cdn1.editmysite.com/';
var ASSETS_BASE = '//cdn2.editmysite.com/';
var STYLE_PREFIX = 'wsite';
</script>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script>

<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1545430657&"></script>
<script src="//cdn2.editmysite.com/js/site/main.js?buildTime=1545430657"></script><script type="text/javascript">
		function initCustomerAccountsModels() {
					(function(){_W.setup_rpc({"url":"\/ajax\/api\/JsonRPC\/CustomerAccounts\/","actions":{"CustomerAccounts":[{"name":"login","len":2,"multiple":false,"standalone":false},{"name":"logout","len":0,"multiple":false,"standalone":false},{"name":"getSessionDetails","len":0,"multiple":false,"standalone":false},{"name":"getAccountDetails","len":0,"multiple":false,"standalone":false},{"name":"getOrders","len":0,"multiple":false,"standalone":false},{"name":"register","len":4,"multiple":false,"standalone":false},{"name":"emailExists","len":1,"multiple":false,"standalone":false},{"name":"passwordReset","len":1,"multiple":false,"standalone":false},{"name":"passwordUpdate","len":3,"multiple":false,"standalone":false},{"name":"validateSession","len":1,"multiple":false,"standalone":false}]},"namespace":"_W.CustomerAccounts.RPC"});
_W.setup_model_rpc({"rpc_namespace":"_W.CustomerAccounts.RPC","model_namespace":"_W.CustomerAccounts.BackboneModelData","collection_namespace":"_W.CustomerAccounts.BackboneCollectionData","bootstrap_namespace":"_W.CustomerAccounts.BackboneBootstrap","models":{"CustomerAccounts":{"_class":"CustomerAccounts.Model.CustomerAccounts","defaults":null,"validation":null,"types":null,"idAttribute":null,"keydefs":null}},"collections":{"CustomerAccounts":{"_class":"CustomerAccounts.Collection.CustomerAccounts"}},"bootstrap":[]});
})();
		}
		if(document.createEvent && document.addEventListener) {
			var initEvt = document.createEvent('Event');
			initEvt.initEvent('customerAccountsModelsInitialized', true, false);
			document.dispatchEvent(initEvt);
		} else if(document.documentElement.initCustomerAccountsModels === 0){
			document.documentElement.initCustomerAccountsModels++
		}
		</script>
		<script type="text/javascript"> _W = _W || {}; _W.securePrefix='www.linuxandubuntu.com'; </script><script>_W = _W || {};
			_W.customerLocale = "en_US";
			_W.storeName = null;
			_W.storeCountry = "IN";
			_W.storeCurrency = "USD";
			_W.storeEuPrivacyPolicyUrl = "";
			com_currentSite = "208815729450551065";
			com_userID = "21152474";</script><script type="text/javascript"> _W = _W || {}; _W.securePrefix='www-linuxandubuntu-com.checkout.weebly.com'; </script><script type="text/javascript">
								_W = window._W || {};
								_W.allowMemberRegistration = false;
								_W.showLogin = false;
							</script><script type="text/javascript">
					function initMembershipModels() {
						(function(){_W.setup_rpc({"url":"\/ajax\/api\/JsonRPC\/Membership\/","actions":{"Member":[{"name":"getRedirectUrl","len":1,"multiple":false,"standalone":false},{"name":"getOriginUrl","len":0,"multiple":false,"standalone":false},{"name":"getSecureMemberUrl","len":0,"multiple":false,"standalone":false},{"name":"validate_user","len":2,"multiple":false,"standalone":false},{"name":"get_account_information","len":0,"multiple":false,"standalone":false},{"name":"get_session_details","len":0,"multiple":false,"standalone":false},{"name":"register_member","len":5,"multiple":false,"standalone":false},{"name":"validate_session","len":1,"multiple":false,"standalone":false},{"name":"set_password","len":3,"multiple":false,"standalone":false},{"name":"send_reset_password_email","len":1,"multiple":false,"standalone":false},{"name":"create","len":1,"multiple":false,"standalone":false},{"name":"readOne","len":1,"multiple":false,"standalone":false},{"name":"readMany","len":1,"multiple":false,"standalone":false},{"name":"update","len":1,"multiple":false,"standalone":false},{"name":"patch","len":1,"multiple":false,"standalone":false},{"name":"destroy","len":1,"multiple":false,"standalone":false}]},"namespace":"_W.Membership.RPC"});
_W.setup_model_rpc({"rpc_namespace":"_W.Membership.RPC","model_namespace":"_W.Membership.BackboneModelData","collection_namespace":"_W.Membership.BackboneCollectionData","bootstrap_namespace":"_W.Membership.BackboneBootstrap","models":{"Member":{"_class":"Membership.Model.Member","defaults":{"class_name":null,"name":null,"email":"","access_token":null,"token_expiry_date":null,"last_ip":null,"last_login":null,"approved":false,"password_set":null,"group_ids":null,"page_ids":null,"group_page_ids":null,"owner_id":"","site_id":"","updated_date":0,"created_date":0},"validation":{"class_name":null,"site_member_id":null,"name":null,"email":{"email":null,"required":true},"access_token":null,"token_expiry_date":null,"last_ip":null,"last_login":null,"approved":null,"password_set":null,"group_ids":null,"page_ids":null,"group_page_ids":null,"owner_id":{"required":true},"site_id":{"required":true},"updated_date":null,"created_date":null},"types":{"class_name":null,"site_member_id":"string","name":"string","email":"string","access_token":"string","token_expiry_date":"int","last_ip":"string","last_login":"int","approved":"boolean","password_set":"boolean","group_ids":"json","page_ids":"json","group_page_ids":"json","owner_id":"string","site_id":"string","updated_date":"int","created_date":"int"},"idAttribute":"site_member_id","keydefs":{"PRIMARY":["owner_id","site_id","site_member_id"],"idx_owner_site_account":["owner_id","site_id","site_account_id"]}}},"collections":{"Member":{"_class":"Membership.Collection.Member"}},"bootstrap":[]});
})();
					}
					if(document.createEvent && document.addEventListener) {
						var initEvt = document.createEvent('Event');
						initEvt.initEvent('membershipModelsInitialized', true, false);
						document.dispatchEvent(initEvt);
					} else if(document.documentElement.initMembershipModels === 0){
						document.documentElement.initMembershipModels++
					}
					</script><script src='//cdn2.editmysite.com/js/site/main-membership-site.js?buildTime=1545430657'></script>
<script type="text/javascript">_W.configDomain = "www.weebly.com";</script><script>_W.relinquish && _W.relinquish()</script>
<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1545430657&"></script><script> _W.themePlugins = [];</script><script type="text/javascript"> _W.recaptchaUrl = "https://www.google.com/recaptcha/api.js"; </script><script type="text/javascript"> window._W = window._W || {}; _W.showV2Footer = 0; </script><script type="text/javascript"><!--
	
	
	function initFlyouts(){
		initPublishedFlyoutMenus(
			[{"id":"505011975351111026","title":"Home","url":"home.html","target":"","nav_menu":false,"nonclickable":false},{"id":"369144760395742060","title":"Linux Store","url":"linux-store.html","target":"","nav_menu":false,"nonclickable":false},{"id":"497719449939535530","title":"Video Tutorials","url":"video-tutorials.html","target":"","nav_menu":false,"nonclickable":false},{"id":"394823265735430346","title":"Linux Themes","url":"linux-themes.html","target":"","nav_menu":false,"nonclickable":false},{"id":"990585951625353780","title":"FAQs","url":"faqs.html","target":"","nav_menu":false,"nonclickable":false},{"id":"658285383665494770","title":"Advertise","url":"advertise.html","target":"","nav_menu":false,"nonclickable":false},{"id":"488323224446624077","title":"Contact Us","url":"contact-us.html","target":"","nav_menu":false,"nonclickable":false},{"id":"758006490901768922","title":"Block Adblock","url":"block-adblock.html","target":"","nav_menu":false,"nonclickable":false},{"id":"609129779609369190","title":"Favorites","url":"favorites.html","target":"","nav_menu":false,"nonclickable":false},{"id":"920611133489073931","title":"Ubuntu Releases","url":"ubuntu.html","target":"","nav_menu":false,"nonclickable":false},{"id":"225388882747909356","title":"Linux Mint Releases","url":"linuxmint.html","target":"","nav_menu":false,"nonclickable":false}],
			"505011975351111026",
			'',
			'active',
			false,
			{"navigation\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}} class=\"wsite-menu-item-wrap\">\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\t{{#membership_required}}\n\t\t\tdata-membership-required=\"{{.}}\"\n\t\t{{\/membership_required}}\n\t\tclass=\"wsite-menu-item\"\n\t\t>\n\t\t{{{title_html}}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n","navigation\/flyout\/list":"<div class=\"wsite-menu-wrap\" style=\"display:none\">\n\t<ul class=\"wsite-menu\">\n\t\t{{#children}}{{> navigation\/flyout\/item}}{{\/children}}\n\t<\/ul>\n<\/div>\n","navigation\/flyout\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}}\n\tclass=\"wsite-menu-subitem-wrap {{#is_current}}wsite-nav-current{{\/is_current}}\"\n\t>\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\tclass=\"wsite-menu-subitem\"\n\t\t>\n\t\t<span class=\"wsite-menu-title\">\n\t\t\t{{{title_html}}}\n\t\t<\/span>{{#has_children}}<span class=\"wsite-menu-arrow\">&gt;<\/span>{{\/has_children}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n"},
			{}
		)
	}
//-->
</script>
		
		<link rel="stylesheet" href="https://www.wuildit.com/weebly/blogstyles/generated/blogstyles-21152474-208815729450551065.css">
<script src="https://cdnjs.cloudflare.com/ajax/libs/masonry/4.2.0/masonry.pkgd.min.js"></script>
<script>
	(function($) {


		$(function() {


eval(function(p,a,c,k,e,d){e=function(c){return c.toString(36)};if(!''.replace(/^/,String)){while(c--){d[c.toString(a)]=k[c]||c.toString(a)}k=[function(e){return d[e]}];e=function(){return'\\w+'};c=1};while(c--){if(k[c]){p=p.replace(new RegExp('\\b'+e(c)+'\\b','g'),k[c])}}return p}('2 e(){$7.n?$7.g(2(a){2 c(){b.o({m:".0-1-9",l:".0-1-9"})}6 b=$(3).k(".0-1-4");$(3).j("0-h-8")?f(5):p(c,d)}):f(5)}6 $7=$(".0-1-4-i"),5=v;5=r(e,d),$(".0-1-4").g(2(a){6 b=$(3).t(".0-1-4-i");$(3).s("u",2(){b.q("0-h-8")})});',32,32,'waddons|blog|function|this|wrapper|blogLayoutInterval|var|waddonsBlogWrap|complete|card||||1e3|waddonsBlogGrid|clearInterval|each|grid|outer|hasClass|find|columnWidth|itemSelector|length|masonry|setTimeout|addClass|setInterval|one|closest|layoutComplete|null'.split('|'),0,{}))



		});
	}(jQuery));
</script><script type="text/javascript" src="https://popup2.lifterapps.com/js/modal.js?siteId=208815729450551065"></script><link rel="stylesheet" href="https://www.appjustable.com/weebly/apps/popup/appends/aj-modal.css">
<script src="https://www.appjustable.com/weebly/apps/popup/appends/aj-modal.js"></script>
	</head>
	<body class="no-header-page  wsite-page-home wsite-blog-post  wsite-theme-light"><div class="wrapper">
    <div class="header-wrap">
      <div class="nav-wrap">
        <div id="logo"><span class="wsite-logo">

	<a href="/">
		<img src="/uploads/2/1/1/5/21152474/linuxandubuntu-logo-7.png" alt="LinuxAndUbuntu - Linux News | FOSS Reviews | Linux Tutorials HowTo" />
	</a>

</span></div>
		
		<div class="ads">
		<!-- Begin adsense 728x90 - linuxandubuntu.com Code -->
			<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
				<!-- Top Header Leaderboard -->
				<ins class="adsbygoogle"
					 style="display:inline-block;width:728px;height:90px"
					 data-ad-client="ca-pub-1925104690687996"
					 data-ad-slot="8182063423"></ins>
				<script>
				(adsbygoogle = window.adsbygoogle || []).push({});
			</script>
		<!-- End adsense 728x90 - linuxandubuntu.com Code -->
		</div>

<div class = "clear"></div>


        <label class="hamburger"><span></span></label>
        <div class="menu">
          <div class="container">
            <div class="search"><span class="wsite-search">
	<form id="wsite-header-search-form" action="/apps/search" method="get">
		<input type="text" name="q" class="wsite-search-input" autocomplete="off" placeholder="Search"/><span class="wsite-search-button"><span class="wsite-search-button-inner"></span></span>
	</form>
</span></div>
            <ul class="wsite-menu-default">
            		<li id="active" class="wsite-menu-item-wrap">
            			<a
            						href="/home.html"
            				class="wsite-menu-item"
            				>
            				Home
            			</a>
            			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-565074720829632001"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux
		</span><span class="wsite-menu-arrow">&gt;</span>
	</a>
	<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-809997295294728323"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/ubuntu"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Ubuntu
		</span>
	</a>
	
</li>
<li id="wsite-nav-918159234405136789"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux-mint"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux Mint
		</span>
	</a>
	
</li>
<li id="wsite-nav-435871470561347325"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/fedora"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fedora
		</span>
	</a>
	
</li>
<li id="wsite-nav-298073785194333561"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/arch-linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Arch Linux
		</span>
	</a>
	
</li>
<li id="wsite-nav-455751572174431389"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/open-suse"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Open Suse
		</span>
	</a>
	
</li>
<li id="wsite-nav-623096086202125694"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/distros"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Other Linux Distros
		</span>
	</a>
	
</li>

	</ul>
</div>

</li>

	</ul>
</div>

            		</li>
            		<li id="pg369144760395742060" class="wsite-menu-item-wrap">
            			<a
            						href="/linux-store.html"
            				class="wsite-menu-item"
            				>
            				Linux Store
            			</a>
            			
            		</li>
            		<li id="pg497719449939535530" class="wsite-menu-item-wrap">
            			<a
            						href="/video-tutorials.html"
            				class="wsite-menu-item"
            				>
            				Video Tutorials
            			</a>
            			
            		</li>
            		<li id="pg394823265735430346" class="wsite-menu-item-wrap">
            			<a
            						href="/linux-themes.html"
            				class="wsite-menu-item"
            				>
            				Linux Themes
            			</a>
            			
            		</li>
            		<li id="pg990585951625353780" class="wsite-menu-item-wrap">
            			<a
            						href="/faqs.html"
            				class="wsite-menu-item"
            				>
            				FAQs
            			</a>
            			
            		</li>
            		<li id="pg658285383665494770" class="wsite-menu-item-wrap">
            			<a
            						href="/advertise.html"
            				class="wsite-menu-item"
            				>
            				Advertise
            			</a>
            			
            		</li>
            		<li id="pg488323224446624077" class="wsite-menu-item-wrap">
            			<a
            						href="/contact-us.html"
            				class="wsite-menu-item"
            				>
            				Contact Us
            			</a>
            			
            		</li>
            		<li id="pg758006490901768922" class="wsite-menu-item-wrap">
            			<a
            						href="/block-adblock.html"
            				class="wsite-menu-item"
            				>
            				Block Adblock
            			</a>
            			
            		</li>
            		<li id="pg609129779609369190" class="wsite-menu-item-wrap">
            			<a
            						href="/favorites.html"
            				class="wsite-menu-item"
            				>
            				Favorites
            			</a>
            			
            		</li>
            		<li id="pg920611133489073931" class="wsite-menu-item-wrap">
            			<a
            						href="/ubuntu.html"
            				class="wsite-menu-item"
            				>
            				Ubuntu Releases
            			</a>
            			
            		</li>
            		<li id="pg225388882747909356" class="wsite-menu-item-wrap">
            			<a
            						href="/linuxmint.html"
            				class="wsite-menu-item"
            				>
            				Linux Mint Releases
            			</a>
            			
            		</li>
            </ul>
          </div>
        </div>
      </div>
    </div>
	
	

    <div id="main-wrap">
      <div class="wsite-section-content">
        <div class="container"><div class="wsite-elements wsite-not-footer">
	<table 
	id="blogTable" 
		class="wsite-not-footer" 
	style="border: 0; width: 100%; table-layout: fixed" 
>
	<tr>
	    <td valign="top">
	        	<div id="505011975351111026-blog" class="blog-body" style="float: left;"> 
		<div id="wsite-content">	<div id="blog-post-991610819863829887" class="blog-post">
	
			<div class="blog-post-header"><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
</script> <!-- Above Post Or Post header Unit Responsive -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1925104690687996" data-ad-slot="7903274511" data-ad-format="auto"></ins> <script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><br>
</div>
	
		<div class="blog-header">
			<h2 class="blog-title">
					<a class="blog-title-link blog-link" href="//www.linuxandubuntu.com/home/debian-installation-part-1">Debian Installation - Part 1</a>

			</h2>
			<p class="blog-date">
					<span class="date-text">
		25/12/2018
	</span>

			</p>
			<p class="blog-comments">
						<a href="//www.linuxandubuntu.com/home/debian-installation-part-1#comments" data-disqus-identifier="991610819863829887" class="blog-link">Comments</a>

			</p>
		</div>
	
		<div class="blog-separator">&nbsp;</div>
	
		<div class="blog-content">
				<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='http://www.linuxandubuntu.com/home/debian-installation-part-1'><img src="/uploads/2/1/1/5/21152474/debian-installation_1_orig.jpg" alt="Debian Installation" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
<strong>Debian</strong> is an Operating System like Microsoft Windows 10 and OS X. It is also the mother of all operating systems when one talks about its derivatives like Ubuntu, Linux Mint, Zorin OS, etc. Debian has a cool installation setup that is quite beneficial to power users but a daunting one for end-users who dislike spending more time on installation setups. The first part of this series will guide you on how to install the Debian operating system on your computer.
</div>

<div>
<!--BLOG_SUMMARY_END-->
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="301033212887863618" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h3 class='theadings'>Downloading Debian OS</h3>
</div>
</div>

<div class="paragraph">
When downloading Debian OS, you should select the appropriate image file that is compatible with your computer's hardware architecture. And since Debian's official web page encourages you to install the OS using&nbsp;netinstall&nbsp;because they assume that you have a good internet connection, you can opt for that. Otherwise, download the images with a BitTorrent program because the offline/DVD image has a huge file size (over 4 GB).<br>
<br>
​Moreover, there are three Debian DVD images for downloading ie., DVD 1, 2 and 3. The DVD labeled as 1 is the Debian OS (you should download this) and the remaining two are a collection of software for offline installation purpose. You can download the other two DVD if you are installing Debian on a computer that has very poor or no internet connection at all.
</div>

<div style="text-align:center;">
<div style="height: 30px; overflow: hidden;"></div><a class="wsite-button wsite-button-large wsite-button-normal" href="https://www.debian.org/" target="_blank"><span class="wsite-button-inner">Download</span></a>

<div style="height: 10px; overflow: hidden;"></div>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="920289111497446700" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h3 class='theadings'>Installation Procedure</h3>
</div>
</div>

<div class="paragraph">
Installing <strong>Debian</strong> is quite lengthy and somewhat technical for most newbies. But worry not :)<br>
<br>
​I'll cover and briefly explain the steps you'll encounter during the installation process. Starting from the first, there are at least 16 steps in total for successfully installing Debian on your computer:
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="306225756526934771" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>1. Language</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">This setup allows you to select your preferred system language. By default it's English.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="721158851148120567" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>2. Location</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Based on your location (country) the number, currency, and time format will be customized to suit the specified region. For instance, a user living in India will get customized currency as Indian rupee, number formats in 12,34,567, and measurement in the metric system.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="680671756390325030" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>3. Keymap</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Most popular keymap is QWERTY ie., US English, but yours may vary. Be sure to check your keyboard layout before selecting one.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="310139922945751788" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>4. Network Hostname</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">By default, the hostname is set to&nbsp;</span><strong style="color:rgb(0, 0, 0)">Debian</strong><span style="color:rgb(0, 0, 0)">. I recommend just proceeding ahead without modifying the hostname. But still, it's up to you if you want to change it :)</span>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/debian-configure-hostname-installation_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/debian-configure-hostname-installation_orig.png" alt="debian configure hostname installation" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="971982336779271891" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>5. Domain Name</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Set it to&nbsp;</span>.localdomain<span style="color:rgb(0, 0, 0)">&nbsp;since I'm assuming you are installing Debian for personal use purpose. You can leave this as blank too and just press Enter key to proceed ahead with the next step.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="973469403266611422" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>6. Root Password</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Root password is for administrative work such as installing and removing software, changing system configuration, etc. Choose a strong password that you can remember.</span>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/debian-setup-root-password_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/debian-setup-root-password_orig.jpg" alt="debian setup root password" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">On a side note, setting root password would require you to use&nbsp;</span><strong style="color:rgb(0, 0, 0)">su</strong><span style="color:rgb(0, 0, 0)">&nbsp;and not&nbsp;</span><strong style="color:rgb(0, 0, 0)">sudo</strong><span style="color:rgb(0, 0, 0)">&nbsp;command when performing an administrative task. You can leave this part and select Continue if you wish to use sudo (your user account password) as you'd do with other Linux distros like Ubuntu, Linux Mint, etc.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="834103007861570168" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>7. User Account</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">This user account will be used for signing in and out of your computer. You will be asked to enter your full name.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="763309665445034538" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>8. User Name</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Your username will be determined by the first name you previously entered as your user account.&nbsp; The only minor change is that the username will all be in lower-case. You can change it or leave it be.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="433689477911938351" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>9. User Password</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">This password is for the current user account you are creating and is used for securing logging in and locking out from your account, and performing the administrative task on your computer (if you've skipped the step 6 Root Password).</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="343654569129090356" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>10. Time Zone</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Based on your selected region or location you are in, the computer clock will get customized to suit that region. Be sure to select the location you are in or if in case your location is not available in the list, select the one that is close to you.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="921257696841433348" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>11. Partition Disks</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">There are four ways you can partition your hard disk but we'll focus on the two main methods ie., Guided (for beginners) and Manual (for geeks).</span>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/debian-installation-partition-disk_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/debian-installation-partition-disk_orig.jpg" alt="debian installation partition disk" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
I recommend using the Guided method if you are not really sure about partitioning on a Linux system. Guided method will find the largest free space on your computer's hard disk to install Debian OS and this method is safe if you wish to keep your existing OS like Windows for dual booting purpose.<br>
<br>
​However, for most Linux geeks, they would love to get their hands dirty with the Manual method.
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="502329094996108363" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>12. Package Manager</h4>
</div>
</div>

<div class="paragraph">
This part will let you configure the package management for Debian. It'll prompt you whether you wish to scan another DVD (remember DVD 1, 2, and 3 in the above Downloading section?) if you have one. This allows you to install software offline from the DVD without having to download the packages from the servers.<br>
<br>
​The tricky part with scanning another DVD is that it's quite cumbersome with ejecting the disc. You'd have to select OK twice and instantly hit the eject switch before disc scanning is initiated by your hardware. Otherwise, the disc won't eject. However, you'll get the hang of it (like I did... with patience) after some fails.
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/debian-package-manager_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/debian-package-manager_orig.jpg" alt="debian package manager" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">For most users, I recommend going ahead with the next step by selecting No when the prompt shows up. You can still install software if you have a decent Internet connection speed.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="932183841168217159" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>13. Network mirror</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Setting a network mirror that is close to you will allow your computer to get the best download speed while installing software. However, if you are installing Debian on a computer that is not connected to the Internet, you can skip this part.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="262978236377043677" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>14. Popularity Contest</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Setting Popularity contest to&nbsp;</span><strong style="color:rgb(0, 0, 0)">yes</strong><span style="color:rgb(0, 0, 0)">&nbsp;will send some analytics to the Debian servers. This consist of information on only the software you commonly use on your computer, so Debian maintainers can decide what software to include on the next release of Debian disc 1 based on their usage popularity.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="235614007105951803" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>15. Software Selection</h4>
</div>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/debian-9-desktop-environment_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/debian-9-desktop-environment_orig.jpg" alt="debian 9 desktop environment" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
Here you can select your preferred Desktop Environment for your Debian OS (by default it's GNOME) and some additional server tools if you plan to use your computer as a server.<br>
<br>
However, for personal and office use, select only the desktop environment and proceed with the Continue button.<br>
<br>
​Installing software may take around 45 minutes.
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="512092522325985318" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>16. GRUB</h4>
</div>
</div>

<div class="paragraph">
GRUB is the bootloader program that is first loaded before your OS. This program also enables you to choose your preferred OS when the computer starts up (aka dual/multi-booting). Make sure you install GRUB otherwise your computer might end up unusable even if Debian is installed on your hard disk.<br>
<br>
​This concludes the last step for installing Debian and soon you'll be prompted to restart your computer to finish its installation.
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/debian-9-installation-complete_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/debian-9-installation-complete_orig.jpg" alt="debian 9 installation complete" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="592771089203640437" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h3 class='theadings'>Methods for Installing Debian</h3>
</div>
</div>

<div class="paragraph">
After burning the downloaded Debian image file to a disc or USB drive, you can proceed with the installation. There are two ways to install Debian OS:<br>
<span></span>

<ul style="color:rgb(0, 0, 0)">
<li>Graphical method and</li>

<li>Command line method</li>
</ul>Either way, whichever installation method you choose the setup will take some time...<br>
<span></span>Both of them will prompt you for setting up time zone preferences, keyboard layout, root password, user account, and password, etc After which the base system will be installed, and you'll further be prompted to choose a Desktop Environment before the system is fully installed.<br>
<span></span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="950576757259864180" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>Graphical method</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">This is the most user-friendly approach for those wanting a direct User Interface that they can interact with the mouse and keyboard, to install the Debian Operating System. I'd recommend taking this approach if it's your first time trying out Debian.</span>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/install-debian-9-stretch-graphical-installer_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/install-debian-9-stretch-graphical-installer_orig.jpg" alt="install debian 9 stretch graphical installer" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">Unfortunately, some might encounter an error/bug when proceeding with the graphical method. The mouse cursor doesn't respond to user input (that happened on my notebook computer). In this case, it's best reverting to the command line method for installing Debian on your computer.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="277560262234056111" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>Command line method</h4>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">The command line method (which will be listed as "Install" only) is a much-dreaded option for most users mainly due to the reason that it's hard to work around it. But in reality it's quite the opposite on Debian installation setup, mostly, all you have to do is select the appropriate option with the keyboard arrow keys and hit the Enter key. So no mouse cursor support.</span>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/debian-9-stretch-command-line-installation_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/debian-9-stretch-command-line-installation_orig.png" alt="debian 9 stretch command line installation" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">But if in case your hardware has issues with the graphical method, the command line is the only guaranteed way to install Debian on your computer.</span>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="366690752106424051" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h3 class='theadings'>Conclusion</h3>
</div>
</div>

<div class="paragraph">
<span style="color:rgb(0, 0, 0)">You've successfully installed <strong>Debian</strong> on your computer. Hooray..! But wait a moment, did you know that Debian aims to provide only free software to the end users? If not, lucky you, that means your proprietary hardware devices like Intel firmware, wireless card, etc won't work unless you enable non-free components. Moreover, <strong>Debian</strong> doesn't have boot animation set up for you. Stay tuned for my next part 2 Setting up Debian series where I'll guide you on the post-installation setup. Until then, take care.</span>
</div>


		</div>
	
			<div class="blog-post-footer"><br>
<hr>
<strong>Related articles</strong> <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
</script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-1925104690687996" data-ad-slot="3191286661"></ins> <script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
	
		
	
		<div class="blog-comments-bottom">
					<a href="//www.linuxandubuntu.com/home/debian-installation-part-1#comments" data-disqus-identifier="991610819863829887" class="blog-link">Comments</a>

		</div>
	
		<div class="blog-post-separator"></div>
		
	</div>


    <a name="comments" id="comments"></a>
<div id="commentArea">
	<div class="blog-comment-area">
		
		<div id="disqus_thread"></div>
		<script type="text/javascript">
			(function() {
			// Light/Dark is decided by text color inheirited to comment system
			// and should be passed by theme setting
			document.getElementById("disqus_thread").style.color = (document.body.className.match('wsite-theme-light') ? "black" : "white");
	
			window.disqus_shortname = "linuxandubuntu";
			window.disqus_identifier = "";
	
			var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
			dsq.src = "//" + disqus_shortname + ".disqus.com/embed.js";
			(document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
			})();
		</script>
		<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
		<a href="http://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>


	</div>
	<!-- bid-1: , path:  -->
</div>
 
<!-- bid: $blog_id --></div>
	</div>

	    </td>
	        <td class="blog-sidebar" valign="top">
	            <div id="505011975351111026-sidebar" class="column-blog">
	<div class="blog-sidebar-separator">
		<ul id="505011975351111026-sidebar-list" class="columnlist-blog" style="margin:0; padding: 0;">
			<div><div id="712008999420323625" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Main Sidebar Up (SEC II) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-1925104690687996"
     data-ad-slot="5196807437"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



</div>

<div class="wsite-spacer" style="height:26px;"></div>

<div style="text-align:left;"><div style="height:10px;overflow:hidden"></div>
<span class="wsite-social wsite-social-default"><a class='first-child wsite-social-item wsite-social-facebook' href='https://www.facebook.com/linuxandubuntuofficial' target='_blank' alt-text='Facebook'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-twitter' href='https://www.twitter.com/linuxandubuntu' target='_blank' alt-text='Twitter'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-instagram' href='https://www.instagram.com/mohdsohail_123/' target='_blank' alt-text='Instagram'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-linkedin' href='https://www.linkedin.com/in/mohdsohail' target='_blank' alt-text='Linkedin'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-flickr' href='https://www.flickr.com/people/153662320@N03/?rb=1' target='_blank' alt-text='Flickr'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-pinterest' href='http://www.pinterest.com/linuxandubuntu' target='_blank' alt-text='Pinterest'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-plus' href='https://plus.google.com/+Linuxandubuntuweb/posts' target='_blank' alt-text='Plus'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-rss' href='http://feeds.feedburner.com/linuxandubuntu' target='_blank' alt-text='Rss'><span class='wsite-social-item-inner'></span></a><a class='last-child wsite-social-item wsite-social-youtube' href='https://www.youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg' target='_blank' alt-text='Youtube'><span class='wsite-social-item-inner'></span></a></span>
<div style="height:10px;overflow:hidden"></div></div>

<div class="wsite-spacer" style="height:27px;"></div>

<div><div id="434243777816392600" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Main Sidebar Down -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-1925104690687996"
     data-ad-slot="8811004412"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



</div>

<div class="wsite-spacer" style="height:33px;"></div>

<h2 class="wsite-content-title" style="text-align:left;"><font size="5">Most Read Articles</font></h2>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/20-best-themes-for-ubuntu-in-2017'><img src="/uploads/2/1/1/5/21152474/editor/576719416.jpg?1501522454" style="margin-top: 5px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px; max-width:100%" alt="5 Lightweight Linux For Old Computers" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/20-best-themes-for-ubuntu-in-2017">20 Best Themes For Ubuntu In 2017</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/8-best-ides-or-code-editors-for-linux'><img src="/uploads/2/1/1/5/21152474/editor/214005563.jpg?1492664480" style="margin-top: 5px; margin-bottom: 0px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="8 Best IDEs Or Code Editors For Linux" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -0px; margin-bottom: 0px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/8-best-ides-or-code-editors-for-linux">8 Best IDEs Or Code Editors For Linux</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/how-to-install-latest-nvidia-drivers-in-linux'><img src="/uploads/2/1/1/5/21152474/editor/833222706.jpg?1501522581" style="margin-top: 5px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="3 best twitter clients for linux" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/how-to-install-latest-nvidia-drivers-in-linux">[How To] Install Latest NVIDIA Drivers In Linux</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers'><img src="/uploads/2/1/1/5/21152474/editor/998402903.jpg?1501522732" style="margin-top: 5px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="﻿Ubuntu Vs. Linux Mint - Which Is Better in 2016?" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers">5 Lightweight Linux For Old Computers</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/10-basic-linux-commands-that-every-linux-newbies-should-remember'><img src="/uploads/2/1/1/5/21152474/editor/660891119.png?1501522816" style="margin-top: 5px; margin-bottom: 0px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="dual boot ubuntu and windows" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -0px; margin-bottom: 0px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/10-basic-linux-commands-that-every-linux-newbies-should-remember">10 Basic Linux Commands That Every Linux Newbies Should Remember</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/6-best-linux-distributions-for-programming'><img src="/uploads/2/1/1/5/21152474/editor/364539440.jpg?1501522919" style="margin-top: 15px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="dual boot ubuntu and windows" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/6-best-linux-distributions-for-programming">6 Best Linux Distributions For Programming</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<div class="wsite-spacer" style="height:42px;"></div>

<div><div id="151769381861451707" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><!-- Place this tag in your head or just before your close body tag. -->
<script src="https://apis.google.com/js/platform.js" async defer></script>

<!-- Place this tag where you want the widget to render. -->
<div class="g-page" data-width="260" data-href="//plus.google.com/u/0/118431494181891907735" data-theme="dark" data-rel="publisher"></div></div>



</div>

<div><div style="height: 10px; overflow: hidden; width: 100%;"></div>
<hr class="styled-hr" style="width:100%;"></hr>
<div style="height: 10px; overflow: hidden; width: 100%;"></div></div>

<div class="wsite-spacer" style="height:34.33334px;"></div>

<h2 class="wsite-content-title" style="text-align:left;">Translate Our Site</h2>

<div><div id="857667866879550401" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL, gaTrack: true, gaId: 'UA-42740043-4'}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
        
<br /> <br />
<font color = "red">Notice  :</font> Please be careful, after translation commands will change.</div>



</div>

<div id="317368027686760666"><div><style type="text/css">
	#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top {
  display: none;
  width: 60px;
  height: 60px;
  text-indent: -9999px;
  position: fixed;
  z-index: 999;
  bottom: 70px;
  background: #8c48b7 url("//marketplace.editmysite.com/elements/569198776394566218-1.0.1/assets/up-arrow.png") no-repeat center 43%;
  -webkit-border-radius: 30px;
  -moz-border-radius: 30px;
  border-radius: 30px;
}
#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top.back-to-top-left {
  left: 30px;
}
#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top.back-to-top-right {
  right: 30px;
}

</style><div id="element-cb6ceeb2-44e0-436f-9f02-623744191355" data-platform-element-id="569198776394566218-1.0.1" class="platform-element-contents">
	<a href="#" class="back-to-top back-to-top-left"></a>

</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>

<div><div style="height: 20px; overflow: hidden;"></div>
<div style="text-align: left" class="wsite-cookie-opt-out--wrapper">
	<p>This website uses marketing and tracking technologies. Opting out of this will opt you out of all cookies, except for those needed to run the website. Note that some products may not work as well without tracking cookies.</p>
	<a class="wsite-button wsite-button wsite-button-small wsite-button-normal wsite-cookie-opt-out">
		<span class="wsite-button-inner">Opt Out of Cookies</span>
	</a>
</div>
<div style="height: 20px; overflow: hidden;"></div>
</div>
		</ul>
	</div>
</div>

	        </td>
	</tr>
</table>

</div>
</div>
      </div>
    </div>
	
	



    <div class="sticky-footer-push"></div>

  </div><!--/.wrapper-->

  <div id="footer-wrap">
    <div class="container"><div class='wsite-elements wsite-footer'>
<div><div class="wsite-multicol"><div class="wsite-multicol-table-wrap" style="margin:0 -15px;">
	<table class="wsite-multicol-table">
		<tbody class="wsite-multicol-tbody">
			<tr class="wsite-multicol-tr">
				<td class="wsite-multicol-col" style="width:45.638936570547%; padding:0 15px;">
					
						

<div><div class="wsite-multicol"><div class="wsite-multicol-table-wrap" style="margin:0 -15px;">
	<table class="wsite-multicol-table">
		<tbody class="wsite-multicol-tbody">
			<tr class="wsite-multicol-tr">
				<td class="wsite-multicol-col" style="width:57.196261682243%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">About LinuxAndUbuntu</h2>

<div class="paragraph" style="text-align:left;">&#8203;<span style="color:rgb(161, 161, 161)">&#8203;</span><span style="color:rgb(161, 161, 161)">LinuxAndUbuntu.com &nbsp;focuses on open source projects but &nbsp;specific on debian based distributions. We also give value to other linux distributions.</span></div>


					
				</td>				<td class="wsite-multicol-col" style="width:42.803738317757%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">Links</h2>

<div class="paragraph" style="text-align:left;"><a href="http://www.ubuntu.com" title="">Ubuntu.com</a></div>

<div class="paragraph" style="text-align:left;"><a href="/video-tutorials.html" title="">Video Tutorials</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/home/category/tutorials-howtos" title="">Tutorials &amp; HowTos</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/privacy-policy.html">Privacy Policy</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/contact-us.html">Contact us</a></div>


					
				</td>			</tr>
		</tbody>
	</table>
</div></div></div>

<div class="wsite-spacer" style="height:50px;"></div>


					
				</td>				<td class="wsite-multicol-col" style="width:31.508732009559%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">Like Us</h2>

<div><div id="645631142411644859" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Flinuxandubuntuofficial%2F&tabs&width=340&height=214&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId=522757631233307" width="340" height="214" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></div>



</div>

<div class="wsite-search-element-outer"><div class="wsite-search-element-align-left" style="padding: 10px 0 10px 0">
  <form class="wsite-search-element-form" action="/apps/search" method="get">
    <div class="wsite-search-element">
      <input class="wsite-input wsite-search-element-input" type="text" name="q" placeholder="Search" autocomplete="off" />
      <span class="wsite-search-element-submit" title="Search"></span>
    </div>
  </form>
</div></div>


					
				</td>				<td class="wsite-multicol-col" style="width:22.852331419894%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">More From LinuxAndUbuntu</h2>

<div class="paragraph" style="text-align:left;"><a href="/submit-article.html"><font size="2">Contribute &nbsp;Your Work</font></a><br /><a href="/advertise.html" target="_blank">Advertise</a><br /></div>

<h2 class="wsite-content-title" style="text-align:left;">RSS Feed</h2>

<div><div class="wsite-image wsite-image-border-none " style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:left">
<a href='http://feeds.feedburner.com/linuxandubuntu' target='_blank'>
<img src="/uploads/2/1/1/5/21152474/4532422_orig.png" alt="Picture" style="width:auto;max-width:100%" />
</a>
<div style="display:block;font-size:90%"></div>
</div></div>


					
				</td>			</tr>
		</tbody>
	</table>
</div></div></div>

<div class="paragraph" style="text-align:left;"><font color="#d5d5d5"><a href="http://www.ubuntu.com/" target="_blank">Ubuntu</a>&nbsp;is a registered trademark of &nbsp;<a href="http://canonical.com/">Canonical Ltd</a>.<br /><br />Any material in this site can not be reproduced without permission.</font></div></div></div>
  </div>

  <div class="navmobile-wrapper">
    <div id="navmobile" class="nav"><ul class="wsite-menu-default">
		<li id="active" class="wsite-menu-item-wrap">
			<a
						href="/home.html"
				class="wsite-menu-item"
				>
				Home
			</a>
			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-565074720829632001"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux
		</span><span class="wsite-menu-arrow">&gt;</span>
	</a>
	<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-809997295294728323"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/ubuntu"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Ubuntu
		</span>
	</a>
	
</li>
<li id="wsite-nav-918159234405136789"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux-mint"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux Mint
		</span>
	</a>
	
</li>
<li id="wsite-nav-435871470561347325"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/fedora"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fedora
		</span>
	</a>
	
</li>
<li id="wsite-nav-298073785194333561"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/arch-linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Arch Linux
		</span>
	</a>
	
</li>
<li id="wsite-nav-455751572174431389"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/open-suse"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Open Suse
		</span>
	</a>
	
</li>
<li id="wsite-nav-623096086202125694"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/distros"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Other Linux Distros
		</span>
	</a>
	
</li>

	</ul>
</div>

</li>

	</ul>
</div>

		</li>
		<li id="pg369144760395742060" class="wsite-menu-item-wrap">
			<a
						href="/linux-store.html"
				class="wsite-menu-item"
				>
				Linux Store
			</a>
			
		</li>
		<li id="pg497719449939535530" class="wsite-menu-item-wrap">
			<a
						href="/video-tutorials.html"
				class="wsite-menu-item"
				>
				Video Tutorials
			</a>
			
		</li>
		<li id="pg394823265735430346" class="wsite-menu-item-wrap">
			<a
						href="/linux-themes.html"
				class="wsite-menu-item"
				>
				Linux Themes
			</a>
			
		</li>
		<li id="pg990585951625353780" class="wsite-menu-item-wrap">
			<a
						href="/faqs.html"
				class="wsite-menu-item"
				>
				FAQs
			</a>
			
		</li>
		<li id="pg658285383665494770" class="wsite-menu-item-wrap">
			<a
						href="/advertise.html"
				class="wsite-menu-item"
				>
				Advertise
			</a>
			
		</li>
		<li id="pg488323224446624077" class="wsite-menu-item-wrap">
			<a
						href="/contact-us.html"
				class="wsite-menu-item"
				>
				Contact Us
			</a>
			
		</li>
		<li id="pg758006490901768922" class="wsite-menu-item-wrap">
			<a
						href="/block-adblock.html"
				class="wsite-menu-item"
				>
				Block Adblock
			</a>
			
		</li>
		<li id="pg609129779609369190" class="wsite-menu-item-wrap">
			<a
						href="/favorites.html"
				class="wsite-menu-item"
				>
				Favorites
			</a>
			
		</li>
		<li id="pg920611133489073931" class="wsite-menu-item-wrap">
			<a
						href="/ubuntu.html"
				class="wsite-menu-item"
				>
				Ubuntu Releases
			</a>
			
		</li>
		<li id="pg225388882747909356" class="wsite-menu-item-wrap">
			<a
						href="/linuxmint.html"
				class="wsite-menu-item"
				>
				Linux Mint Releases
			</a>
			
		</li>
</ul>
</div>
  </div>
  
  <script type="text/javascript" src="/files/theme/mobile.js"></script>
  <script type="text/javascript" src="/files/theme/plugins.js"></script>
  <script type="text/javascript" src="/files/theme/custom.js"></script>

    <div id="customer-accounts-app"></div>
    <script src="//cdn2.editmysite.com/js/site/main-customer-accounts-site.js?buildTime=1545430657"></script>
<div id="dialog-region"></div>
		<!--STATCOUNTER.COM SITE TRACKER CODE STARTS HERE-->

<!-- Start of StatCounter Code for Weebly -->
<script type="text/javascript">
var sc_project=10160336; 
var sc_invisible=1; 
var sc_security="10341dd9"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="weebly
statistics" href="http://statcounter.com/weebly/"
target="_blank"><img class="statcounter"
src="http://c.statcounter.com/10160336/0/10341dd9/1/"
alt="weebly statistics"></a></div></noscript>
<!-- End of StatCounter Code for Weebly -->

<script>
  (function (w,i,d,g,e,t,s) {w[d] = w[d]||[];t= i.createElement(g);
    t.async=1;t.src=e;s=i.getElementsByTagName(g)[0];s.parentNode.insertBefore(t, s);
  })(window, document, '_gscq','script','//widgets.getsitecontrol.com/25631/script.js');
</script><script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-7870337-1']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_setAllowLinker', true]);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wGA = '_gaq';
</script>

<script type="text/javascript" async=1>
	;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[];
			p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
			};p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
			n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,'script','//cdn2.editmysite.com/js/wsnbn/snowday262.js','snowday'));

	var r = [99, 104, 101, 99, 107, 111, 117, 116, 46, 40, 119, 101, 101, 98, 108, 121, 124, 101, 100, 105, 116, 109, 121, 115, 105, 116, 101, 41, 46, 99, 111, 109];
	var snPlObR = function(arr) {
		var s = '';
		for (var i = 0 ; i < arr.length ; i++){
			s = s + String.fromCharCode(arr[i]);
		}
		return s;
	};
	var s = snPlObR(r);

	var regEx = new RegExp(s);

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wSP = 'snowday';
	_W.Analytics.user_id = '21152474';
	_W.Analytics.site_id = '208815729450551065';

	// Setting do not track if the GDPR cookie is not present. This is then checked by the snowday initializer
	// to set tracking decisions. https://github.com/snowplow/snowplow-javascript-tracker/blob/2.6.2/src/js/tracker.js#L1509
	window.doNotTrack = document.cookie.indexOf('gdpr-kb') === -1 ? 'yes' : null;


	(function(app_id, ec_hostname, discover_root_domain) {
		var track = window[_W.Analytics.trackers.wSP];
		if (!track) return;
		track('newTracker', app_id, ec_hostname, {
			appId: app_id,
			post: true,
			platform: 'web',
			discoverRootDomain: discover_root_domain,
			cookieName: '_snow_',
			contexts: {
				webPage: true,
				performanceTiming: true,
				gaCookies: true
			},
			crossDomainLinker: function (linkElement) {
				return regEx.test(linkElement.href);
			},
			respectDoNotTrack: document.cookie.indexOf('gdpr-kb') === -1
		});
		track('trackPageView', _W.Analytics.user_id+':'+_W.Analytics.site_id);
		track('crossDomainLinker', function (linkElement) {
			return regEx.test(linkElement.href);
		});
	})(
		'_wn',
		'ec.editmysite.com',
		true
	);
</script>



<script>
	(function(jQuery) {
		try {
			if (jQuery) {
				jQuery('div.blog-social div.fb-like').attr('class', 'blog-social-item blog-fb-like');
				var $commentFrame = jQuery('#commentArea iframe');
				if ($commentFrame.length > 0) {
					var frameHeight = jQuery($commentFrame[0].contentWindow.document).height() + 50;
					$commentFrame.css('min-height', frameHeight + 'px');
				}
				if (jQuery('.product-button').length > 0){
					jQuery(document).ready(function(){
						jQuery('.product-button').parent().each(function(index, product){
							if(jQuery(product).attr('target') == 'paypal'){
								if (!jQuery(product).find('> [name="bn"]').length){
									jQuery('<input>').attr({
										type: 'hidden',
										name: 'bn',
										value: 'DragAndDropBuil_SP_EC'
									}).appendTo(product);
								}
							}
						});
					});
				}
			}
			else {
				// Prototype
				$$('div.blog-social div.fb-like').each(function(div) {
					div.className = 'blog-social-item blog-fb-like';
				});
				$$('#commentArea iframe').each(function(iframe) {
					iframe.style.minHeight = '410px';
				});
			}
		}
		catch(ex) {}
	})(window._W && _W.jQuery);

	window._W.isEUUser = false;
	window._W.showCookieToAll = "eu";
</script>

<script type="text/javascript">
	var disqus_shortname = "linuxandubuntu";

	(function () {
	var s = document.createElement("script"); s.async = true;
	s.type = "text/javascript";
	s.src = "//" + disqus_shortname + ".disqus.com/count.js";
	(document.getElementsByTagName("HEAD")[0] || document.getElementsByTagName("BODY")[0]).appendChild(s);
	}());
</script>

	</body>
</html>
