<!DOCTYPE html>
<html xmlns:fb="http://ogp.me/ns/fb#">
	<head>
		<title>Making Vim Even More Awesome With These Cool Features - LinuxAndUbuntu - Linux News | Apps Reviews | Linux Tutorials HowTo</title><meta property="og:site_name" content="LinuxAndUbuntu - Linux News | Apps Reviews | Linux Tutorials HowTo" />
<meta property="og:title" content="Making Vim Even More Awesome With These Cool Features" />
<meta property="og:description" content="​Vim is quite an integral part of Every Linux Distribution and the most useful tool (of course after the terminal) for Linux Users." />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/making-vim-even-more-awesome-with-these-cool-features_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/vim_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/vim_1_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/vim_2_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/vim_3_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/vim_4_orig.png" />
<meta property="og:image" content="https://www.facebook.com/tr?id=1622359727778105&ev=PageView&noscript=1" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/editor/576719416.jpg?1501522454" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/editor/214005563.jpg?1492664480" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/editor/833222706.jpg?1501522581" />
<meta property="og:url" content="http://www.linuxandubuntu.com/1/post/2017/12/making-vim-even-more-awesome-with-these-cool-features.html" />
<meta http-equiv='cache-control' content='no-cache' />
<meta property="description" content="​Vim is quite an integral part of Every Linux Distribution and the most useful tool (of course after the terminal) for Linux Users." />


<meta name="keywords" content="Linux, Ubuntu, news, reviews, how, howtos, security, updates, applications, technology, email, marketing, games, tutorials" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
  <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
  <link href="https://fonts.googleapis.com/css?family=Josefin+Sans|Strait" rel="stylesheet">
 

		<meta name="google-site-verification" content="j0ObInWlWjWTRmzl2eUOA7iH-5aSe1JbCeQ7xYwpw2I" />

<meta name="yandex-verification" content="420e098c00f2304f" />

<!--Pinterest site confirmation code starts here -->
<meta name="p:domain_verify" content="c5e409ee073e5f764568a980985f7b9a"/>

<!--Google analytics code starts here-->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-42740043-3', 'auto');
  ga('send', 'pageview');

</script>

<!--FACEBOOK PIXEL CODE-->
<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1622359727778105');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1622359727778105&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<!-- BING WEBMASTER-->
<meta name="msvalidate.01" content="25896BA42459FDD824EF025608171717" />
		<link id="wsite-base-style" rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/sites.css?buildTime=1513899303" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/old/fancybox.css?1513899303" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/social-icons.css?buildtime=1513899303" media="screen,projection" />
<link rel="stylesheet" type="text/css" href="/files/main_style.css?1514744905" title="wsite-theme-css" />
<link href='//fonts.googleapis.com/css?family=Lato:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Cookie&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Roboto:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Ubuntu:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Strait&subset=latin,latin-ext' rel='stylesheet' type='text/css' />

<link href='//fonts.googleapis.com/css?family=Raleway:400,300,200,700&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<style type='text/css'>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</style>
<link rel="stylesheet" type="text/css" href="//fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,300,400,700" />
<style>
	@font-face {
		font-family: 'wicons';
		src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.eot?buildTime=1513899303);
		src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.eot?buildTime=1513899303#iefix) format('embedded-opentype'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.woff?buildTime=1513899303) format('woff'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.ttf?buildTime=1513899303) format('truetype'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.svg?buildTime=1513899303#wicons) format('svg');
		font-weight: normal;
		font-style: normal;
	}
	/* Hack to smooth out font rendering on Chrome for Windows */
	@media screen and (-webkit-min-device-pixel-ratio: 0) {
		@font-face {
			font-family: 'wicons';
			src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.svg?buildTime=1513899303#wicons) format('svg');
		}
	}

	@font-face {
		font-family: 'wsocial';
		src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.eot?buildTime=1513899303);
		src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.eot?buildTime=1513899303#iefix) format('embedded-opentype'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.woff?buildTime=1513899303) format('woff'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.ttf?buildTime=1513899303) format('truetype'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.svg?buildTime=1513899303#wsocial) format('svg');
		font-weight: normal;
		font-style: normal;
	}
	/* Hack to smooth out font rendering on Chrome for Windows */
	@media screen and (-webkit-min-device-pixel-ratio: 0) {
		@font-face {
			font-family: 'wsocial';
			src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.svg?buildTime=1513899303#wsocial) format('svg');
		}
	}
</style>

<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/site_membership.css?buildTime=1513899303">

		<script src='/files/templateArtifacts.js?1514744905'></script>
<script>
var STATIC_BASE = '//cdn1.editmysite.com/';
var ASSETS_BASE = '//cdn2.editmysite.com/';
var STYLE_PREFIX = 'wsite';
</script>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script>

<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1513899303&"></script>
<script src="//cdn2.editmysite.com/js/site/main.js?buildTime=1513899303"></script><script type="text/javascript"> _W = _W || {}; _W.securePrefix='www-linuxandubuntu-com.checkout.weebly.com'; </script><script type="text/javascript">
								_W = window._W || {};
								_W.allowMemberRegistration = false;
								_W.showLogin = false;
							</script><script type="text/javascript">
					function initMembershipModels() {
						(function(){_W.setup_rpc({"url":"\/ajax\/api\/JsonRPC\/Membership\/","actions":{"Member":[{"name":"getRedirectUrl","len":1,"multiple":false,"standalone":false},{"name":"getOriginUrl","len":0,"multiple":false,"standalone":false},{"name":"getSecureMemberUrl","len":0,"multiple":false,"standalone":false},{"name":"validate_user","len":2,"multiple":false,"standalone":false},{"name":"get_account_information","len":0,"multiple":false,"standalone":false},{"name":"get_session_details","len":0,"multiple":false,"standalone":false},{"name":"register_member","len":4,"multiple":false,"standalone":false},{"name":"validate_session","len":1,"multiple":false,"standalone":false},{"name":"set_password","len":3,"multiple":false,"standalone":false},{"name":"send_reset_password_email","len":1,"multiple":false,"standalone":false},{"name":"create","len":1,"multiple":false,"standalone":false},{"name":"readOne","len":1,"multiple":false,"standalone":false},{"name":"readMany","len":1,"multiple":false,"standalone":false},{"name":"update","len":1,"multiple":false,"standalone":false},{"name":"patch","len":1,"multiple":false,"standalone":false},{"name":"destroy","len":1,"multiple":false,"standalone":false}]},"namespace":"_W.Membership.RPC"});
_W.setup_model_rpc({"rpc_namespace":"_W.Membership.RPC","model_namespace":"_W.Membership.BackboneModelData","collection_namespace":"_W.Membership.BackboneCollectionData","bootstrap_namespace":"_W.Membership.BackboneBootstrap","models":{"Member":{"_class":"Membership.Model.Member","defaults":{"class_name":null,"name":null,"email":"","access_token":null,"token_expiry_date":null,"last_ip":null,"last_login":null,"approved":false,"password_set":null,"group_ids":null,"page_ids":null,"group_page_ids":null,"owner_id":"","site_id":"","updated_date":0,"created_date":0},"validation":{"class_name":null,"site_member_id":null,"name":null,"email":{"email":null,"required":true},"access_token":null,"token_expiry_date":null,"last_ip":null,"last_login":null,"approved":null,"password_set":null,"group_ids":null,"page_ids":null,"group_page_ids":null,"owner_id":{"required":true},"site_id":{"required":true},"updated_date":null,"created_date":null},"types":{"class_name":null,"site_member_id":"string","name":"string","email":"string","access_token":"string","token_expiry_date":"int","last_ip":"string","last_login":"int","approved":"boolean","password_set":"boolean","group_ids":"json","page_ids":"json","group_page_ids":"json","owner_id":"string","site_id":"string","updated_date":"int","created_date":"int"},"idAttribute":"site_member_id","keydefs":{"PRIMARY":["owner_id","site_id","site_member_id"]}}},"collections":{"Member":{"_class":"Membership.Collection.Member"}},"bootstrap":[]});
})();
					}
					if(document.createEvent && document.addEventListener) {
						var initEvt = document.createEvent('Event');
						initEvt.initEvent('membershipModelsInitialized', true, false);
						document.dispatchEvent(initEvt);
					} else if(document.documentElement.initMembershipModels === 0){
						document.documentElement.initMembershipModels++
					}
					</script><script src='//cdn2.editmysite.com/js/site/main-membership-site.js?buildTime=1513899303'></script>
<script type="text/javascript">_W.configDomain = "www.weebly.com";</script><script>_W.relinquish && _W.relinquish()</script>
<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1513899303&"></script><script> _W.themePlugins = [];</script><script type="text/javascript"> _W.recaptchaUrl = "https://www.google.com/recaptcha/api.js"; </script><script type="text/javascript"><!--
	
	
	function initFlyouts(){
		initPublishedFlyoutMenus(
			[{"id":"505011975351111026","title":"Home","url":"home.html","target":"","nav_menu":false,"nonclickable":false},{"id":"369144760395742060","title":"Store","url":"store.html","target":"","nav_menu":false,"nonclickable":false},{"id":"497719449939535530","title":"Video Tutorials","url":"video-tutorials.html","target":"","nav_menu":false,"nonclickable":false},{"id":"394823265735430346","title":"Linux Themes","url":"linux-themes.html","target":"","nav_menu":false,"nonclickable":false},{"id":"990585951625353780","title":"FAQs","url":"faqs.html","target":"","nav_menu":false,"nonclickable":false},{"id":"868701769148141363","title":"Become a Regular writer","url":"become-a-regular-writer.html","target":"","nav_menu":false,"nonclickable":false},{"id":"488323224446624077","title":"Contact Us","url":"contact-us.html","target":"","nav_menu":false,"nonclickable":false},{"id":"225612336786093830","title":"Donate","url":"donate-now.html","target":"","nav_menu":false,"nonclickable":false},{"id":"758006490901768922","title":"Block Adblock","url":"block-adblock.html","target":"","nav_menu":false,"nonclickable":false},{"id":"609129779609369190","title":"Favorites","url":"favorites.html","target":"","nav_menu":false,"nonclickable":false},{"id":"920611133489073931","title":"Ubuntu Releases","url":"ubuntu.html","target":"","nav_menu":false,"nonclickable":false},{"id":"225388882747909356","title":"Linux Mint Releases","url":"linuxmint.html","target":"","nav_menu":false,"nonclickable":false}],
			"505011975351111026",
			'',
			'active',
			false,
			{"navigation\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}} class=\"wsite-menu-item-wrap\">\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\t{{#membership_required}}\n\t\t\tdata-membership-required=\"{{.}}\"\n\t\t{{\/membership_required}}\n\t\tclass=\"wsite-menu-item\"\n\t\t>\n\t\t{{{title_html}}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n","navigation\/flyout\/list":"<div class=\"wsite-menu-wrap\" style=\"display:none\">\n\t<ul class=\"wsite-menu\">\n\t\t{{#children}}{{> navigation\/flyout\/item}}{{\/children}}\n\t<\/ul>\n<\/div>\n","navigation\/flyout\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}}\n\tclass=\"wsite-menu-subitem-wrap {{#is_current}}wsite-nav-current{{\/is_current}}\"\n\t>\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\tclass=\"wsite-menu-subitem\"\n\t\t>\n\t\t<span class=\"wsite-menu-title\">\n\t\t\t{{{title_html}}}\n\t\t<\/span>{{#has_children}}<span class=\"wsite-menu-arrow\">&gt;<\/span>{{\/has_children}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n"},
			{}
		)
	}
//-->
</script>
		
		<script>
        var bkRawUrl = function(){return window.location.href}();
    (function (doc, scriptPath, apiKey) {
        var sc, node, today=new Date(),dd=today.getDate(),mm=today.getMonth()+1,yyyy=today.getFullYear();if(dd<10)dd='0'+dd;if(mm<10)mm='0'+mm;today=yyyy+mm+dd;
        window.BKShopApiKey =  apiKey;
        // Load base script tag
        sc = doc.createElement("script");
        sc.type = "text/javascript";
        sc.async = !0;
        sc.src = scriptPath + '?' + today;
        node = doc.getElementsByTagName("script")[0];
        node.parentNode.insertBefore(sc, node);
    })(document, 'https://sdk.beeketing.com/js/beeketing.js', '66941fa6e06f5cefc3481685474e7226');
</script><script type="text/javascript" src="https://popup2.lifterapps.com/js/modal.js?siteId=208815729450551065"></script><link rel="stylesheet" href="https://www.appjustable.com/weebly/apps/popup/appends/aj-modal.css">
<script src="https://www.appjustable.com/weebly/apps/popup/appends/aj-modal.js"></script>
	</head>
	<body class="no-header-page  wsite-page-home wsite-blog-post  wsite-theme-light"><div class="wrapper">
    <div class="header-wrap">
      <div class="nav-wrap">
        <div id="logo"><span class="wsite-logo">

	<a href="/">
		<img src="/uploads/2/1/1/5/21152474/linuxandubuntu-logo-7.png" alt="LinuxAndUbuntu - Linux News | Apps Reviews | Linux Tutorials HowTo" />
	</a>

</span></div>
		
		<div class="ads">
		<!-- Begin adsense 728x90 - linuxandubuntu.com Code -->
			<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
			<!-- Top Header Leaderboard -->
			<ins class="adsbygoogle"
				 style="display:inline-block;width:728px;height:90px"
				 data-ad-client="ca-pub-1925104690687996"
				 data-ad-slot="8182063423"></ins>
			<script>
			(adsbygoogle = window.adsbygoogle || []).push({});
			</script>
		<!-- End adsense 728x90 - linuxandubuntu.com Code -->
		</div>

<div class = "clear"></div>


        <label class="hamburger"><span></span></label>
        <div class="menu">
          <div class="container">
            <div class="search"><span class="wsite-search">
	<form id="wsite-header-search-form" action="/apps/search" method="get">
		<input type="text" name="q" class="wsite-search-input" autocomplete="off" placeholder="Search"/><span class="wsite-search-button"><span class="wsite-search-button-inner"></span></span>
	</form>
</span></div>
            <ul class="wsite-menu-default">
            		<li id="active" class="wsite-menu-item-wrap">
            			<a
            						href="/home.html"
            				class="wsite-menu-item"
            				>
            				Home
            			</a>
            			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-565074720829632001"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux
		</span><span class="wsite-menu-arrow">&gt;</span>
	</a>
	<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-809997295294728323"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/ubuntu"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Ubuntu
		</span>
	</a>
	
</li>
<li id="wsite-nav-918159234405136789"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux-mint"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux Mint
		</span>
	</a>
	
</li>
<li id="wsite-nav-435871470561347325"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/fedora"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fedora
		</span>
	</a>
	
</li>
<li id="wsite-nav-298073785194333561"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/arch-linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Arch Linux
		</span>
	</a>
	
</li>
<li id="wsite-nav-455751572174431389"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/open-suse"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Open Suse
		</span>
	</a>
	
</li>
<li id="wsite-nav-623096086202125694"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/distros"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Other Linux Distros
		</span>
	</a>
	
</li>

	</ul>
</div>

</li>

	</ul>
</div>

            		</li>
            		<li id="pg369144760395742060" class="wsite-menu-item-wrap">
            			<a
            						href="/store.html"
            				class="wsite-menu-item"
            				>
            				Store
            			</a>
            			
            		</li>
            		<li id="pg497719449939535530" class="wsite-menu-item-wrap">
            			<a
            						href="/video-tutorials.html"
            				class="wsite-menu-item"
            				>
            				Video Tutorials
            			</a>
            			
            		</li>
            		<li id="pg394823265735430346" class="wsite-menu-item-wrap">
            			<a
            						href="/linux-themes.html"
            				class="wsite-menu-item"
            				>
            				Linux Themes
            			</a>
            			
            		</li>
            		<li id="pg990585951625353780" class="wsite-menu-item-wrap">
            			<a
            						href="/faqs.html"
            				class="wsite-menu-item"
            				>
            				FAQs
            			</a>
            			
            		</li>
            		<li id="pg868701769148141363" class="wsite-menu-item-wrap">
            			<a
            						href="/become-a-regular-writer.html"
            				class="wsite-menu-item"
            				>
            				Become a Regular writer
            			</a>
            			
            		</li>
            		<li id="pg488323224446624077" class="wsite-menu-item-wrap">
            			<a
            						href="/contact-us.html"
            				class="wsite-menu-item"
            				>
            				Contact Us
            			</a>
            			
            		</li>
            		<li id="pg225612336786093830" class="wsite-menu-item-wrap">
            			<a
            						href="/donate-now.html"
            				class="wsite-menu-item"
            				>
            				Donate
            			</a>
            			
            		</li>
            		<li id="pg758006490901768922" class="wsite-menu-item-wrap">
            			<a
            						href="/block-adblock.html"
            				class="wsite-menu-item"
            				>
            				Block Adblock
            			</a>
            			
            		</li>
            		<li id="pg609129779609369190" class="wsite-menu-item-wrap">
            			<a
            						href="/favorites.html"
            				class="wsite-menu-item"
            				>
            				Favorites
            			</a>
            			
            		</li>
            		<li id="pg920611133489073931" class="wsite-menu-item-wrap">
            			<a
            						href="/ubuntu.html"
            				class="wsite-menu-item"
            				>
            				Ubuntu Releases
            			</a>
            			
            		</li>
            		<li id="pg225388882747909356" class="wsite-menu-item-wrap">
            			<a
            						href="/linuxmint.html"
            				class="wsite-menu-item"
            				>
            				Linux Mint Releases
            			</a>
            			
            		</li>
            </ul>
          </div>
        </div>
      </div>
    </div>
	
	

    <div id="main-wrap">
      <div class="wsite-section-content">
        <div class="container"><div class="wsite-elements wsite-not-footer">
	<table 
	id="blogTable" 
		class="wsite-not-footer" 
	style="border: 0; width: 100%; table-layout: fixed" 
>
	<tr>
	    <td valign="top">
	        	<div id="505011975351111026-blog" class="blog-body" style="float: left;"> 
		<div id="wsite-content">	<div id="blog-post-664939552145944209" class="blog-post">
	
			<div class="blog-post-header"><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
</script> <!-- Above Post Or Post header Unit Responsive -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1925104690687996" data-ad-slot="7903274511" data-ad-format="auto"></ins> <script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><br>
</div>
	
		<div class="blog-header">
			<h2 class="blog-title">
					<a class="blog-title-link blog-link" href="//www.linuxandubuntu.com/home/making-vim-even-more-awesome-with-these-cool-features">Making Vim Even More Awesome With These Cool Features</a>

			</h2>
			<p class="blog-date">
					<span class="date-text">
		31/12/2017
	</span>

			</p>
			<p class="blog-comments">
						<a href="//www.linuxandubuntu.com/home/making-vim-even-more-awesome-with-these-cool-features#comments" data-disqus-identifier="664939552145944209" class="blog-link">Comments</a>

			</p>
		</div>
	
		<div class="blog-separator">&nbsp;</div>
	
		<div class="blog-content">
				<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='http://www.linuxandubuntu.com/home/making-vim-even-more-awesome-with-these-cool-features'><img src="/uploads/2/1/1/5/21152474/making-vim-even-more-awesome-with-these-cool-features_orig.jpg" alt="Making Vim Even More Awesome With These Cool Features" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​<strong>Vim</strong> is quite an integral part of Every <a href="http://www.linuxandubuntu.com/home/category/distros" target="_blank">Linux Distribution</a> and the most useful tool (of course after the terminal) for Linux Users. At least, this theory holds for me. People might argue that for programming, Vim might not be a good choice as there are different IDEs or other sophisticated text editors like Sublime Text 3, Atom etc. which make the programming job pretty easier.
</div>

<div>
<!--BLOG_SUMMARY_END-->
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="328524967663429334" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>My Thoughts</h4>
</div>
</div>

<div class="paragraph">
But what I think is that Vim works the way we want it to right from the very start, while other editors make us work the way they have been designed, not the way we actually want them to work. I can’t say much about other editors cause I haven’t used them much ( I’m biased with Vim ).<br>
<br>
Anyway, Let’s make something out of Vim, that really does the Job god damn well.
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<h2 class="wsite-content-title">​Vim for Programming</h2>

<div class="wsite-spacer" style="height:19px;"></div>

<div>
<div id="105324218389625213" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>Executing the Code</h4>
</div>
</div>

<div class="paragraph">
Consider a scenario, What we do when we are working on a C++ code on Vim and we need to compile and run it.<br>
<br>
(a). We get back to the terminal either through &lt;C-z&gt; (Ctrl + Z) thing or we just save and quit it (:wq).<br>
<br>
(b). And the trouble’s ain’t over, we now need to type on something on terminal like this { g++ fileName.cxx }.<br>
​<br>
(c). And after that execute it by typing { ./a.out } .<br>
<br>
Certainly a lot of things needed to be done in order to get our C++ code running over the shell. But it doesn’t seem to be a Vim way of doing this (as Vim always tends to keep almost everything under one/two keypresses). So, What is the Vim way of doing this stuff?
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="369156790272688844" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>The Vim Way</h4>
</div>
</div>

<div class="paragraph">
Vim isn’t just a Text Editor, It is sort of a Programming Language for Editing Text. And that programming language that helps us extending the features of Vim is “VimScript”.<br>
<br>
So, with the help of VimScript, we can easily automate our task of Compiling and Running code with just a KeyPress.
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/vim_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/vim_orig.png" alt="create functions in vim .vimrc" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
Above is a snippet out of my .vimrc configuration file where i created a function called CPP().<br>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="943223242572845755" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>Creating Functions in VimScript</h4>
</div>
</div>

<div class="paragraph">
The syntax for creating a function in VimScript is pretty easy. It starts with keyword “<strong>func</strong>” and is followed by the name of Function [Function Name must start with a capital letter in VimScript, otherwise Vim will give an error]. And the end of the function is denoted by keyword “<strong>endfunc</strong>”.<br>
<br>
In the function’s body, you can see an <strong>exec</strong> statement, whatever you write after the exec keyword is executed over the Vim’s Command Mode (remember the thing starting with: at the bottom of Vim’s window). Now, the string that I passed to the exec is -<br>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/vim_1_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/vim_1_orig.png" alt="vim functions commands &amp; symbols" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
What happens is when this function is called, it first clears the Terminal Screen, so that only you will be viewing is your output, then it executes g++ over the filename you are working on and after that executes the a.out file formed due to compilation.<br>
<br>
Mapping Ctrl+r to run C++ code<br>
-------------------------------------------------------------<br>
I mapped the statement :call CPP()&lt;CR&gt; to the key-combination &lt;C-r&gt; (Ctrl+r) so that I could now press Ctrl+r to execute my C++ Code without manually typing :call CPP() and then pressing Enter.
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="292546654188953256" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h4 class='fheadings'>End Result</h4>
</div>
</div>

<div class="paragraph">
We finally managed to find the Vim Way of doing that stuff. So now, You just hit a button and the output of your C++ code is on your screen, you don’t need to type all that lengthy thing. It sort of saves your time too.<br>
<br>
We can achieve this sort of functionality for other languages too.
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/vim_2_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/vim_2_orig.png" alt="create function in vim for python" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​So For Python: Now you could press &lt;Ctrl + e&gt; to interpret your code.
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/vim_3_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/vim_3_orig.png" alt="create function in vim for java" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
For Java: You could now press &lt;Ctrl + j&gt; , it will first Compile your Java Code then interpret your java class file and show you the output.<br>
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div>
<div id="573885379317908847" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<h3 class='theadings'>Picture ain’t over, Marching a level deep</h3>
</div>
</div>

<div class="paragraph">
So, this was all about how you could manipulate things to work your way in Vim. Now, it comes to how we implement all this in Vim. We can use these Code Snippets directly in Vim and the other way around is by using the AutoCommands in Vim (autocmd’s). The beauty of autocmd is these commands need not be called by users, they execute by themselves at any certain condition which is provided by the user.<br>
<br>
What I want to do with this [autocmd] thing is that, instead of using different mappings to perform execution of codes in different Programming Languages, I would like a single mapping for execution for every language.
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/vim_4_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/vim_4_orig.png" alt="autocmd in vimrc" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​What we did here is that I wrote autocommands for all the File Types for which I had functions for Executing the code.<br>
<br>
What’s going to happen is as soon as I open any buffer of any of the above-mentioned file types, Vim will automatically map my &lt;C-r&gt; (Ctrl + r) to the function call and &lt;CR&gt; represents Enter Key, so that I don’t need to press “Enter key” everytime I press &lt;C-r&gt; and &lt;C-r&gt; alone does the job.<br>
<br>
To achieve this Functionality, you just need to add the function snippets to your [dot]vimrc and after that just put all those autocmds . And with that, the next time you open Vim, Vim will have all the Functionalities to execute all the Codes with the very same KeyBindings.
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<h2 class="wsite-content-title">Conclusion</h2>

<div class="paragraph">
<span style="color:rgb(40, 40, 48)">That’s all for now. Hope this thing makes you love your Vim even more.&nbsp;</span><span style="color:rgb(40, 40, 48)">I am currently exploring things in Vim, reading Documentations etc. and doing additions in [.vimrc] file and I will reach to you again when I will have something wonderful to share with you all.</span><br>
<br>
<span style="color:rgb(40, 40, 48)">If you want to have a look at my current [.vimrc] file, here is the link to my Github account:&nbsp;</span><a href="https://github.com/phenomenal-ab/VIm-Configurations/blob/master/.vimrc">MyVimrc</a>.&nbsp;<span style="color:rgb(40, 40, 48)">Please do Comment on how you liked the article.</span>
</div>


		</div>
	
			<div class="blog-post-footer"><br>
<hr>
<strong>Related articles</strong> <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
</script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-1925104690687996" data-ad-slot="3191286661"></ins> <script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
	
			<div class="blog-social  ">
		<div class="blog-social-item blog-fb-like"><fb:like href="http://www.linuxandubuntu.com/1/post/2017/12/making-vim-even-more-awesome-with-these-cool-features.html" width="90" layout="button_count" action="like" show_faces="false" share="false"></fb:like></div><div class="blog-social-item"><a class="twitter-share-button" href="http://twitter.com/share?url=http://www.linuxandubuntu.com/1/post/2017/12/making-vim-even-more-awesome-with-these-cool-features.html" data-text="Making Vim Even More Awesome With These Cool Features - LinuxAndUbuntu - Linux News | Apps Reviews | Linux Tutorials HowTo" data-count="horizontal"></a></div>
		<div style="clear:both"></div>
	</div>

	
		<div class="blog-comments-bottom">
					<a href="//www.linuxandubuntu.com/home/making-vim-even-more-awesome-with-these-cool-features#comments" data-disqus-identifier="664939552145944209" class="blog-link">Comments</a>

		</div>
	
		<div class="blog-post-separator"></div>
	</div>


    <a name="comments" id="comments"></a>
<div id="commentArea">
	<div class="blog-comment-area">
		
		<div id="disqus_thread"></div>
		<script type="text/javascript">
			(function() {
			// Light/Dark is decided by text color inheirited to comment system
			// and should be passed by theme setting
			document.getElementById("disqus_thread").style.color = (document.body.className.match('wsite-theme-light') ? "black" : "white");
	
			window.disqus_shortname = "linuxandubuntu";
			window.disqus_identifier = "";
	
			var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
			dsq.src = "//" + disqus_shortname + ".disqus.com/embed.js";
			(document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
			})();
		</script>
		<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
		<a href="http://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>


	</div>
	<!-- bid-1: , path:  -->
</div>
 
<!-- bid: $blog_id --></div>
	</div>

	    </td>
	        <td class="blog-sidebar" valign="top">
	            <div id="505011975351111026-sidebar" class="column-blog">
	<div class="blog-sidebar-separator">
		<ul id="505011975351111026-sidebar-list" class="columnlist-blog" style="margin:0; padding: 0;">
			<div><div id="712008999420323625" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Main Sidebar Up (SEC II) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-1925104690687996"
     data-ad-slot="5196807437"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



</div>

<div id="782653919158895356"><div><style type="text/css">
	#element-1932ca9b-3479-4626-a024-22eb1b9fb5e8 .callout-box-wrapper {
  padding: 20px 0px;
  word-wrap: break-word;
}
#element-1932ca9b-3479-4626-a024-22eb1b9fb5e8 .callout-box--standard {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
}
#element-1932ca9b-3479-4626-a024-22eb1b9fb5e8 .callout-box--material {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}
#element-1932ca9b-3479-4626-a024-22eb1b9fb5e8 .callout-base {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
}
#element-1932ca9b-3479-4626-a024-22eb1b9fb5e8 .material {
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}

</style><div id="element-1932ca9b-3479-4626-a024-22eb1b9fb5e8" data-platform-element-id="694046499467037623-1.2.6" class="platform-element-contents">
	<div class="callout-box-wrapper">
	<div class="callout-box--standard">
	    <div class="element-content">
	        <div style="width: auto"><div></div><div style="text-align:left;"><div style="height:10px;overflow:hidden"></div>
<span class="wsite-social wsite-social-default"><a class='first-child wsite-social-item wsite-social-facebook' href='https://www.facebook.com/linuxandubuntuofficial' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-twitter' href='https://www.twitter.com/linuxandubuntu' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-instagram' href='https://www.instagram.com/mohdsohail_123/' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-linkedin' href='https://www.linkedin.com/in/mohdsohail' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-flickr' href='https://www.flickr.com/people/153662320@N03/?rb=1' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-pinterest' href='http://www.pinterest.com/linuxandubuntu' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-plus' href='https://plus.google.com/+Linuxandubuntuweb/posts' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-rss' href='http://feeds.feedburner.com/linuxandubuntu' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='last-child wsite-social-item wsite-social-youtube' href='https://www.youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg' target='_blank'><span class='wsite-social-item-inner'></span></a></span>
<div style="height:10px;overflow:hidden"></div></div></div>
	    </div>
	</div>
</div>
</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>

<div><div id="434243777816392600" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Main Sidebar Down -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-1925104690687996"
     data-ad-slot="8811004412"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



</div>

<div class="wsite-spacer" style="height:33px;"></div>

<h2 class="wsite-content-title" style="text-align:left;"><font size="5">Most Read Articles</font></h2>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/20-best-themes-for-ubuntu-in-2017'><img src="/uploads/2/1/1/5/21152474/editor/576719416.jpg?1501522454" style="margin-top: 5px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px; max-width:100%" alt="5 Lightweight Linux For Old Computers" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/20-best-themes-for-ubuntu-in-2017">20 Best Themes For Ubuntu In 2017</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/8-best-ides-or-code-editors-for-linux'><img src="/uploads/2/1/1/5/21152474/editor/214005563.jpg?1492664480" style="margin-top: 5px; margin-bottom: 0px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="8 Best IDEs Or Code Editors For Linux" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -0px; margin-bottom: 0px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/8-best-ides-or-code-editors-for-linux">8 Best IDEs Or Code Editors For Linux</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/how-to-install-latest-nvidia-drivers-in-linux'><img src="/uploads/2/1/1/5/21152474/editor/833222706.jpg?1501522581" style="margin-top: 5px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="3 best twitter clients for linux" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/how-to-install-latest-nvidia-drivers-in-linux">[How To] Install Latest NVIDIA Drivers In Linux</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers'><img src="/uploads/2/1/1/5/21152474/editor/998402903.jpg?1501522732" style="margin-top: 5px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="﻿Ubuntu Vs. Linux Mint - Which Is Better in 2016?" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers">5 Lightweight Linux For Old Computers</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/10-basic-linux-commands-that-every-linux-newbies-should-remember'><img src="/uploads/2/1/1/5/21152474/published/660891119.png?1501522816" style="margin-top: 5px; margin-bottom: 0px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="dual boot ubuntu and windows" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -0px; margin-bottom: 0px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/10-basic-linux-commands-that-every-linux-newbies-should-remember">10 Basic Linux Commands That Every Linux Newbies Should Remember</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/6-best-linux-distributions-for-programming'><img src="/uploads/2/1/1/5/21152474/published/364539440.jpg?1501522919" style="margin-top: 15px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="dual boot ubuntu and windows" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/6-best-linux-distributions-for-programming">6 Best Linux Distributions For Programming</a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<div id="208354040506696420"><div><style type="text/css">
	#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-box-wrapper {
  padding: 20px 0px;
  word-wrap: break-word;
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-box--standard {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-box--material {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-base {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .material {
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}

</style><div id="element-66239272-0681-4f78-b18e-ac5eb66ed42f" data-platform-element-id="694046499467037623-1.2.6" class="platform-element-contents">
	<div class="callout-box-wrapper">
	<div class="callout-box--standard">
	    <div class="element-content">
	        <div style="width: auto"><div></div><div><div id="151769381861451707" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><!-- Place this tag in your head or just before your close body tag. -->
<script src="https://apis.google.com/js/platform.js" async defer></script>

<!-- Place this tag where you want the widget to render. -->
<div class="g-page" data-width="260" data-href="//plus.google.com/u/0/118431494181891907735" data-theme="dark" data-rel="publisher"></div></div>



</div></div>
	    </div>
	</div>
</div>
</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>

<div class="wsite-spacer" style="height:42px;"></div>

<div><div style="height: 10px; overflow: hidden; width: 100%;"></div>
<hr class="styled-hr" style="width:100%;"></hr>
<div style="height: 10px; overflow: hidden; width: 100%;"></div></div>

<div class="wsite-spacer" style="height:34.33334px;"></div>

<h2 class="wsite-content-title" style="text-align:left;">Translate Our Site</h2>

<div><div id="857667866879550401" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><div style="background-color:#FCFCFC; padding: 5px; border-style:solid; border-radius:0px; border-width:1px; border-color:#ABA4A4;" align="center">
<br><br/><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL, gaTrack: true, gaId: 'UA-42740043-4'}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
        
<br /> <br />
<font color = "red">Notice  :</font> Please be careful, after translation commands will change.
</div></div>



</div>

<div id="317368027686760666"><div><style type="text/css">
	#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top {
  display: none;
  width: 60px;
  height: 60px;
  text-indent: -9999px;
  position: fixed;
  z-index: 999;
  bottom: 70px;
  background: #8c48b7 url("//marketplace.editmysite.com/elements/569198776394566218-1.0.1/assets/up-arrow.png") no-repeat center 43%;
  -webkit-border-radius: 30px;
  -moz-border-radius: 30px;
  border-radius: 30px;
}
#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top.back-to-top-left {
  left: 30px;
}
#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top.back-to-top-right {
  right: 30px;
}

</style><div id="element-cb6ceeb2-44e0-436f-9f02-623744191355" data-platform-element-id="569198776394566218-1.0.1" class="platform-element-contents">
	<a href="#" class="back-to-top back-to-top-left"></a>

</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>
		</ul>
	</div>
</div>

	        </td>
	</tr>
</table>

</div>
</div>
      </div>
    </div>
	
	



    <div class="sticky-footer-push"></div>

  </div><!--/.wrapper-->

  <div id="footer-wrap">
    <div class="container"><div class='wsite-elements wsite-footer'>
<div><div class="wsite-multicol"><div class="wsite-multicol-table-wrap" style="margin:0 -15px;">
	<table class="wsite-multicol-table">
		<tbody class="wsite-multicol-tbody">
			<tr class="wsite-multicol-tr">
				<td class="wsite-multicol-col" style="width:45.638936570547%; padding:0 15px;">
					
						

<div><div class="wsite-multicol"><div class="wsite-multicol-table-wrap" style="margin:0 -15px;">
	<table class="wsite-multicol-table">
		<tbody class="wsite-multicol-tbody">
			<tr class="wsite-multicol-tr">
				<td class="wsite-multicol-col" style="width:57.196261682243%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">About LinuxAndUbuntu</h2>

<div class="paragraph" style="text-align:left;">&#8203;<span style="color:rgb(161, 161, 161)">&#8203;</span><span style="color:rgb(161, 161, 161)">LinuxAndUbuntu.com &nbsp;focuses on open source projects but &nbsp;specific on debian based distributions. We also give value to other linux distributions.</span></div>


					
				</td>				<td class="wsite-multicol-col" style="width:42.803738317757%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">Links</h2>

<div class="paragraph" style="text-align:left;"><a href="http://www.ubuntu.com" title="">Ubuntu.com</a></div>

<div class="paragraph" style="text-align:left;"><a href="/video-tutorials.html" title="">Video Tutorials</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/home/category/tutorials-howtos" title="">Tutorials &amp; HowTos</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/privacy-policy.html">Privacy Policy</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/contact-us.html">Contact us</a></div>


					
				</td>			</tr>
		</tbody>
	</table>
</div></div></div>

<div class="wsite-spacer" style="height:50px;"></div>


					
				</td>				<td class="wsite-multicol-col" style="width:31.508732009559%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">Like Us</h2>

<div><div id="645631142411644859" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Flinuxandubuntuofficial%2F&tabs&width=340&height=214&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId=522757631233307" width="340" height="214" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></div>



</div>

<div class="wsite-search-element-outer"><div class="wsite-search-element-align-left" style="padding: 10px 0 10px 0">
  <form class="wsite-search-element-form" action="/apps/search" method="get">
    <div class="wsite-search-element">
      <input class="wsite-input wsite-search-element-input" type="text" name="q" placeholder="Search" autocomplete="off" />
      <span class="wsite-search-element-submit" title="Search"></span>
    </div>
  </form>
</div></div>


					
				</td>				<td class="wsite-multicol-col" style="width:22.852331419894%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">More From LinuxAndUbuntu</h2>

<div class="paragraph" style="text-align:left;"><a href="/submit-article.html"><font size="2">Contribute &nbsp;Your Work</font></a><br /><a href="/advertise-with-us.html" target="_blank">Advertise</a><br /><a href="/donate-now.html" target="_blank">Donate Us</a></div>

<h2 class="wsite-content-title" style="text-align:left;">RSS Feed</h2>

<div><div class="wsite-image wsite-image-border-none " style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:left">
<a href='http://feeds.feedburner.com/linuxandubuntu' target='_blank'>
<img src="/uploads/2/1/1/5/21152474/4532422_orig.png" alt="Picture" style="width:auto;max-width:100%" />
</a>
<div style="display:block;font-size:90%"></div>
</div></div>


					
				</td>			</tr>
		</tbody>
	</table>
</div></div></div>

<div class="paragraph" style="text-align:left;"><font color="#d5d5d5"><a href="http://www.ubuntu.com/" target="_blank">Ubuntu</a>&nbsp;is a registered trademark of &nbsp;<a href="http://canonical.com/">Canonical Ltd</a>.<br /><br />Any material in this site can not be reproduced without permission.</font></div>

<div id="172266712501878073"><div><style type="text/css">
	#element-12c27639-4676-4034-a340-ff642712cb58 .overlaybg-picker {
  background: overlayBg;
}
#element-12c27639-4676-4034-a340-ff642712cb58 .aj-themodal-inner {
  background: #fafafa;
  padding: 15px 15px;
  -webkit-box-sizing: border-box;
  box-sizing: border-box;
}
#element-12c27639-4676-4034-a340-ff642712cb58 .close {
  font-size: 0;
  top: -20px;
  right: -20px;
  width: 30px;
  height: 30px;
  line-height: 30px;
  text-align: center;
  background: #000;
  -webkit-box-sizing: border-box;
  -webkit-border-radius: 50%;
  border-radius: 50%;
  border: 2px solid #fff;
}
@media (max-width: 800px) {
  #element-12c27639-4676-4034-a340-ff642712cb58 .close {
    top: 0 !important;
    right: 0 !important;
    -webkit-border-radius: 0;
    border-radius: 0;
  }
}
#element-12c27639-4676-4034-a340-ff642712cb58 .close > svg {
  width: 10px;
  height: 10px;
  top: 8px;
  left: 8px;
  position: absolute;
}
#element-12c27639-4676-4034-a340-ff642712cb58 .close > svg .closeBtn {
  stroke: #fff;
  stroke-width: 3;
}
#element-12c27639-4676-4034-a340-ff642712cb58 .aj-themodal-inner--useimagebg {
  background-position: center center;
  background-size: cover;
  background-color: none;
}

</style><div id="element-12c27639-4676-4034-a340-ff642712cb58" data-platform-element-id="260691225102257046-1.0.0" class="platform-element-contents">
	<style>
	/*/@media (min-width: 1200px) {*/
		.aj-themodal[data-parent-id="12c27639-4676-4034-a340-ff642712cb58"] {
			width: 750px;
			margin-left: calc(750px / -2);
		}
	/*}*/

	@media (max-width: 750px) {
		.aj-themodal[data-parent-id="12c27639-4676-4034-a340-ff642712cb58"] {
			width: 95%;
			margin-left: -47.5%;
		}
	}
</style>
<div class="aj-themodal ui modal " data-autoplayvid="false" data-modalwindow="name_your_popup" data-reveal="scale" data-reveal-duration="500" data-overlay-close="true" data-reveal-bottom="none" data-reveal-pageleave="none" data-always-show="1" data-show-delay="3000" data-parent-id="12c27639-4676-4034-a340-ff642712cb58" >
	<div class="overlaybg-picker" style="background:rgba(0,0,0,.7);opacity:" data-overlay-bg="rgba(0,0,0,.7)" data-overlay-op=""></div>
    <div class="close"><svg width="18px" height="18px" viewBox="0 0 18 18" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd" stroke-linecap="round" stroke-linejoin="round"><g class="closeBtn" transform="translate(-53.000000, -72.000000)" stroke="#fff" stroke-width="2"><path d="M69.9581874,73.5069486 L54.9581874,88.5069486 M69.9581874,88.5069486 L54.9581874,73.5069486"></path></g></g></svg></div>
    <div class="aj-themodal-inner " data-parent-id="12c27639-4676-4034-a340-ff642712cb58" >
	    <div style="width: auto"><div></div><h2 class="wsite-content-title" style="text-align:center;"><font color="#2a2a2a" size="6">LinuxAndUbuntu Wishes You A Happy New Year</font></h2>

<div><div class="wsite-image wsite-image-border-none " style="padding-top:10px;padding-bottom:10px;margin-left:0;margin-right:0;text-align:center">
<a>
<img src="/uploads/2/1/1/5/21152474/tux_orig.png" alt="Picture" style="width:auto;max-width:100%" />
</a>
<div style="display:block;font-size:90%"></div>
</div></div></div>
	    </div>
</div> 
</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div></div></div>
  </div>

  <div class="navmobile-wrapper">
    <div id="navmobile" class="nav"><ul class="wsite-menu-default">
		<li id="active" class="wsite-menu-item-wrap">
			<a
						href="/home.html"
				class="wsite-menu-item"
				>
				Home
			</a>
			<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-565074720829632001"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux
		</span><span class="wsite-menu-arrow">&gt;</span>
	</a>
	<div class="wsite-menu-wrap" style="display:none">
	<ul class="wsite-menu">
		<li id="wsite-nav-809997295294728323"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/ubuntu"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Ubuntu
		</span>
	</a>
	
</li>
<li id="wsite-nav-918159234405136789"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/linux-mint"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Linux Mint
		</span>
	</a>
	
</li>
<li id="wsite-nav-435871470561347325"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/fedora"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Fedora
		</span>
	</a>
	
</li>
<li id="wsite-nav-298073785194333561"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/arch-linux"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Arch Linux
		</span>
	</a>
	
</li>
<li id="wsite-nav-455751572174431389"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/open-suse"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Open Suse
		</span>
	</a>
	
</li>
<li id="wsite-nav-623096086202125694"
	class="wsite-menu-subitem-wrap "
	>
	<a
				href="http://www.linuxandubuntu.com/home/category/distros"
		class="wsite-menu-subitem"
		>
		<span class="wsite-menu-title">
			Other Linux Distros
		</span>
	</a>
	
</li>

	</ul>
</div>

</li>

	</ul>
</div>

		</li>
		<li id="pg369144760395742060" class="wsite-menu-item-wrap">
			<a
						href="/store.html"
				class="wsite-menu-item"
				>
				Store
			</a>
			
		</li>
		<li id="pg497719449939535530" class="wsite-menu-item-wrap">
			<a
						href="/video-tutorials.html"
				class="wsite-menu-item"
				>
				Video Tutorials
			</a>
			
		</li>
		<li id="pg394823265735430346" class="wsite-menu-item-wrap">
			<a
						href="/linux-themes.html"
				class="wsite-menu-item"
				>
				Linux Themes
			</a>
			
		</li>
		<li id="pg990585951625353780" class="wsite-menu-item-wrap">
			<a
						href="/faqs.html"
				class="wsite-menu-item"
				>
				FAQs
			</a>
			
		</li>
		<li id="pg868701769148141363" class="wsite-menu-item-wrap">
			<a
						href="/become-a-regular-writer.html"
				class="wsite-menu-item"
				>
				Become a Regular writer
			</a>
			
		</li>
		<li id="pg488323224446624077" class="wsite-menu-item-wrap">
			<a
						href="/contact-us.html"
				class="wsite-menu-item"
				>
				Contact Us
			</a>
			
		</li>
		<li id="pg225612336786093830" class="wsite-menu-item-wrap">
			<a
						href="/donate-now.html"
				class="wsite-menu-item"
				>
				Donate
			</a>
			
		</li>
		<li id="pg758006490901768922" class="wsite-menu-item-wrap">
			<a
						href="/block-adblock.html"
				class="wsite-menu-item"
				>
				Block Adblock
			</a>
			
		</li>
		<li id="pg609129779609369190" class="wsite-menu-item-wrap">
			<a
						href="/favorites.html"
				class="wsite-menu-item"
				>
				Favorites
			</a>
			
		</li>
		<li id="pg920611133489073931" class="wsite-menu-item-wrap">
			<a
						href="/ubuntu.html"
				class="wsite-menu-item"
				>
				Ubuntu Releases
			</a>
			
		</li>
		<li id="pg225388882747909356" class="wsite-menu-item-wrap">
			<a
						href="/linuxmint.html"
				class="wsite-menu-item"
				>
				Linux Mint Releases
			</a>
			
		</li>
</ul>
</div>
  </div>

  <script type="text/javascript" src="/files/theme/mobile.js"></script>
  <script type="text/javascript" src="/files/theme/plugins.js"></script>
  <script type="text/javascript" src="/files/theme/custom.js"></script>
  
  <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54735dd100c86111"></script>

<!--Hellobar code-->
<script src="//my.hellobar.com/d40bc16125e026e2838a1c33da0b62ab276fdaa2.js" type="text/javascript" charset="utf-8" async="async"></script>

<script>
  (function (w,i,d,g,e,t,s) {w[d] = w[d]||[];t= i.createElement(g);
    t.async=1;t.src=e;s=i.getElementsByTagName(g)[0];s.parentNode.insertBefore(t, s);
  })(window, document, '_gscq','script','//widgets.getsitecontrol.com/25631/script.js');
</script>

<div id="dialog-region"></div>
		<!--STATCOUNTER.COM SITE TRACKER CODE STARTS HERE-->

<!-- Start of StatCounter Code for Weebly -->
<script type="text/javascript">
var sc_project=10160336; 
var sc_invisible=1; 
var sc_security="10341dd9"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="weebly
statistics" href="http://statcounter.com/weebly/"
target="_blank"><img class="statcounter"
src="http://c.statcounter.com/10160336/0/10341dd9/1/"
alt="weebly statistics"></a></div></noscript>
<!-- End of StatCounter Code for Weebly --><script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-7870337-1']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_setAllowLinker', true]);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wGA = '_gaq';

</script>

<script type="text/javascript" async=1>
	;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[];
			p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
			};p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
			n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,'script','//cdn2.editmysite.com/js/wsnbn/snowday262.js','snowday'));

	var r = [99, 104, 101, 99, 107, 111, 117, 116, 46, 40, 119, 101, 101, 98, 108, 121, 124, 101, 100, 105, 116, 109, 121, 115, 105, 116, 101, 41, 46, 99, 111, 109];
	var snPlObR = function(arr) {
		var s = '';
		for (var i = 0 ; i < arr.length ; i++){
			s = s + String.fromCharCode(arr[i]);
		}
		return s;
	};
	var s = snPlObR(r);

	var regEx = new RegExp(s);

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wSP = 'snowday';
	_W.Analytics.user_id = '21152474';
	_W.Analytics.site_id = '208815729450551065';


	(function(app_id, ec_hostname, discover_root_domain) {
		var track = window[_W.Analytics.trackers.wSP];
		if (!track) return;
		track('newTracker', app_id, ec_hostname, {
			appId: app_id,
			post: true,
			platform: 'web',
			discoverRootDomain: discover_root_domain,
			cookieName: '_snow_',
			contexts: {
				webPage: true,
				performanceTiming: true,
				gaCookies: true
			},
			crossDomainLinker: function (linkElement) {
				return regEx.test(linkElement.href);
			}
		});
		track('trackPageView', _W.Analytics.user_id+':'+_W.Analytics.site_id);
		track('crossDomainLinker', function (linkElement) {
			return regEx.test(linkElement.href);
		});
	})(
		'_wn',
		'ec.editmysite.com',
		true
	);
</script>

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = "https://secure.quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-0dYLvhSGGqUWo",
labels:"l10,u21152474.u21152474s208815729450551065"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-0dYLvhSGGqUWo.gif?labels=l10,u21152474.u21152474s208815729450551065" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


<script>

	(function(jQuery) {
		try {
			if (jQuery) {
				jQuery('div.blog-social div.fb-like').attr('class', 'blog-social-item blog-fb-like');
				var $commentFrame = jQuery('#commentArea iframe');
				if ($commentFrame.length > 0) {
					var frameHeight = jQuery($commentFrame[0].contentWindow.document).height() + 50;
					$commentFrame.css('min-height', frameHeight + 'px');
				}
				if (jQuery('.product-button').length > 0){
					jQuery(document).ready(function(){
						jQuery('.product-button').parent().each(function(index, product){
							if(jQuery(product).attr('target') == 'paypal'){
								if (!jQuery(product).find('> [name="bn"]').length){
									jQuery('<input>').attr({
										type: 'hidden',
										name: 'bn',
										value: 'DragAndDropBuil_SP_EC'
									}).appendTo(product);
								}
							}
						});
					});
				}
			}
			else {
				// Prototype
				$$('div.blog-social div.fb-like').each(function(div) {
					div.className = 'blog-social-item blog-fb-like';
				});
				$$('#commentArea iframe').each(function(iframe) {
					iframe.style.minHeight = '410px';
				});
			}
		}
		catch(ex) {}
	})(window._W && _W.jQuery);

</script>
<div id="eu-cookie" class="notification" style="display: none;">
	<span id="eu-cookie-content"></span>
	<span id="eu-cookie-close">&#10005;</span>
</div>

<script type="text/javascript">
	(function($) {
		window.cookie_location = 'off';
		// this cookie_content should already be pre-encoded from CookieSettingView.js
		window.cookie_content = 'By using this site you consent to the use of cookies. Cookies can be managed in your browser or device settings.' || _W.stl('templates.publish.virtual-includes.footerCode_1');
		window.cookie_policy_key = '208815729450551065_cookie_policy';
		window.cookie_content_hash = 'e67c816bde33ee2f23878d228c1c751d80249811';

		if (!_W.getCookie(window.cookie_policy_key) || _W.getCookie(window.cookie_policy_key) !== window.cookie_content_hash){
			if (window.cookie_location === 'top' || window.cookie_location === 'bottom'){
				$('#eu-cookie-content').text(decodeURIComponent(window.cookie_content));
				(window.cookie_location === 'top') ? animateFromTop() : animateFromBottom();
				$('#eu-cookie').show();
			}
		}

		$('#eu-cookie-close').click(function(){
			_W.setCookie(window.cookie_policy_key, window.cookie_content_hash, 100000);
			$('#eu-cookie').hide();
		});

		function animateFromTop(){
			$('#eu-cookie').css({
				'top': '0px',
				'animation': 'reveal-top 1 2s'
			});
		}

		function animateFromBottom(){
			$('#eu-cookie').css({
				'bottom': '0px',
				'animation': 'reveal-bottom 1 2s'
			});
		}
	})(window._W && _W.jQuery);
</script>
<script type="text/javascript">
	var disqus_shortname = "linuxandubuntu";

	(function () {
	var s = document.createElement("script"); s.async = true;
	s.type = "text/javascript";
	s.src = "//" + disqus_shortname + ".disqus.com/count.js";
	(document.getElementsByTagName("HEAD")[0] || document.getElementsByTagName("BODY")[0]).appendChild(s);
	}());
</script>
<div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({
			appId : '190291501407',
			xfbml : true,
			version : 'v2.6'
		});

        // Set Facebook comment plugin's colorscheme based off of theme
		var comments = document.getElementsByClassName('facebook-comment-widget'),
			scheme = document.body.className.match('wsite-theme-light');

		for (var i = 0; i < comments.length; i++) {
			comments[i].setAttribute('colorscheme', scheme ? 'light' : 'dark');
		}

		var fbCommentCounts;

		FB.Event.subscribe('xfbml.render', function(){
			fbCommentCounts = jQuery('.fb_comments_count');
			for (var i = 0; i < fbCommentCounts.length; i++) {
				var commentText = (jQuery(fbCommentCounts[i]).text() == '1' ? "Comment" : "Comments");
				jQuery(fbCommentCounts[i]).parent().siblings('.fb_comment_count_label').text(commentText);
			}
		});

		var comment_callback = function(res) {
			FB.XFBML.parse(); // Refresh comment counters on page
		}

		FB.Event.subscribe('comment.create', comment_callback);
		FB.Event.subscribe('comment.remove', comment_callback);

	};

	(function(d, s, id){
		var js, fjs = d.getElementsByTagName(s)[0];
		if (d.getElementById(id)) {return;}
		js = d.createElement(s); js.id = id;
		js.src = "//connect.facebook.net/"+_W.facebookLocale+"/sdk.js";
		fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));
</script>
<script type='text/javascript'>
	(function() {
		function j(src, id) {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.async = true;
			s.src = src;
			if(id) {s.id=id};
			document.getElementsByTagName('head')[0].appendChild(s);
		}
		j('//platform.twi'+'tter.com/widgets.js');
	})()
</script>
	</body>
</html>
