<!DOCTYPE html><html lang=en-US><head><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1"><link rel=profile href="https://gmpg.org/xfn/11"> <script>!function(e){var n={};function r(t){if(n[t])return n[t].exports;var o=n[t]={i:t,l:!1,exports:{}};return e[t].call(o.exports,o,o.exports,r),o.l=!0,o.exports}r.m=e,r.c=n,r.d=function(e,n,t){r.o(e,n)||Object.defineProperty(e,n,{enumerable:!0,get:t})},r.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},r.t=function(e,n){if(1&n&&(e=r(e)),8&n)return e;if(4&n&&"object"==typeof e&&e&&e.__esModule)return e;var t=Object.create(null);if(r.r(t),Object.defineProperty(t,"default",{enumerable:!0,value:e}),2&n&&"string"!=typeof e)for(var o in e)r.d(t,o,function(n){return e[n]}.bind(null,o));return t},r.n=function(e){var n=e&&e.__esModule?function(){return e.default}:function(){return e};return r.d(n,"a",n),n},r.o=function(e,n){return Object.prototype.hasOwnProperty.call(e,n)},r.p="",r(r.s=0)}([function(e,n){!function(e){var n=e.ampUrl,r=e.isCustomizePreview,t=e.isAmpDevMode,o=e.noampQueryVarName,i=e.noampQueryVarValue,a=e.disabledStorageKey,u=e.mobileUserAgents,s=e.regexRegex;if("undefined"!=typeof sessionStorage){var c=new RegExp(s);if(u.some((function(e){var n=e.match(c);if(n&&new RegExp(n[1],n[2]).test(navigator.userAgent))return!0;return navigator.userAgent.includes(e)}))){document.addEventListener("DOMContentLoaded",(function(){var e=document.getElementById("amp-mobile-version-switcher");if(e){e.hidden=!1;var n=e.querySelector("a[href]");n&&n.addEventListener("click",(function(){sessionStorage.removeItem(a)}))}}));var f=t&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(!(sessionStorage.getItem(a)||r||f)){var d=new URL(location.href);d.searchParams.has(o)&&i===d.searchParams.get(o)?sessionStorage.setItem(a,"1"):(window.stop(),location.replace(n))}}}}({"ampUrl":"http:\/\/www.linuxandubuntu.com\/home\/things-to-remember-before-upgrading-production-server?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}]);</script> <title>Things To Remember Before Upgrading Production Server</title><meta name=robots content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link rel=canonical href=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Things To Remember Before Upgrading Production Server"><meta property=og:description content="Server security is the topmost priority for every system administrator. Besides having third-party security tools like Firewall, DDoS protection, etc. it is extremely important to keep every piece of code up-to-date on your production server. When your application is in production, upgrading it is riskier. If your server is powered..."><meta property=og:url content=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server><meta property=og:site_name content="Linux Tutorials, FOSS Reviews, Security News"><meta property=article:published_time content=2020-11-04T19:44:51+00:00><meta property=article:modified_time content=2020-11-04T19:45:08+00:00><meta property=og:image content="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?fit=1200%2C675"><meta property=og:image:width content=1200><meta property=og:image:height content=675><meta name=twitter:card content=summary_large_image><meta name=twitter:creator content=@linuxandubuntu><meta name=twitter:site content=@linuxandubuntu><meta name=twitter:label1 content="Written by"><meta name=twitter:data1 content=Sohail><meta name=twitter:label2 content="Est. reading time"><meta name=twitter:data2 content="3 minutes"> <script type=application/ld+json class=yoast-schema-graph>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.linuxandubuntu.com/#website","url":"http://www.linuxandubuntu.com/","name":"Linux Tutorials, FOSS Reviews, Security News","description":"","publisher":{"@id":"http://www.linuxandubuntu.com/#/schema/person/0447fe091d706ec24eec0e743c2a6143"},"potentialAction":[{"@type":"SearchAction","target":"http://www.linuxandubuntu.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?fit=1200%2C675","width":1200,"height":675,"caption":"Things to remember before server upgrade"},{"@type":"WebPage","@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#webpage","url":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server","name":"Things To Remember Before Upgrading Production Server","isPartOf":{"@id":"http://www.linuxandubuntu.com/#website"},"primaryImageOfPage":{"@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#primaryimage"},"datePublished":"2020-11-04T19:44:51+00:00","dateModified":"2020-11-04T19:45:08+00:00","breadcrumb":{"@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server"]}]},{"@type":"BreadcrumbList","@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"http://www.linuxandubuntu.com/","url":"http://www.linuxandubuntu.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server","url":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server","name":"Things To Remember Before Upgrading Production Server"}}]},{"@type":"Article","@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#article","isPartOf":{"@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#webpage"},"author":{"@id":"http://www.linuxandubuntu.com/#/schema/person/0447fe091d706ec24eec0e743c2a6143"},"headline":"Things To Remember Before Upgrading Production Server","datePublished":"2020-11-04T19:44:51+00:00","dateModified":"2020-11-04T19:45:08+00:00","mainEntityOfPage":{"@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#webpage"},"commentCount":0,"publisher":{"@id":"http://www.linuxandubuntu.com/#/schema/person/0447fe091d706ec24eec0e743c2a6143"},"image":{"@id":"http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#primaryimage"},"articleSection":"Linux Tutorials","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#respond"]}]},{"@type":["Person","Organization"],"@id":"http://www.linuxandubuntu.com/#/schema/person/0447fe091d706ec24eec0e743c2a6143","name":"Sohail","image":{"@type":"ImageObject","@id":"http://www.linuxandubuntu.com/#personlogo","inLanguage":"en-US","url":"http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=96&d=mm&r=g","caption":"Sohail"},"logo":{"@id":"http://www.linuxandubuntu.com/#personlogo"},"description":"Mohd Sohail is a web developer and a Linux sysAdmin. He also loves to write how-to articles, applications reviews and loves to use new Linux distributions."}]}</script> <link rel=dns-prefetch href=//www.googletagmanager.com><link rel=dns-prefetch href=//fonts.googleapis.com><link rel=dns-prefetch href=//i0.wp.com><link rel=dns-prefetch href=//i1.wp.com><link rel=dns-prefetch href=//i2.wp.com><link rel=dns-prefetch href=//c0.wp.com><link rel=alternate type=application/rss+xml title="Linux Tutorials, FOSS Reviews, Security News &raquo; Feed" href=http://www.linuxandubuntu.com/feed><link rel=alternate type=application/rss+xml title="Linux Tutorials, FOSS Reviews, Security News &raquo; Comments Feed" href=http://www.linuxandubuntu.com/comments/feed><link rel=alternate type=application/rss+xml title="Linux Tutorials, FOSS Reviews, Security News &raquo; Things To Remember Before Upgrading Production Server Comments Feed" href=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server/feed><link rel=stylesheet id=wp-block-library-css href=https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/style.min.css type=text/css media=all><style id=wp-block-library-inline-css>.has-text-align-justify{text-align:justify}</style><link rel=stylesheet id=wp-block-library-theme-css href=https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/theme.min.css type=text/css media=all><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/28364.css media=all><style id=ez-toc-inline-css>div#ez-toc-container p.ez-toc-title{font-size:120%}div#ez-toc-container p.ez-toc-title{font-weight:500}div#ez-toc-container ul
li{font-size:95%}div#ez-toc-container{background:#fffff7;border:1px
solid #ddd;width:100%}div#ez-toc-container p.ez-toc-title{color:#999}div#ez-toc-container ul.ez-toc-list
a{color:#16a085}div#ez-toc-container ul.ez-toc-list a:hover{color:#19c157}div#ez-toc-container ul.ez-toc-list a:visited{color:#428bca}</style><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/46981.css media=all><link crossorigin=anonymous rel=stylesheet id=penci-fonts-css href='//fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMukta+Vaani%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CTeko%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMegrim%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CNunito%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext' type=text/css media=all><link rel=stylesheet id=penci-font-nunitovfbeta-css href='//fonts.googleapis.com/earlyaccess/nunitovfbeta.css?ver=6.5.9' type=text/css media=all><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/d6466.css media=all><style id=penci-style-inline-css>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</style><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/a74eb.css media=all><link rel=stylesheet id=jetpack_css-css href=https://c0.wp.com/p/jetpack/9.0.2/css/jetpack.css type=text/css media=all> <script src=https://c0.wp.com/c/5.5.3/wp-includes/js/jquery/jquery.js id=jquery-core-js></script> <script src='https://www.googletagmanager.com/gtag/js?id=UA-42740043-3' id=google_gtagjs-js async></script> <script id=google_gtagjs-js-after>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('set','linker',{"domains":["www.linuxandubuntu.com"]});gtag('js',new Date());gtag('set','developer_id.dZTNiMT',true);gtag('config','UA-42740043-3',{"anonymize_ip":true});</script> <link rel=EditURI type=application/rsd+xml title=RSD href=http://www.linuxandubuntu.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=http://www.linuxandubuntu.com/wp-includes/wlwmanifest.xml><meta name=generator content="WordPress 5.5.3"><link rel=shortlink href='http://www.linuxandubuntu.com/?p=25431'><link rel=alternate type=application/json+oembed href="http://www.linuxandubuntu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server"><link rel=alternate type=text/xml+oembed href="http://www.linuxandubuntu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server&#038;format=xml"><meta name=generator content="Site Kit by Google 1.19.0"><script>var portfolioDataJs=portfolioDataJs||[];var penciBlocksArray=[];var PENCILOCALCACHE={};(function(){"use strict";PENCILOCALCACHE={data:{},remove:function(ajaxFilterItem){delete PENCILOCALCACHE.data[ajaxFilterItem];},exist:function(ajaxFilterItem){return PENCILOCALCACHE.data.hasOwnProperty(ajaxFilterItem)&&PENCILOCALCACHE.data[ajaxFilterItem]!==null;},get:function(ajaxFilterItem){return PENCILOCALCACHE.data[ajaxFilterItem];},set:function(ajaxFilterItem,cachedData){PENCILOCALCACHE.remove(ajaxFilterItem);PENCILOCALCACHE.data[ajaxFilterItem]=cachedData;}};})();function penciBlock(){this.atts_json='';this.content='';}</script> <style>img#wpstats{display:none}</style> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TZNZ9MM');</script> <script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"organization","@id":"#organization","logo":"","url":"http:\/\/www.linuxandubuntu.com\/","name":"Linux Tutorials, FOSS Reviews, Security News","description":""}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WebSite","name":"Linux Tutorials, FOSS Reviews, Security News","alternateName":"","url":"http:\/\/www.linuxandubuntu.com\/"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Sidebar Right","alternateName":"Add widgets here to display them on blog and single","url":"http:\/\/www.linuxandubuntu.com\/home\/things-to-remember-before-upgrading-production-server"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Sidebar Left","alternateName":"Add widgets here to display them on page","url":"http:\/\/www.linuxandubuntu.com\/home\/things-to-remember-before-upgrading-production-server"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Footer Column #1","alternateName":"Add widgets here to display them in the first column of the footer","url":"http:\/\/www.linuxandubuntu.com\/home\/things-to-remember-before-upgrading-production-server"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Footer Column #2","alternateName":"Add widgets here to display them in the second column of the footer","url":"http:\/\/www.linuxandubuntu.com\/home\/things-to-remember-before-upgrading-production-server"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Footer Column #3","alternateName":"Add widgets here to display them in the third column of the footer","url":"http:\/\/www.linuxandubuntu.com\/home\/things-to-remember-before-upgrading-production-server"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"BlogPosting","headline":"Things To Remember Before Upgrading Production Server","description":"Server security is the topmost priority for every system administrator. Besides having third-party security tools like Firewall, DDoS protection, etc. it is extremely important to keep every piece of code up-to-date on your production server. When your application is in production, upgrading it is riskier. If your server is powered...","datePublished":"2020-11-05","datemodified":"2020-11-05","mainEntityOfPage":"http:\/\/www.linuxandubuntu.com\/home\/things-to-remember-before-upgrading-production-server","image":{"@type":"ImageObject","url":"https:\/\/i1.wp.com\/www.linuxandubuntu.com\/wp-content\/uploads\/2020\/11\/Things-to-remember-before-server-upgrade.png?fit=1200%2C675","width":1200,"height":675},"publisher":{"@type":"Organization","name":"Linux Tutorials, FOSS Reviews, Security News"},"author":{"@type":"Person","@id":"#person-Sohail","name":"Sohail"}}</script><meta property=fb:app_id content=348280475330978> <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:'/'};OneSignal.setDefaultNotificationUrl("http://www.linuxandubuntu.com");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options['wordpress']=true;oneSignal_options['appId']='a1705b21-de0a-4fad-92c1-6bb270274512';oneSignal_options['welcomeNotification']={};oneSignal_options['welcomeNotification']['title']="";oneSignal_options['welcomeNotification']['message']="";oneSignal_options['subdomainName']="linuxandubuntu";oneSignal_options['persistNotification']=false;oneSignal_options['promptOptions']={};oneSignal_options['promptOptions']['actionMessage']='Subscribe to our push notifications and never miss any latest article.';OneSignal.init(window._oneSignalInitOptions);OneSignal.showSlidedownPrompt();});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault();};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,false);}
if(document.readyState==='complete'){documentInitOneSignal();}
else{window.addEventListener("load",function(event){documentInitOneSignal();});}</script> <meta name=generator content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."><style>html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image{display:none}</style> <script>document.documentElement.classList.add('jetpack-lazy-images-js-enabled');</script> <link rel=amphtml href=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server/amp><style>#amp-mobile-version-switcher{position:absolute;width:100%;left:0;z-index:100}#amp-mobile-version-switcher>a{display:block;padding:15px
0;font-family:-apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;font-size:16px;font-weight:600;color:#eaeaea;text-align:center;text-decoration:none;background-color:#444;border:0}#amp-mobile-version-switcher>a:hover,#amp-mobile-version-switcher>a:focus,#amp-mobile-version-switcher>a:active{text-decoration:underline}</style><link rel=alternate type=text/html media="only screen and (max-width: 640px)" href="http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server?amp=1"><link rel=icon href="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=32%2C32" sizes=32x32><link rel=icon href="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=192%2C192" sizes=192x192><link rel=apple-touch-icon href="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=180%2C180"><meta name=msapplication-TileImage content="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=270%2C270"> <noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><style>a.custom-button.pencisc-button{background:transparent;color:#D3347B;border:2px
solid #D3347B;line-height:36px;padding:0
20px;font-size:14px;font-weight:bold}a.custom-button.pencisc-button:hover{background:#D3347B;color:#fff;border:2px
solid #D3347B}a.custom-button.pencisc-button.pencisc-small{line-height:28px;font-size:12px}a.custom-button.pencisc-button.pencisc-large{line-height:46px;font-size:18px}</style></head><body class="post-template-default single single-post postid-25431 single-format-standard group-blog header-sticky penci-body-boxed penci_enable_ajaxsearch penci_sticky_content_sidebar sidebar-right penci-single-style-1 penci-disalp-mobile penci-caption-above-img wpb-js-composer js-comp-ver-6.2.0 vc_responsive"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TZNZ9MM" height=0 width=0 style=display:none;visibility:hidden></iframe></noscript><div id=page class="site penci-enable-boxed"><div class="penci-topbar clearfix style-1"><div class="penci-topbar_container penci-container-fullwidth"><div class=penci-topbar__left><div class="topbar_item topbar__menu"><ul id=menu-top-bar class=menu><li id=menu-item-25126 class="menu-item menu-item-type-post_type menu-item-object-post menu-item-25126"><a href=http://www.linuxandubuntu.com/home/passwordless-login-vs-password-login>Passwordless Login Vs. Password Login – Good &#038; Bad</a></li></ul></div></div><div class=penci-topbar__right><div class="topbar_item topbar__social-media"> <a class="social-media-item socail_media__facebook" target=_blank href=https://www.facebook.com/linuxandubuntuofficial title=Facebook rel=noopener><span class=socail-media-item__content><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target=_blank href=https://twitter.com/linuxandubuntu title=Twitter rel=noopener><span class=socail-media-item__content><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a><a class="social-media-item socail_media__pinterest" target=_blank href="https://www.pinterest.com/linuxandubuntu" title=Pinterest rel=noopener><span class=socail-media-item__content><i class="fa fa-pinterest"></i><span class="social_title screen-reader-text">Pinterest</span></span></a><a class="social-media-item socail_media__linkedin" target=_blank href=https://www.linkedin.com/in/mohdsohail title=Linkedin rel=noopener><span class=socail-media-item__content><i class="fa fa-linkedin"></i><span class="social_title screen-reader-text">Linkedin</span></span></a><a class="social-media-item socail_media__youtube" target=_blank href=https://www.youtube.com/linuxandubuntuweb title=Youtube rel=noopener><span class=socail-media-item__content><i class="fa fa-youtube-play"></i><span class="social_title screen-reader-text">Youtube</span></span></a><a class="social-media-item socail_media__rss" target=_blank href=http://www.linuxandubuntu.com/feed/rss title=Rss rel=noopener><span class=socail-media-item__content><i class="fa fa-rss"></i><span class="social_title screen-reader-text">Rss</span></span></a></div></div></div></div><div class=site-header-wrapper><div class="header__top header--s2"><div class="penci-container-fluid header-top__container"><div class=site-branding><h2 class="site-title"><a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></h2></div><div class=header__banner> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:inline-block;width:728px;height:90px data-ad-client=ca-pub-1925104690687996 data-ad-slot=8182063423></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div></div><header id=masthead class="site-header header--s2" data-height=80 itemscope=itemscope itemtype=http://schema.org/WPHeader><div class="penci-container-fluid header-content__container"><nav id=site-navigation class="main-navigation pencimn-slide_down" itemscope itemtype=http://schema.org/SiteNavigationElement><ul id=menu-main-menu class=menu><li id=menu-item-9637 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9637"><a href=http://www.linuxandubuntu.com itemprop=url>Home</a></li><li id=menu-item-16021 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu penci-megamenu-fullwidth menu-item-16021"><a href=http://www.linuxandubuntu.com/home/category/distros itemprop=url>Linux Distributions</a><ul class=sub-menu><li id=menu-item-0 class=menu-item-0><div class=penci-megamenu><div class="penci-content-megamenu penci-content-megamenu-style-1"><div class="penci-mega-latest-posts col-mn-8 mega-row-1 "><div class="penci-mega-row penci-mega-162 row-active" data-current=1 data-blockUid=penci_megamenu__13617><div id=penci_megamenu__13617block_content class="penci-block_content penci-mega-row_content"><div class="penci-mega-post penci-mega-post-1 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/08/Kali-Linux-2020.3-released.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/kali-linux-2020-3-released title="Kali Linux 2020.3 Released With Bluetooth Arsenal in NetHunter, Automating HiDPI Support, New Shell &#038; More"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/kali-linux-2020-3-released>Kali Linux 2020.3 Released With Bluetooth Arsenal in&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-2 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/07/whats-new-in-Linux-Mint-20.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/linux-mint-20-ulyana-released title="What&#8217;s New In Linux Mint 20 &#8220;Ulyana&#8221;"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/linux-mint-20-ulyana-released>What&#8217;s New In Linux Mint 20 &#8220;Ulyana&#8221;</a></h3></div></div><div class="penci-mega-post penci-mega-post-3 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Ubuntu-20.04-available-to-download.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/ubuntu-20-04-focal-fossa-released title="Ubuntu 20.04 &#8220;Focal Fossa&#8221; LTS Available To Download"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/ubuntu-20-04-focal-fossa-released>Ubuntu 20.04 &#8220;Focal Fossa&#8221; LTS Available To Download</a></h3></div></div><div class="penci-mega-post penci-mega-post-4 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/EndeavourOS-Learn-Arch-right-way.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/endeavouros-learn-arch-right-way title="EndeavourOS &#8211; Learn Arch The Right Way"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/endeavouros-learn-arch-right-way>EndeavourOS &#8211; Learn Arch The Right Way</a></h3></div></div><div class="penci-mega-post penci-mega-post-5 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/AntiX-lightweight-linux-distribution.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/antix-lightweight-linux-systemd-free title="AntiX &#8211; A Lightweight systemd-free Linux distribution for old computers"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/antix-lightweight-linux-systemd-free>AntiX &#8211; A Lightweight systemd-free Linux distribution for&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-6 penci-imgtype-landscape"><div class=penci-mega-thumbnail><div class=icon-post-format><i class="fa fa-play"></i></div><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/UbuntuDDE.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/ubuntudde-beta-released title="Ubuntu 20.04 + Depin &#8212; Perfect combination for a beautiful Linux distro"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/ubuntudde-beta-released>Ubuntu 20.04 + Depin &#8212; Perfect combination for&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-7 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Linux-Mint-20-Ulyana.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/linux-mint-20-codenamed-ulyana title="Linux Mint 20 Codenamed Ulyana &#038; More"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/linux-mint-20-codenamed-ulyana>Linux Mint 20 Codenamed Ulyana &#038; More</a></h3></div></div><div class="penci-mega-post penci-mega-post-8 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/03/Obarun-Arch-without-systemd.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/obarun-arch-based-linux-distro-without-systemd title="Obarun &#8211; An Arch Based Linux Distro Without Systemd"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/obarun-arch-based-linux-distro-without-systemd>Obarun &#8211; An Arch Based Linux Distro Without&#8230;</a></h3></div></div><div class="penci-loader-effect penci-loading-animation-7"><div class=penci-loading-animation></div><div class="penci-loading-animation penci-loading-animation-inner-2"></div><div class="penci-loading-animation penci-loading-animation-inner-3"></div><div class="penci-loading-animation penci-loading-animation-inner-4"></div><div class="penci-loading-animation penci-loading-animation-inner-5"></div><div class="penci-loading-animation penci-loading-animation-inner-6"></div><div class="penci-loading-animation penci-loading-animation-inner-7"></div><div class="penci-loading-animation penci-loading-animation-inner-8"></div><div class="penci-loading-animation penci-loading-animation-inner-9"></div></div></div> <script>if(typeof(penciBlock)==="undefined"){function penciBlock(){this.atts_json='';this.content='';}}var penciBlocksArray=penciBlocksArray||[];var PENCILOCALCACHE=PENCILOCALCACHE||{};var penci_megamenu__13617=new penciBlock();penci_megamenu__13617.blockID="penci_megamenu__13617";penci_megamenu__13617.atts_json='{"showposts":8,"style_pag":"next_prev","post_types":"post","block_id":"penci_megamenu__13617","paged":1,"unique_id":"penci_megamenu__13617","shortcode_id":"megamenu","cat_id":162,"tax":"category","category_ids":"","taxonomy":""}';penciBlocksArray.push(penci_megamenu__13617);</script> <span class=penci-slider-nav> <a class="penci-mega-pag penci-slider-prev penci-pag-disabled" data-block_id=penci_megamenu__13617block_content href=#><i class="fa fa-angle-left"></i></a> <a class="penci-mega-pag penci-slider-next " data-block_id=penci_megamenu__13617block_content href=#><i class="fa fa-angle-right"></i></a> </span></div><div class="penci-loader-effect penci-loading-animation-7"><div class=penci-loading-animation></div><div class="penci-loading-animation penci-loading-animation-inner-2"></div><div class="penci-loading-animation penci-loading-animation-inner-3"></div><div class="penci-loading-animation penci-loading-animation-inner-4"></div><div class="penci-loading-animation penci-loading-animation-inner-5"></div><div class="penci-loading-animation penci-loading-animation-inner-6"></div><div class="penci-loading-animation penci-loading-animation-inner-7"></div><div class="penci-loading-animation penci-loading-animation-inner-8"></div><div class="penci-loading-animation penci-loading-animation-inner-9"></div></div></div></div></div></li></ul></li><li id=menu-item-21700 class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu penci-megamenu-width1080 menu-item-21700"><a href=http://www.linuxandubuntu.com/home/category/linux/themes itemprop=url>Linux Themes</a><ul class=sub-menu><li class=menu-item-0><div class=penci-megamenu><div class="penci-content-megamenu penci-content-megamenu-style-1"><div class="penci-mega-latest-posts col-mn-5 mega-row-1 "><div class="penci-mega-row penci-mega-3892 row-active" data-current=1 data-blockUid=penci_megamenu__32917><div id=penci_megamenu__32917block_content class="penci-block_content penci-mega-row_content"><div class="penci-mega-post penci-mega-post-1 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/plataro-master-icons-for-ubuntu.png?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/plataro-master-icon-theme-install-in-ubuntu-1604 title="Plataro Master Icon Theme Install In Ubuntu 16.04"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/plataro-master-icon-theme-install-in-ubuntu-1604>Plataro Master Icon Theme Install In Ubuntu 16.04</a></h3></div></div><div class="penci-mega-post penci-mega-post-2 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/unity-8-theme-for-ubuntu-unity-1.jpg?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/unity-8-theme-for-ubuntu-unity title="﻿Unity 8 Theme For Ubuntu Unity"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/unity-8-theme-for-ubuntu-unity>﻿Unity 8 Theme For Ubuntu Unity</a></h3></div></div><div class="penci-mega-post penci-mega-post-3 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/osx-theme-for-ubuntu-linux.jpg?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/make-linux-look-like-osx-with-osx-arc-collection title="Make Linux Look Like OSX With OSX Arc Collection"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/make-linux-look-like-osx-with-osx-arc-collection>Make Linux Look Like OSX With OSX Arc&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-4 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/07/10-best-icon-themes-for-linux.jpg?resize=280%2C186);" data-delay href=http://www.linuxandubuntu.com/home/10-best-icon-themes-for-linux title="10 Best Icon Themes For Linux"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/10-best-icon-themes-for-linux>10 Best Icon Themes For Linux</a></h3></div></div><div class="penci-mega-post penci-mega-post-5 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-disable-lazy" style="background-image: url(http://www.linuxandubuntu.com/wp-content/themes/pennews/images/no-thumb.jpg);" data-delay href=http://www.linuxandubuntu.com/home/adwaita-grey-31411-theme-updated-install-in-ubuntu title="Adwaita-Grey 3.14.11 Theme Updated Install In Ubuntu"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/adwaita-grey-31411-theme-updated-install-in-ubuntu>Adwaita-Grey 3.14.11 Theme Updated Install In Ubuntu</a></h3></div></div><div class="penci-loader-effect penci-loading-animation-7"><div class=penci-loading-animation></div><div class="penci-loading-animation penci-loading-animation-inner-2"></div><div class="penci-loading-animation penci-loading-animation-inner-3"></div><div class="penci-loading-animation penci-loading-animation-inner-4"></div><div class="penci-loading-animation penci-loading-animation-inner-5"></div><div class="penci-loading-animation penci-loading-animation-inner-6"></div><div class="penci-loading-animation penci-loading-animation-inner-7"></div><div class="penci-loading-animation penci-loading-animation-inner-8"></div><div class="penci-loading-animation penci-loading-animation-inner-9"></div></div></div> <script>if(typeof(penciBlock)==="undefined"){function penciBlock(){this.atts_json='';this.content='';}}var penciBlocksArray=penciBlocksArray||[];var PENCILOCALCACHE=PENCILOCALCACHE||{};var penci_megamenu__32917=new penciBlock();penci_megamenu__32917.blockID="penci_megamenu__32917";penci_megamenu__32917.atts_json='{"showposts":5,"style_pag":"next_prev","post_types":"post","block_id":"penci_megamenu__32917","paged":1,"unique_id":"penci_megamenu__32917","shortcode_id":"megamenu","cat_id":3892,"tax":"category","category_ids":"","taxonomy":""}';penciBlocksArray.push(penci_megamenu__32917);</script> <span class=penci-slider-nav> <a class="penci-mega-pag penci-slider-prev penci-pag-disabled" data-block_id=penci_megamenu__32917block_content href=#><i class="fa fa-angle-left"></i></a> <a class="penci-mega-pag penci-slider-next " data-block_id=penci_megamenu__32917block_content href=#><i class="fa fa-angle-right"></i></a> </span></div><div class="penci-loader-effect penci-loading-animation-7"><div class=penci-loading-animation></div><div class="penci-loading-animation penci-loading-animation-inner-2"></div><div class="penci-loading-animation penci-loading-animation-inner-3"></div><div class="penci-loading-animation penci-loading-animation-inner-4"></div><div class="penci-loading-animation penci-loading-animation-inner-5"></div><div class="penci-loading-animation penci-loading-animation-inner-6"></div><div class="penci-loading-animation penci-loading-animation-inner-7"></div><div class="penci-loading-animation penci-loading-animation-inner-8"></div><div class="penci-loading-animation penci-loading-animation-inner-9"></div></div></div></div></div></li></ul></li><li id=menu-item-17077 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-17077"><a href=http://www.linuxandubuntu.com/home/category/linux-tutorials itemprop=url>Linux Tutorials</a></li><li id=menu-item-8337 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-8337"><a href=http://www.linuxandubuntu.com/faqs itemprop=url>Linux FAQs</a></li><li id=menu-item-9733 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9733"><a href=http://www.linuxandubuntu.com/advertise itemprop=url>Advertise</a></li><li id=menu-item-9636 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9636"><a href=http://www.linuxandubuntu.com/contact-us itemprop=url>Contact us</a></li></ul></nav></div></header></div><div class="penci-header-mobile mobile"><div class=penci-header-mobile_container> <button class="menu-toggle navbar-toggle" aria-expanded=false><span class=screen-reader-text>Primary Menu</span><i class="fa fa-bars"></i></button><div class=site-branding><div class=site-title><a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></div></div></div></div><div id=content class=site-content><div id=primary class=content-area><main id=main class=site-main><div class=penci-container><div class="penci-container__content penci-con_sb1_sb2"><div class="penci-wide-content penci-content-novc penci-sticky-content penci-content-single-inner"><div class=theiaStickySidebar><div class="penci-content-post noloaddisqus " data-url=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server data-id=25431 data-title> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-1925104690687996 data-ad-slot=7903274511 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br><div class="penci_breadcrumbs "><ul itemscope itemtype=http://schema.org/BreadcrumbList><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem><a class=home href=http://www.linuxandubuntu.com itemprop=item><span itemprop=name>Home</span></a><meta itemprop=position content=1></li><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem><i class="fa fa-angle-right"></i><a href=http://www.linuxandubuntu.com/home/category/linux-tutorials itemprop=item><span itemprop=name>Linux Tutorials</span></a><meta itemprop=position content=2></li><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem><i class="fa fa-angle-right"></i><a href=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server itemprop=item><span itemprop=name>Things To Remember Before Upgrading Production Server</span></a><meta itemprop=position content=3></li></ul></div><article id=post-25431 class="penci-single-artcontent noloaddisqus post-25431 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-tutorials penci-post-item"><header class="entry-header penci-entry-header penci-title-"><div class=penci-entry-categories><span class=penci-cat-links><a href=http://www.linuxandubuntu.com/home/category/linux-tutorials rel="category tag">Linux Tutorials</a></span></div><h1 class="entry-title penci-entry-title penci-title-">Things To Remember Before Upgrading Production Server</h1><div class="entry-meta penci-entry-meta"> <span class="entry-meta-item penci-byline">by <span class="author vcard"><a class="url fn n" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span></span><span class="entry-meta-item penci-posted-on"><i class="fa fa-clock-o"></i><time class="entry-date published" datetime=2020-11-05T01:15:08+05:30>November 5, 2020</time><time class=updated datetime=2020-11-05T01:15:08+05:30>November 5, 2020</time></span><span class="entry-meta-item penci-comment-count"><a class=penci_pmeta-link href=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server#respond><i class="la la-comments"></i>0</a></span></div></header><div class="entry-media penci-entry-media"><div class="post-format-meta "><div class="post-image penci-standard-format"><img width=960 height=540 src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?fit=960%2C540" class="attachment-penci-thumb-960-auto size-penci-thumb-960-auto wp-post-image jetpack-lazy-image" alt="Things to remember before server upgrade" loading=lazy data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?w=1200 1200w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?resize=300%2C169 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?resize=1024%2C576 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?resize=768%2C432 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?resize=960%2C540 960w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?resize=711%2C400 711w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?resize=585%2C329 585w" data-lazy-sizes="(max-width: 960px) 100vw, 960px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Things-to-remember-before-server-upgrade.png?fit=960%2C540&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7></div></div></div><div class="penci-entry-content entry-content"><p>Server security is the topmost priority for every system administrator. Besides having third-party security tools like Firewall, DDoS protection, etc. it is extremely important to keep every piece of code up-to-date on your production server.</p><p>When your application is in production, upgrading it is riskier. If your server is powered by Linux, Linux distributions keep releasing new versions every now and then. Each major release contains bug fixes, security updates, and new tools.</p><p>Upgrading a production server without any preparation is a big mistake. An unprepared upgrade can cause permanent data loss, poor server performance, and customer loss. In this article, I will list some important steps to take before initiating a server upgrade.</p><div id=ez-toc-container class="ez-toc-v2_0_11 counter-hierarchy counter-decimal"><div class=ez-toc-title-container><p class=ez-toc-title>Table of Contents</p> <span class=ez-toc-title-toggle><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div><nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href=#Things_to_do_before_upgrading_a_production_server title="Things to do before upgrading a production server">Things to do before upgrading a production server</a><ul class=ez-toc-list-level-3><li class=ez-toc-heading-level-3><a class="ez-toc-link ez-toc-heading-2" href=#Prepare_full_backup title="Prepare full backup">Prepare full backup</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-3" href=#Software_compatibility title="Software compatibility">Software compatibility</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-4" href=#Setup_temporary_server title="Setup temporary server">Setup temporary server</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-5" href=#Set_up_load_balancer title="Set up load balancer">Set up load balancer</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-6" href=#Start_server_upgrade_when_the_least_traffic_is_on_site title="Start server upgrade when the least traffic is on site">Start server upgrade when the least traffic is on site</a></li></ul></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-7" href=#Conclusion title=Conclusion>Conclusion</a></li></ul></nav></div><h2><span class=ez-toc-section id=Things_to_do_before_upgrading_a_production_server></span>Things to do before upgrading a production server<span class=ez-toc-section-end></span></h2><p>Just recently I upgraded one of my clients&#8217; server and it was a Ubuntu server. His e-commerce website receives a decent amount of traffic and has been around for almost a year now.</p><p>I decided to upgrade his server from Ubuntu 18.04 to 20.04 LTS. The actual upgrade took about 30 minutes but the preparation took longer. As a result, the upgrade was smooth without any downtime.</p><h3><span class=ez-toc-section id=Prepare_full_backup></span>Prepare full backup<span class=ez-toc-section-end></span></h3><p>Backing up just the website or the entire server should be the daily task. Before upgrading, make sure your website is fully backed up in the cloud or locally. Recently, I listed some of the greatest backup plugins for WordPress. If your website is powered by WordPress, read the article <a href=http://www.linuxandubuntu.com/home/best-wordpress-backup-plugins target=_blank rel="noreferrer noopener">best backup plugins for WordPress</a>.</p><figure class="wp-block-image size-large"><img loading=lazy width=1024 height=576 src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=1024%2C576" alt="Create server backup" class="wp-image-26663 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=1024%2C576 1024w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=300%2C169 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=768%2C432 768w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=960%2C540 960w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=711%2C400 711w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=585%2C329 585w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?w=1200 1200w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=1024%2C576&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img loading=lazy width=1024 height=576 src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=1024%2C576" alt="Create server backup" class=wp-image-26663 srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=1024%2C576 1024w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=300%2C169 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=768%2C432 768w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=960%2C540 960w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=711%2C400 711w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?resize=585%2C329 585w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/11/Create-server-backup.png?w=1200 1200w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims=1></noscript><figcaption>Create server backup</figcaption></figure><p>If you are using any other CMS, create a backup of the application. If you are using cPanel based web hosting, there should be an option to create a full backup of the entire server. Creating full backup from cPanel is the easiest way.</p><p>If you are using any of the cPanels that I have covered in my <a href=http://www.linuxandubuntu.com/home/category/linux-cpanels target=_blank rel="noreferrer noopener">cPanel series</a>, they all have options to create a full backup. All of these Linux cPanles are free and <a href=http://www.linuxandubuntu.com/home/open-source-vs-closed-source>open source</a>. Just let me know if you have any trouble with anyone of the cPanels I have reviewed, I will help you out.</p><p>Once you have a complete backup of your server, you can proceed to the next step.</p><h3><span class=ez-toc-section id=Software_compatibility></span>Software compatibility<span class=ez-toc-section-end></span></h3><p>The newer Linux distribution may have removed or replaced tools that your website or CMS uses. Mostly, popular CMS like WordPress will not have any issue. If you have a custom CMS that might be using a certain library, make sure it still exists in the newer version of the operating system.</p><h3><span class=ez-toc-section id=Setup_temporary_server></span>Setup temporary server<span class=ez-toc-section-end></span></h3><p>The entire purpose of this article is to upgrade a live server without any downtime. While the server is upgrading, it may restart multiple times hence the website will not open during the restart. The best way to avoid it from happening is to create a separate server and restore your website on the new server.</p><p>You can restore the backup on the new server and point the domain name to the new server temporarily. During the upgrade, visitors will visit the temporary website instead of the main.</p><p>We have already covered <a href=http://www.linuxandubuntu.com/home/migrate-wordpress-to-new-hosting-easy-ways target=_blank rel="noreferrer noopener">how to migrate a WordPress website </a>from one server to another in detail.</p><h3><span class=ez-toc-section id=Set_up_load_balancer></span>Set up load balancer<span class=ez-toc-section-end></span></h3><p>Load balancer is the best way to manage traffic on your website and make sure every visitor accesses the site no matter what&#8217;s happening on the server. Load balancer may cost a little but worth using if you receive a large amount of traffic on your website.</p><p>During the upgrade, we can use premium load balancer services and redirect all the traffic to our temporary server without changing domain settings.</p><p>If you use the Cloudflare firewall, you are in luck. <a href=https://support.cloudflare.com/hc/en-us/articles/115005254367-Billing-for-Cloudflare-Load-Balancing target=_blank rel="noreferrer noopener">Cloudflare provides load balancing</a> at a cost of $5/month. It&#8217;s cheap and you can cancel it anytime.</p><p>Enter the IP address of main website server and temporary server in load balancer. After successfully connecting servers with the load balancer, it will redirect the visitors to the website tha&#8217;t is functioning properly.</p><p>In case your main server does not respond during the update, load balancer will serve visitors temporary website. After the server has been upgraded, we can remove the temporary server.</p><h3><span class=ez-toc-section id=Start_server_upgrade_when_the_least_traffic_is_on_site></span>Start server upgrade when the least traffic is on site<span class=ez-toc-section-end></span></h3><p>Even though the above points will prevent your services from going down, still it is better to start the upgrade when you receive the least traffic on site. You can use Google Analytics or any other website analytics service you&#8217;ve connected with your website.</p><h2><span class=ez-toc-section id=Conclusion></span>Conclusion<span class=ez-toc-section-end></span></h2><p>Once the server has been upgraded, you can point the domain name to the main server and remove the temporary server after a few hours. If you did not change the domain settings and used a load balancer instead, you can delete the temporary server and remove the temporary server&#8217;s IP address from the load balancer.</p><p>A failed upgrade can cause a real problem for your services. It is extremely important to plan server upgrades and prevent losing any data during the upgrade.</p><div class="penci-google-adsense penci_single_ad_after_content"><a href=https://t.me/linuxandubuntu target=_blank><img src=http://www.linuxandubuntu.com/wp-content/uploads/2020/09/join-telegram-channel.png></a> <br><br>LinuxAndUbuntu hosting is sponsored by massiveGRID<a href="https://portal.massivegrid.com/link.php?id=2" target=_blank><img src=https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/MassiveGRID-Banner.jpg></a></div></div><footer class=penci-entry-footer><div class=penci-source-via-tags-wrap></div><span class="penci-social-buttons penci-social-share-footer penci-social-share-center"><span class=penci-social-share-text>Share</span><a href=# class="penci-post-like penci_post-meta_item  single-like-button penci-social-item like" data-post_id=25431 title=Like data-like=Like data-unlike=Unlike><i class="fa fa-thumbs-o-up"></i><span class=penci-share-number>0</span></a><a class="penci-social-item facebook" target=_blank rel=noopener title href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server"><i class="fa fa-facebook"></i></a><a class="penci-social-item twitter" target=_blank rel=noopener title href="https://twitter.com/intent/tweet?text=Things%20To%20Remember%20Before%20Upgrading%20Production%20Server%20-%20http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server"><i class="fa fa-twitter"></i></a><a class="penci-social-item google_plus" target=_blank rel=noopener title href="https://plus.google.com/share?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server"><i class="fa fa-google-plus"></i></a><a class="penci-social-item pinterest" target=_blank rel=noopener title href="https://pinterest.com/pin/create/button?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server&#038;media=http%3A%2F%2Fwww.linuxandubuntu.com%2Fwp-content%2Fuploads%2F2020%2F11%2FThings-to-remember-before-server-upgrade.png&#038;description=Things%20To%20Remember%20Before%20Upgrading%20Production%20Server"><i class="fa fa-pinterest"></i></a><a class="penci-social-item linkedin" target=_blank rel=noopener title href="https://www.linkedin.com/shareArticle?mini=true&#038;url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server&#038;title=Things%20To%20Remember%20Before%20Upgrading%20Production%20Server"><i class="fa fa-linkedin"></i></a><a class="penci-social-item tumblr" target=_blank rel=noopener title href="https://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server&#038;name=Things%20To%20Remember%20Before%20Upgrading%20Production%20Server"><i class="fa fa-tumblr"></i></a><a class="penci-social-item reddit" target=_blank rel=noopener title href="https://reddit.com/submit?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server&#038;title=Things%20To%20Remember%20Before%20Upgrading%20Production%20Server"><i class="fa fa-reddit"></i></a><a class="penci-social-item telegram" target=_blank rel=noopener title href="https://telegram.me/share/url?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fthings-to-remember-before-upgrading-production-server&#038;text=Things%20To%20Remember%20Before%20Upgrading%20Production%20Server"><i class="fa fa-telegram"></i></a><a class="penci-social-item email" target=_blank rel=noopener href="/cdn-cgi/l/email-protection#ac93dfd9cec6c9cfd891f8c4c5c2cbdf899e9cf8c3899e9cfec9c1c9c1cec9de899e9ceec9cac3dec9899e9cf9dccbdecdc8c5c2cb899e9cfcdec3c8d9cfd8c5c3c2899e9cffc9dedac9de8a8f9c9f9497eee3e8f591c4d8d8dc968383dbdbdb82c0c5c2d9d4cdc2c8d9ced9c2d8d982cfc3c183c4c3c1c983d8c4c5c2cbdf81d8c381dec9c1c9c1cec9de81cec9cac3dec981d9dccbdecdc8c5c2cb81dcdec3c8d9cfd8c5c3c281dfc9dedac9de"><i class="fa fa-envelope"></i></a></span></footer></article> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-1925104690687996 data-ad-slot=3191286661></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <div class=penci-post-pagination><div class=prev-post><div class="prev-post-inner penci_mobj__body"><div class=prev-post-title> <span><i class="fa fa-angle-left"></i>previous post</span></div><div class=pagi-text><h5 class="prev-title"><a href=http://www.linuxandubuntu.com/home/git-remote-add-with-another-ssh-port-not-22>Git Remote Add With Another SSH Port (Not 22)</a></h5></div></div></div></div><div class="penci-post-author penci_media_object"><div class="author-img penci_mobj__img"> <img alt src="https://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=100&#038;d=mm&#038;r=g" class="avatar avatar-100 photo jetpack-lazy-image" height=100 width=100 loading=lazy data-lazy-srcset="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=200&#038;d=mm&#038;r=g 2x" data-lazy-src="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=100&amp;is-pending-load=1#038;d=mm&#038;r=g"><img alt src="https://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=100&#038;d=mm&#038;r=g" class='avatar avatar-100 photo' height=100 width=100 loading=lazy></div><div class="penci-author-content penci_mobj__body"><h5><a href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye title="Posts by Sohail" rel=author>Sohail</a></h5><div class=author-description> Mohd Sohail is a web developer and a Linux sysAdmin. He also loves to write how-to articles, applications reviews and loves to use new Linux distributions.</div><div class=author-socials></div></div></div><div id=wordpress-25431-comment class="active multi-wordpress-comment penci-tab-pane"><div class="post-comments  post-comments-25431  no-comment-yet" id=comments><div class=comments></div><div id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel=nofollow id=cancel-comment-reply-link href=/home/things-to-remember-before-upgrading-production-server#respond style=display:none;>Cancel Reply</a></small></h3><form action=http://www.linuxandubuntu.com/wp-comments-post.php method=post id=commentform class=comment-form novalidate><p class=comment-form-comment><textarea id=comment name=comment cols=45 rows=8 placeholder="Your Comment" aria-required=true></textarea></p><p class=comment-form-author><input id=author name=author type=text value placeholder=Name* size=30 aria-required=true></p><p class=comment-form-email><input id=email name=email type=text value placeholder=Email* size=30 aria-required=true></p><p class=comment-form-url><input id=url name=url type=text value placeholder=Website size=30></p><p class=comment-form-cookies-consent><input id=wp-comment-cookies-consent name=wp-comment-cookies-consent type=checkbox value=yes><span>Save my name, email, and website in this browser for the next time I comment.</span></p><div class=penci-gdpr-message>* By using this form you agree with the storage and handling of your data by this website.</div><p class=form-submit><input name=submit type=submit id=submit class=submit value=Submit> <input type=hidden name=comment_post_ID value=25431 id=comment_post_ID> <input type=hidden name=comment_parent id=comment_parent value=0></p><p style="display: none;"><input type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=3a952d890d></p><p style="display: none;"><input type=hidden id=ak_js name=ak_js value=148></p></form></div></div></div></div></div></div><aside class="widget-area widget-area-1 penci-sticky-sidebar penci-sidebar-widgets"><div class=theiaStickySidebar><div id=penci_custom_html-2 class="widget_text widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_custom_html"><div class="textwidget custom-html-widget"><script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:inline-block;width:336px;height:280px data-ad-client=ca-pub-1925104690687996 data-ad-slot=5196807437></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><style>#penci_custom_html-2.widget{padding:0
!important;background-color:transparent !important}#penci_custom_html-2.style-title-8:not(.footer-widget) .penci-block__title:before,#penci_custom_html-2.style-title-1:not(.footer-widget) .penci-block__title:before{right:0;left:0}</style><div id=search-4 class="widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_search"><form method=get class=search-form action=http://www.linuxandubuntu.com/> <label> <span class=screen-reader-text>Search for:</span> <input type=search class=search-field placeholder="Enter keyword..." value name=s> </label> <button type=submit class=search-submit> <i class="fa fa-search"></i> <span class=screen-reader-text>Search</span> </button></form></div><div id=penci_custom_html-3 class="widget_text widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_custom_html"><div class="textwidget custom-html-widget"><script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:inline-block;width:336px;height:280px data-ad-client=ca-pub-1925104690687996 data-ad-slot=8811004412></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><style>#penci_custom_html-3.widget{padding:0
!important;background-color:transparent !important}#penci_custom_html-3.style-title-8:not(.footer-widget) .penci-block__title:before,#penci_custom_html-3.style-title-1:not(.footer-widget) .penci-block__title:before{right:0;left:0}</style><div id=recent-posts-4 class="widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_recent_entries"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>Recent Posts</span></h4></div><ul><li> <a href=http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server aria-current=page>Things To Remember Before Upgrading Production Server</a></li><li> <a href=http://www.linuxandubuntu.com/home/git-remote-add-with-another-ssh-port-not-22>Git Remote Add With Another SSH Port (Not 22)</a></li><li> <a href=http://www.linuxandubuntu.com/home/install-and-remove-software-in-manjaro>Install And Remove Software In Manjaro</a></li><li> <a href=http://www.linuxandubuntu.com/home/install-lamp-on-manjaro>Install LAMP On Manjaro</a></li><li> <a href=http://www.linuxandubuntu.com/home/best-torrent-clients-for-linux>Best Torrent Clients For Linux</a></li><li> <a href=http://www.linuxandubuntu.com/home/best-wordpress-backup-plugins>Best WordPress Backup Plugins 2020</a></li><li> <a href=http://www.linuxandubuntu.com/home/setup-email-server-with-virtualmin-unlimited-emails>Set up Email Server With Virtualmin For Unlimited Emails &#038; Storage</a></li><li> <a href=http://www.linuxandubuntu.com/home/no-input-file-specified-wordpress-error>Fix WordPress No input file specified Error</a></li></ul></div><div id=penci_custom_html-4 class="widget_text widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_custom_html"><div class="textwidget custom-html-widget"><script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:inline-block;width:300px;height:600px data-ad-client=ca-pub-1925104690687996 data-ad-slot=8856775759></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><style>#penci_custom_html-4.widget{padding:0
!important;background-color:transparent !important}#penci_custom_html-4.style-title-8:not(.footer-widget) .penci-block__title:before,#penci_custom_html-4.style-title-1:not(.footer-widget) .penci-block__title:before{right:0;left:0}</style><div id=penci_block_7__50166698 class="penci-block-vc penci-block_7 penci__general-meta widget penci-block-vc penci-widget-sidebar style-title-1 style-title-left penci-block-vc penci-widget penci-block_7 penci-widget__block_7 left penci-imgtype-landscape penci-link-filter-hidden penci-vc-column-1" data-current=1 data-blockUid=penci_block_7__50166698><div class=penci-block-heading><h3 class="penci-block__title"><a href=http://www.linuxandubuntu.com/home/category/hacking-with-kali-linux title="Ongoing series">Ongoing series</a ></h3></div><div id=penci_block_7__50166698block_content class=penci-block_content><div class="penci-block_content__items penci-block-items__1"><article class="hentry penci-post-item"><div class=penci-post-item__inner><div class=penci_post_thumb><a class="penci-image-holder  penci-disable-lazy penci-image_has_icon" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/04/install-kali-linux-on-virtualbox.jpg?resize=480%2C316);" data-delay href=http://www.linuxandubuntu.com/home/install-kali-linux title="Install Kali Linux &#8211; The Quickest Way"></a></div><div class=penci_post_content><h3 class="penci__post-title entry-title"><a href=http://www.linuxandubuntu.com/home/install-kali-linux title=" Install Kali Linux &#8211; The Quickest Way ">Install Kali Linux &#8211; The Quickest Way</a></h3><div class=penci-schema-markup><span class="author vcard"><a class="url fn n" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span><time class="entry-date published" datetime=2019-04-29T00:00:00+05:30>April 29, 2019</time><time class=updated datetime=2020-08-24T00:15:23+05:30>August 24, 2020</time></div><div class=penci_post-meta><span class="entry-meta-item penci-byline">by <span class="author vcard"><a class="url fn n penci_pmeta-link" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span></span><span class="entry-meta-item penci-posted-on"><i class="fa fa-clock-o"></i><time class="entry-date published" datetime=2020-08-24T00:15:23+05:30>August 24, 2020</time><time class=updated datetime=2020-08-24T00:15:23+05:30>August 24, 2020</time></span><span class="entry-meta-item penci-comment-count"><a class=penci_pmeta-link href=http://www.linuxandubuntu.com/home/install-kali-linux#comments><i class="la la-comments"></i>4 </a></span></div></div></div></article><article class="hentry penci-post-item"><div class=penci-post-item__inner><div class=penci_post_thumb><a class="penci-image-holder  penci-disable-lazy penci-image_has_icon" style="background-image: url(https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/04/hacking-with-kali-linux.jpg?resize=480%2C320);" data-delay href=http://www.linuxandubuntu.com/home/hacking-with-kali-linux title="Hacking With Kali Linux"></a></div><div class=penci_post_content><h3 class="penci__post-title entry-title"><a href=http://www.linuxandubuntu.com/home/hacking-with-kali-linux title=" Hacking With Kali Linux ">Hacking With Kali Linux</a></h3><div class=penci-schema-markup><span class="author vcard"><a class="url fn n" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span><time class="entry-date published" datetime=2019-04-23T00:00:00+05:30>April 23, 2019</time><time class=updated datetime=2019-12-13T03:27:27+05:30>December 13, 2019</time></div><div class=penci_post-meta><span class="entry-meta-item penci-byline">by <span class="author vcard"><a class="url fn n penci_pmeta-link" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span></span><span class="entry-meta-item penci-posted-on"><i class="fa fa-clock-o"></i><time class="entry-date published" datetime=2019-12-13T03:27:27+05:30>December 13, 2019</time><time class=updated datetime=2019-12-13T03:27:27+05:30>December 13, 2019</time></span><span class="entry-meta-item penci-comment-count"><a class=penci_pmeta-link href=http://www.linuxandubuntu.com/home/hacking-with-kali-linux#comments><i class="la la-comments"></i>11 </a></span></div></div></div></article></div><div class="penci-loader-effect penci-loading-animation-7"><div class=penci-loading-animation></div><div class="penci-loading-animation penci-loading-animation-inner-2"></div><div class="penci-loading-animation penci-loading-animation-inner-3"></div><div class="penci-loading-animation penci-loading-animation-inner-4"></div><div class="penci-loading-animation penci-loading-animation-inner-5"></div><div class="penci-loading-animation penci-loading-animation-inner-6"></div><div class="penci-loading-animation penci-loading-animation-inner-7"></div><div class="penci-loading-animation penci-loading-animation-inner-8"></div><div class="penci-loading-animation penci-loading-animation-inner-9"></div></div></div></div><style>@media screen and (min-width: 768px ){}#penci_block_7__50166698 .penci-pmore-link .more-link{font-family:"Mukta Vaani";font-weight:500}#penci_block_7__50166698 .penci-subcat-filter .penci-subcat-item a,#penci_block_7__50166698 .penci-subcat-list .flexMenu-viewMore>a{font-family:"Roboto";font-weight:400}</style><script>if(typeof(penciBlock)==="undefined"){function penciBlock(){this.atts_json='';this.content='';}}var penciBlocksArray=penciBlocksArray||[];var PENCILOCALCACHE=PENCILOCALCACHE||{};var penci_block_7__50166698=new penciBlock();penci_block_7__50166698.blockID="penci_block_7__50166698";penci_block_7__50166698.atts_json='{"build_query":"post_type:post|size:5|categories:649","add_title_icon":"","title_i_align":"left","title_icon":"","image_type":"landscape","image_ratio":"","image_size":"penci-thumb-480-320","block_title_meta_settings":"","block_title_align":"left","block_title_off_uppercase":"","block_title_wborder_left_right":"5px","block_title_wborder":"3px","post_title_trimword_settings":"","post_standard_title_length":"12","hide_comment":"","hide_post_date":"","hide_icon_post_format":"","hide_author":"","hide_review_piechart":"","show_readmore":"","show_count_view":"","dis_bg_block":"","enable_stiky_post":"","show_order_number":"","style_pag":"","limit_loadmore":"3","readmore_css":"","pagination_css":"","loadmore_css":"","disable_bg_load_more":"","custom_markup_1":"","ajax_filter_type":"","ajax_filter_selected":"","ajax_filter_childselected":"","ajax_filter_number_item":"5","infeed_ads__order":"","block_id":"penci-widget__block_7-2","penci_show_desk":"Yes","penci_show_tablet":"Yes","penci_show_mobile":"Yes","paged":1,"unique_id":"penci_block_7__50166698","shortcode_id":"block_7","category_ids":"","taxonomy":""}';penci_block_7__50166698.content="";penciBlocksArray.push(penci_block_7__50166698);</script> </div></aside></div></div></main></div></div><footer id=colophon class=site-footer itemscope itemtype=http://schema.org/WPFooter><meta itemprop=name content="Webpage footer for Linux Tutorials, FOSS Reviews, Security News"><meta itemprop=description content><meta itemprop=keywords content="Data Protection, Copyright Data"><meta itemprop=copyrightYear content=2020><meta itemprop=copyrightHolder content="Linux Tutorials, FOSS Reviews, Security News"><div id=footer__sidebars class="footer__sidebars footer__sidebar-col-3 footer__sidebars-style-3"><div class="footer__sidebars-inner penci-container-fluid"><div class=row><div id=footer-1 class="footer-sidebar-item footer-1 penci-col-4"><div id=text-3 class="widget footer-widget penci-block-vc penci-fwidget-sidebar style-title-3 style-title-left widget_text"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>About LinuxAndUbuntu</span></h4></div><div class=textwidget><div class=paragraph>​​LinuxAndUbuntu.com  focuses on open source projects but specific on Debian based distributions. We also give value to other Linux distributions.</div></div></div><div id=media_image-5 class="widget footer-widget penci-block-vc penci-fwidget-sidebar style-title-3 style-title-left widget_media_image"><figure style="width: 88px" class="wp-caption alignnone"><a href=https://creativecommons.org/licenses/by-sa/4.0/><img width=88 height=31 src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/10/creative-commons.png?fit=88%2C31" class="image wp-image-25992  attachment-full size-full jetpack-lazy-image" alt="creative commons" loading=lazy style="max-width: 100%; height: auto;" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/10/creative-commons.png?fit=88%2C31&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7></a><figcaption class=wp-caption-text>creative commons</figcaption></figure></div></div><div id=footer-2 class="footer-sidebar-item footer-2 penci-col-4"><div id=text-9 class="widget footer-widget penci-block-vc penci-fwidget-sidebar style-title-3 style-title-left widget_text"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>Links</span></h4></div><div class=textwidget><div><a href="https://www.ubuntu.com/" target=_blank rel="noopener noreferrer">Ubuntu.com</a></div><div><a href=https://linuxmint.com/ target=_blank rel="noopener noreferrer">Linux Mint</a></div><div><a href=http://www.linuxandubuntu.com/home/category/linux-tutorials target=_blank rel="noopener noreferrer">Tutorials &amp; HowTos</a></div></div></div><style>#text-9 .penci-block__title a, #text-9 .penci-block__title
span{color:#efefef !important}#text-9 .penci-block-heading:after{background-color:#efefef !important}</style></div><div id=footer-3 class="footer-sidebar-item footer-3 penci-col-4"><div id=text-10 class="widget footer-widget penci-block-vc penci-fwidget-sidebar style-title-3 style-title-left widget_text"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>More From LinuxAndUbuntu</span></h4></div><div class=textwidget><div class=paragraph><a href=http://www.linuxandubuntu.com/advertise/ target=_blank rel="noopener noreferrer">Advertise</a></div><div><a href=http://www.linuxandubuntu.com/become-a-regular-writer/ target=_blank rel="noopener noreferrer">Become a LinuxAndUbuntu writer</a></div><div><a href=http://www.linuxandubuntu.com/privacy-policy/ target=_blank rel="noopener noreferrer">Privacy Policy</a></div></div></div><style>#text-10 .penci-block__title a, #text-10 .penci-block__title
span{color:#fff !important}#text-10 .penci-block-heading:after{background-color:#fff !important}</style></div></div></div></div><div class="footer__bottom style-2"><div class="footer__bottom_container footer__sidebars-inner penci-container-fluid"><div class=row><div class="footer__bottom-item footer__logo penci-col-6"> <a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></div><div class="footer__bottom-item footer__social-media penci-col-6"><div class=block-title><span>Follow us</span></div> <a class="social-media-item socail_media__facebook" target=_blank href=https://www.facebook.com/linuxandubuntuofficial title=Facebook rel=noopener><span class=socail-media-item__content><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target=_blank href=https://twitter.com/linuxandubuntu title=Twitter rel=noopener><span class=socail-media-item__content><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a><a class="social-media-item socail_media__pinterest" target=_blank href="https://www.pinterest.com/linuxandubuntu" title=Pinterest rel=noopener><span class=socail-media-item__content><i class="fa fa-pinterest"></i><span class="social_title screen-reader-text">Pinterest</span></span></a><a class="social-media-item socail_media__linkedin" target=_blank href=https://www.linkedin.com/in/mohdsohail title=Linkedin rel=noopener><span class=socail-media-item__content><i class="fa fa-linkedin"></i><span class="social_title screen-reader-text">Linkedin</span></span></a><a class="social-media-item socail_media__youtube" target=_blank href=https://www.youtube.com/linuxandubuntuweb title=Youtube rel=noopener><span class=socail-media-item__content><i class="fa fa-youtube-play"></i><span class="social_title screen-reader-text">Youtube</span></span></a><a class="social-media-item socail_media__rss" target=_blank href=http://www.linuxandubuntu.com/feed/rss title=Rss rel=noopener><span class=socail-media-item__content><i class="fa fa-rss"></i><span class="social_title screen-reader-text">Rss</span></span></a></div></div></div></div><div class=footer__copyright_menu><div class="footer__sidebars-inner penci-container-fluid penci_bottom-sub penci_has_copyright"><div class=site-info> @2020 - www.linuxandubuntu.com. All Right Reserved. Powered by <a href="https://portal.massivegrid.com/link.php?id=2" target=_blank>MassiveGRID</a> on <a href="https://wordpress.org" target=_blank>WordPress</a></div></div></div></footer></div><aside class="mobile-sidebar "><div id=sidebar-nav-logo> <a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></div><div class="header-social sidebar-nav-social"><div class=inner-header-social> <a class="social-media-item socail_media__facebook" target=_blank href=https://www.facebook.com/linuxandubuntuofficial title=Facebook rel=noopener><span class=socail-media-item__content><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target=_blank href=https://twitter.com/linuxandubuntu title=Twitter rel=noopener><span class=socail-media-item__content><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a><a class="social-media-item socail_media__pinterest" target=_blank href="https://www.pinterest.com/linuxandubuntu" title=Pinterest rel=noopener><span class=socail-media-item__content><i class="fa fa-pinterest"></i><span class="social_title screen-reader-text">Pinterest</span></span></a><a class="social-media-item socail_media__linkedin" target=_blank href=https://www.linkedin.com/in/mohdsohail title=Linkedin rel=noopener><span class=socail-media-item__content><i class="fa fa-linkedin"></i><span class="social_title screen-reader-text">Linkedin</span></span></a><a class="social-media-item socail_media__youtube" target=_blank href=https://www.youtube.com/linuxandubuntuweb title=Youtube rel=noopener><span class=socail-media-item__content><i class="fa fa-youtube-play"></i><span class="social_title screen-reader-text">Youtube</span></span></a><a class="social-media-item socail_media__rss" target=_blank href=http://www.linuxandubuntu.com/feed/rss title=Rss rel=noopener><span class=socail-media-item__content><i class="fa fa-rss"></i><span class="social_title screen-reader-text">Rss</span></span></a></div></div><nav class=mobile-navigation itemscope itemtype=http://schema.org/SiteNavigationElement><ul id=primary-menu-mobile class=primary-menu-mobile><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9637"><a href=http://www.linuxandubuntu.com>Home</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16021"><a href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21700"><a href=http://www.linuxandubuntu.com/home/category/linux/themes>Linux Themes</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-17077"><a href=http://www.linuxandubuntu.com/home/category/linux-tutorials>Linux Tutorials</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-8337"><a href=http://www.linuxandubuntu.com/faqs>Linux FAQs</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9733"><a href=http://www.linuxandubuntu.com/advertise>Advertise</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9636"><a href=http://www.linuxandubuntu.com/contact-us>Contact us</a></li></ul></nav></aside> <a id=close-sidebar-nav class=header-1><i class="fa fa-close"></i></a> <a href=# id=scroll-to-top><i class="fa fa-angle-up"></i></a><div class="penci-wrap-gprd-law penci-wrap-gprd-law-close"><div class=penci-gprd-law><p> This website uses cookies to improve your experience. We'll assume you're ok with this. Thank you!	<a class=penci-gprd-accept href=#>Ok</a> <a class=penci-gprd-more href=http://www.linuxandubuntu.com/privacy-policy>Read More</a></p></div></div><div id=amp-mobile-version-switcher hidden> <a rel=amphtml href="http://www.linuxandubuntu.com/home/things-to-remember-before-upgrading-production-server?amp=1"> Go to mobile version	</a></div> <script src=https://c0.wp.com/p/jetpack/9.0.2/_inc/build/photon/photon.min.js id=jetpack-photon-js></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/c0179.js></script> <script id=contact-form-7-js-extra>var wpcf7={"apiSettings":{"root":"http:\/\/www.linuxandubuntu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/0fef6.js></script> <script id=ta_main_js-js-extra>var thirsty_global_vars={"home_url":"\/\/www.linuxandubuntu.com","ajax_url":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"recommends","link_prefixes":{"1":"recommends"},"post_id":"25431","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/86e9b.js></script> <script id=penci-js-extra>/*<![CDATA[*/var PENCILOCALIZE={"ajaxUrl":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","nonce":"82b33e7d46","errorMsg":"Something wrong happened. Please try again.","login":"Email Address","password":"Password","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","prevNumber":"1","minlengthSearch":"0","linkTitle":"View More","linkTextAll":"Menu","linkText":"More"};/*]]>*/</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/168b5.js></script> <script src=https://c0.wp.com/c/5.5.3/wp-includes/js/comment-reply.min.js id=comment-reply-js></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/462c4.js></script> <script id=enlighterjs-js-after>!function(e,n){if("undefined"!=typeof EnlighterJS){var o={"selectors":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"options":{"indent":2,"ampersandCleanup":true,"linehover":true,"rawcodeDbclick":false,"textOverflow":"break","linenumbers":false,"theme":"beyond","language":"generic","retainCssClasses":false,"collapse":false,"toolbarOuter":"","toolbarTop":"{BTN_RAW}{BTN_COPY}{BTN_WINDOW}{BTN_WEBSITE}","toolbarBottom":""}};(e.EnlighterJSINIT=function(){EnlighterJS.init(o.selectors.block,o.selectors.inline,o.options)})()}else{(n&&(n.error||n.log)||function(){})("Error: EnlighterJS resources not loaded yet!")}}(window,console);</script> <script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.5.3' async=async id=remote_sdk-js></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/0a65a.js></script> <script id=ez-toc-js-js-extra>var ezTOC={"smooth_scroll":"1","visibility_hide_by_default":"","width":"100%","scroll_offset":"0"};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/d7224.js></script> <script src=https://stats.wp.com/e-202045.js async=async defer=defer></script> <script>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:9.0.2',blog:'164016613',post:'25431',tz:'5.5',srv:'www.linuxandubuntu.com'}]);_stq.push(['clickTrackerInit','164016613','25431']);</script> </body></html>