<!DOCTYPE html>
<html xmlns:fb="http://ogp.me/ns/fb#">
	<head>
		<title>What Is Crontab And How To Automate Tasks In Linux With Crontab - LinuxAndUbuntu - Linux News | Apps Reviews | Linux Tutorials HowTo</title><meta property="og:site_name" content="LinuxAndUbuntu - Linux News | Apps Reviews | Linux Tutorials HowTo" />
<meta property="og:title" content="What Is Crontab And How To Automate Tasks In Linux With Crontab" />
<meta property="og:description" content="​Cron is a utility that manages background processes or daemons from time to time (for example each minute, day, week or month). Cron works like a scheduler, for example, it can download files from the internet or download emails at regular intervals, als" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/how-to-automate-tasks-in-linux-with-crontab_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/how-to-use-cron_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/set-cron-job-in-linux_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/automate-backup-using-cron-job-in-linux_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/test-cron-job-in-linux_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/how-to-run-a-cron-job-hourly_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/give-permission-to-cron-job_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/how-to-schedule-a-cron-job-in-linux_orig.jpg" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/run-cron-task-hourly-daily-weekly-and-yearly_orig.png" />
<meta property="og:image" content="http://www.linuxandubuntu.com/uploads/2/1/1/5/21152474/create-a-crontab-file_orig.png" />
<meta property="og:url" content="http://www.linuxandubuntu.com/1/post/2017/05/what-is-crontab-and-how-to-automate-tasks-in-linux-with-crontab.html" />
<meta http-equiv='cache-control' content='no-cache' />
<meta property="description" content="​Cron is a utility that manages background processes or daemons from time to time (for example each minute, day, week or month). Cron works like a scheduler, for example, it can download files from the internet or download emails at regular intervals, als" />


<meta name="keywords" content="Linux, Ubuntu, news, reviews, how, howtos, security, updates, applications, technology, email, marketing, games, tutorials" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
  <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
  <link href="https://fonts.googleapis.com/css?family=Josefin+Sans|Strait" rel="stylesheet">

<!--ANALYTICS PAGE LEVEL ADS STARTS HERE-->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-1925104690687996",
    enable_page_level_ads: true
  });
</script>
 

		<meta name="google-site-verification" content="j0ObInWlWjWTRmzl2eUOA7iH-5aSe1JbCeQ7xYwpw2I" />

<!--Pinterest site confirmation code starts here -->
<meta name="p:domain_verify" content="c5e409ee073e5f764568a980985f7b9a"/>

<!--Google analytics code starts here-->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-42740043-3', 'auto');
  ga('send', 'pageview');

</script>

<!--FACEBOOK PIXEL CODE-->
<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1622359727778105');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1622359727778105&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<!-- BING WEBMASTER-->
<meta name="msvalidate.01" content="25896BA42459FDD824EF025608171717" />
		<link id="wsite-base-style" rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/sites.css?buildTime=1494624291" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/old/fancybox.css?1494624291" />
<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/social-icons.css?buildtime=1494624291" media="screen,projection" />
<link rel="stylesheet" type="text/css" href="/files/main_style.css?1494665231" title="wsite-theme-css" />
<link href='//fonts.googleapis.com/css?family=Lato:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Cookie&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Roboto:400,300,300italic,700,400italic,700italic&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
<link href='//fonts.googleapis.com/css?family=Strait&subset=latin,latin-ext' rel='stylesheet' type='text/css' />

<style type='text/css'>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</style>
<link rel="stylesheet" type="text/css" href="//fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,300,400,700" />
<style>
	@font-face {
		font-family: 'wicons';
		src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.eot?buildTime=1494624291);
		src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.eot?buildTime=1494624291#iefix) format('embedded-opentype'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.woff?buildTime=1494624291) format('woff'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.ttf?buildTime=1494624291) format('truetype'),
				 url(//cdn2.editmysite.com/fonts/wIcons/wicons.svg?buildTime=1494624291#wicons) format('svg');
		font-weight: normal;
		font-style: normal;
	}
	/* Hack to smooth out font rendering on Chrome for Windows */
	@media screen and (-webkit-min-device-pixel-ratio: 0) {
		@font-face {
			font-family: 'wicons';
			src: url(//cdn2.editmysite.com/fonts/wIcons/wicons.svg?buildTime=1494624291#wicons) format('svg');
		}
	}

	@font-face {
		font-family: 'wsocial';
		src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.eot?buildTime=1494624291);
		src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.eot?buildTime=1494624291#iefix) format('embedded-opentype'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.woff?buildTime=1494624291) format('woff'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.ttf?buildTime=1494624291) format('truetype'),
				 url(//cdn2.editmysite.com/fonts/wSocial/wsocial.svg?buildTime=1494624291#wsocial) format('svg');
		font-weight: normal;
		font-style: normal;
	}
	/* Hack to smooth out font rendering on Chrome for Windows */
	@media screen and (-webkit-min-device-pixel-ratio: 0) {
		@font-face {
			font-family: 'wsocial';
			src: url(//cdn2.editmysite.com/fonts/wSocial/wsocial.svg?buildTime=1494624291#wsocial) format('svg');
		}
	}
</style>

<link rel="stylesheet" type="text/css" href="//cdn2.editmysite.com/css/site_membership.css?buildTime=1494624291">

		<script src='/files/templateArtifacts.js?1494665231'></script>
<script>
var STATIC_BASE = '//cdn1.editmysite.com/';
var ASSETS_BASE = '//cdn2.editmysite.com/';
var STYLE_PREFIX = 'wsite';
</script>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script>

<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1494624291&"></script>
<script src="//cdn2.editmysite.com/js/site/main.js?buildTime=1494624291"></script><script type="text/javascript"> _W = _W || {}; _W.securePrefix='www-linuxandubuntu-com.checkout.weebly.com'; </script><script type="text/javascript">
								_W = window._W || {};
								_W.allowMemberRegistration = false;
								_W.showLogin = false;
							</script><script type="text/javascript">
					function initMembershipModels() {
						(function(){_W.setup_rpc({"url":"\/ajax\/api\/JsonRPC\/Membership\/","actions":{"Member":[{"name":"getRedirectUrl","len":1,"multiple":false,"standalone":false},{"name":"getOriginUrl","len":0,"multiple":false,"standalone":false},{"name":"getSecureMemberUrl","len":0,"multiple":false,"standalone":false},{"name":"validate_user","len":2,"multiple":false,"standalone":false},{"name":"get_account_information","len":0,"multiple":false,"standalone":false},{"name":"get_session_details","len":0,"multiple":false,"standalone":false},{"name":"register_member","len":4,"multiple":false,"standalone":false},{"name":"validate_session","len":1,"multiple":false,"standalone":false},{"name":"set_password","len":3,"multiple":false,"standalone":false},{"name":"send_reset_password_email","len":1,"multiple":false,"standalone":false},{"name":"create","len":1,"multiple":false,"standalone":false},{"name":"readOne","len":1,"multiple":false,"standalone":false},{"name":"readMany","len":1,"multiple":false,"standalone":false},{"name":"update","len":1,"multiple":false,"standalone":false},{"name":"patch","len":1,"multiple":false,"standalone":false},{"name":"destroy","len":1,"multiple":false,"standalone":false}]},"namespace":"_W.Membership.RPC"});
_W.setup_model_rpc({"rpc_namespace":"_W.Membership.RPC","model_namespace":"_W.Membership.BackboneModelData","collection_namespace":"_W.Membership.BackboneCollectionData","bootstrap_namespace":"_W.Membership.BackboneBootstrap","models":{"Member":{"_class":"Membership.Model.Member","defaults":{"class_name":null,"name":null,"email":"","access_token":null,"token_expiry_date":null,"last_ip":null,"last_login":null,"approved":false,"password_set":null,"group_ids":null,"page_ids":null,"group_page_ids":null,"owner_id":"","site_id":"","updated_date":0,"created_date":0},"validation":{"class_name":null,"site_member_id":null,"name":null,"email":{"email":null,"required":true},"access_token":null,"token_expiry_date":null,"last_ip":null,"last_login":null,"approved":null,"password_set":null,"group_ids":null,"page_ids":null,"group_page_ids":null,"owner_id":{"required":true},"site_id":{"required":true},"updated_date":null,"created_date":null},"types":{"class_name":null,"site_member_id":"string","name":"string","email":"string","access_token":"string","token_expiry_date":"int","last_ip":"string","last_login":"int","approved":"boolean","password_set":"boolean","group_ids":"json","page_ids":"json","group_page_ids":"json","owner_id":"string","site_id":"string","updated_date":"int","created_date":"int"},"idAttribute":"site_member_id","keydefs":{"PRIMARY":["owner_id","site_id","site_member_id"]}}},"collections":{"Member":{"_class":"Membership.Collection.Member"}},"bootstrap":[]});
})();
					}
					if(document.createEvent && document.addEventListener) {
						var initEvt = document.createEvent('Event');
						initEvt.initEvent('membershipModelsInitialized', true, false);
						document.dispatchEvent(initEvt);
					} else if(document.documentElement.initMembershipModels === 0){
						document.documentElement.initMembershipModels++
					}
					</script><script src='//cdn2.editmysite.com/js/site/main-membership-site.js?buildTime=1494624291'></script>
<script type="text/javascript">_W.configDomain = "www.weebly.com";</script><script>_W.relinquish && _W.relinquish()</script>
<script type="text/javascript" src="//cdn2.editmysite.com/js/lang/en/stl.js?buildTime=1494624291&"></script><script> _W.themePlugins = [];</script><script type="text/javascript"><!--
	
	
	function initFlyouts(){
		initPublishedFlyoutMenus(
			[{"id":"473124243954054265","title":"Homepage","url":"index.html","target":"","nav_menu":false,"nonclickable":false},{"id":"369144760395742060","title":"Store","url":"store.html","target":"","nav_menu":false,"nonclickable":false},{"id":"497719449939535530","title":"Video Tutorials","url":"video-tutorials.html","target":"","nav_menu":false,"nonclickable":false},{"id":"394823265735430346","title":"Linux Themes","url":"linux-themes.html","target":"","nav_menu":false,"nonclickable":false},{"id":"990585951625353780","title":"FAQs","url":"faqs.html","target":"","nav_menu":false,"nonclickable":false},{"id":"868701769148141363","title":"Become a Regular writer","url":"become-a-regular-writer.html","target":"","nav_menu":false,"nonclickable":false},{"id":"488323224446624077","title":"Contact Us","url":"contact-us.html","target":"","nav_menu":false,"nonclickable":false},{"id":"225612336786093830","title":"Donate","url":"donate-now.html","target":"","nav_menu":false,"nonclickable":false},{"id":"758006490901768922","title":"Block Adblock","url":"block-adblock.html","target":"","nav_menu":false,"nonclickable":false}],
			"505011975351111026",
			'',
			'active',
			false,
			{"navigation\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}} class=\"wsite-menu-item-wrap\">\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\t{{#membership_required}}\n\t\t\tdata-membership-required=\"{{.}}\"\n\t\t{{\/membership_required}}\n\t\tclass=\"wsite-menu-item\"\n\t\t>\n\t\t{{{title_html}}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n","navigation\/flyout\/list":"<div class=\"wsite-menu-wrap\" style=\"display:none\">\n\t<ul class=\"wsite-menu\">\n\t\t{{#children}}{{> navigation\/flyout\/item}}{{\/children}}\n\t<\/ul>\n<\/div>\n","navigation\/flyout\/item":"<li {{#id}}id=\"{{id}}\"{{\/id}}\n\tclass=\"wsite-menu-subitem-wrap {{#is_current}}wsite-nav-current{{\/is_current}}\"\n\t>\n\t<a\n\t\t{{^nonclickable}}\n\t\t\t{{^nav_menu}}\n\t\t\t\thref=\"{{url}}\"\n\t\t\t{{\/nav_menu}}\n\t\t{{\/nonclickable}}\n\t\t{{#target}}\n\t\t\ttarget=\"{{target}}\"\n\t\t{{\/target}}\n\t\tclass=\"wsite-menu-subitem\"\n\t\t>\n\t\t<span class=\"wsite-menu-title\">\n\t\t\t{{{title_html}}}\n\t\t<\/span>{{#has_children}}<span class=\"wsite-menu-arrow\">&gt;<\/span>{{\/has_children}}\n\t<\/a>\n\t{{#has_children}}{{> navigation\/flyout\/list}}{{\/has_children}}\n<\/li>\n"},
			{}
		)
	}
//-->
</script>
		
		<script type="text/javascript" src="https://popup2.lifterapps.com/js/modal.js?siteId=208815729450551065"></script>
	</head>
	<body class="no-header-page  wsite-page-home wsite-blog-post  wsite-theme-light"><div class="wrapper">
    <div class="header-wrap">
      <div class="nav-wrap">
        <div id="logo"><span class="wsite-logo">

	<a href="/">
		<img src="/uploads/2/1/1/5/21152474/1439612142.png" />
	</a>

</span></div>
		
		<div class="ads">
		<!-- Begin Adversal 728x90 - linuxandubuntu.com Code -->

		<!-- End Adversal 728x90 - linuxandubuntu.com Code -->
		</div>

<div class = "clear"></div>


        <label class="hamburger"><span></span></label>
        <div class="menu">
          <div class="container">
            <div class="search"><span class="wsite-search">
	<form id="wsite-header-search-form" action="/apps/search" method="get">
		<input type="text" name="q" class="wsite-search-input" autocomplete="off" placeholder="Search"/><span class="wsite-search-button"><span class="wsite-search-button-inner"></span></span>
	</form>
</span></div>
            <ul class="wsite-menu-default">
            		<li id="pg473124243954054265" class="wsite-menu-item-wrap">
            			<a
            						href="/"
            				class="wsite-menu-item"
            				>
            				Homepage
            			</a>
            			
            		</li>
            		<li id="pg369144760395742060" class="wsite-menu-item-wrap">
            			<a
            						href="/store.html"
            				class="wsite-menu-item"
            				>
            				Store
            			</a>
            			
            		</li>
            		<li id="pg497719449939535530" class="wsite-menu-item-wrap">
            			<a
            						href="/video-tutorials.html"
            				class="wsite-menu-item"
            				>
            				Video Tutorials
            			</a>
            			
            		</li>
            		<li id="pg394823265735430346" class="wsite-menu-item-wrap">
            			<a
            						href="/linux-themes.html"
            				class="wsite-menu-item"
            				>
            				Linux Themes
            			</a>
            			
            		</li>
            		<li id="pg990585951625353780" class="wsite-menu-item-wrap">
            			<a
            						href="/faqs.html"
            				class="wsite-menu-item"
            				>
            				FAQs
            			</a>
            			
            		</li>
            		<li id="pg868701769148141363" class="wsite-menu-item-wrap">
            			<a
            						href="/become-a-regular-writer.html"
            				class="wsite-menu-item"
            				>
            				Become a Regular writer
            			</a>
            			
            		</li>
            		<li id="pg488323224446624077" class="wsite-menu-item-wrap">
            			<a
            						href="/contact-us.html"
            				class="wsite-menu-item"
            				>
            				Contact Us
            			</a>
            			
            		</li>
            		<li id="pg225612336786093830" class="wsite-menu-item-wrap">
            			<a
            						href="/donate-now.html"
            				class="wsite-menu-item"
            				>
            				Donate
            			</a>
            			
            		</li>
            		<li id="pg758006490901768922" class="wsite-menu-item-wrap">
            			<a
            						href="/block-adblock.html"
            				class="wsite-menu-item"
            				>
            				Block Adblock
            			</a>
            			
            		</li>
            </ul>
          </div>
        </div>
      </div>
    </div>
	
	

    <div id="main-wrap">
      <div class="wsite-section-content">
        <div class="container"><div class="wsite-elements wsite-not-footer">
	<table 
	id="blogTable" 
		class="wsite-not-footer" 
	style="border: 0; width: 100%; table-layout: fixed" 
>
	<tr>
	    <td valign="top">
	        	<div id="505011975351111026-blog" class="blog-body" style="float: left;"> 
		<div id="wsite-content">	<div id="blog-post-578145403558120074" class="blog-post">
	
			<div class="blog-post-header"><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
</script> <!-- LinuxAndUbuntu top header banner 728x90 -->
<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-1925104690687996" data-ad-slot="8303225468"></ins> <script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
	
		<div class="blog-header">
			<h2 class="blog-title">
					<a class="blog-title-link blog-link" href="http://www.linuxandubuntu.com/home/what-is-crontab-and-how-to-automate-tasks-in-linux-with-crontab">What Is Crontab And How To Automate Tasks In Linux With Crontab</a>

			</h2>
			<p class="blog-date">
					<span class="date-text">
		12/5/2017
	</span>

			</p>
			<p class="blog-comments">
						<a href="http://www.linuxandubuntu.com/home/what-is-crontab-and-how-to-automate-tasks-in-linux-with-crontab#comments" data-disqus-identifier="578145403558120074" class="blog-link">Comments</a>

			</p>
		</div>
	
		<div class="blog-separator">&nbsp;</div>
	
		<div class="blog-content">
				<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/home/what-is-crontab-and-how-to-automate-tasks-in-linux-with-crontab'><img src="/uploads/2/1/1/5/21152474/how-to-automate-tasks-in-linux-with-crontab_orig.jpg" alt="how to automate tasks in linux with crontab" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​Cron is a utility that manages background processes or daemons from time to time (for example each minute, day, week or month). Cron works like a scheduler, for example, it can download files from the internet or download emails at regular intervals, also you can use it for more complex tasks like install updates. Originally cron was created for UNIX by Ken Thompson, but now you can use it in all UNIX-like systems, even Linux! UNIX have other utility for tasks scheduling called “at” but cron is much better.
</div>

<div>
<!--BLOG_SUMMARY_END-->
</div>

<div class="wsite-spacer" style="height:50px;"></div>

<div class="paragraph">
​There are two ways to use cron, the first is through the cron directories located in /etc if you open a terminal and type the following command:
</div>

<div>
<div id="387856198582233264" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<div class='code'>
$ ls /etc/cron*
</div>
</div>
</div>

<div class="paragraph">
You will get the following output:
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/how-to-use-cron_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/how-to-use-cron_orig.jpg" alt="how to use cron" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​Now, you can see the following directories in the image: cron.daily, cron.hourly, cron.monthly, cron.weekly and cron.yearly.<br>
<br>
These directories store the scripts that must be executed by cron, according to the name of each directory is the frequency of the execution. For example, the scripts stored in cron.hourly will be executed each hour.<br>
<br>
Now, I’m going to write a simple script to make a backup of a directory, and I’ll put it on the cron.hourly directory to execute the script each hour. One important thing that you must consider, is to provide the execution permissions to the script, ‘cause if you don’t, cron won’t execute the file.<br>
<br>
The example of the process to add a script to cron tasks using the global cron directories:<br>
<br>
I have a directory and I want to make and automatically backup each hour:<br>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/set-cron-job-in-linux_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/set-cron-job-in-linux_orig.jpg" alt="set cron job in linux" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​I write a script to make the backup, I used nano but you can use your favorite editor:<br>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/automate-backup-using-cron-job-in-linux_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/automate-backup-using-cron-job-in-linux_orig.png" alt="automate backup using cron job in linux" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
I test the script:<br>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/test-cron-job-in-linux_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/test-cron-job-in-linux_orig.png" alt="test cron job in linux" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
I copy the script to /etc/cron.hourly:<br>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/how-to-run-a-cron-job-hourly_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/how-to-run-a-cron-job-hourly_orig.jpg" alt="how to run a cron job hourly" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
I give the execution permissions to the script:<br>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/give-permission-to-cron-job_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/give-permission-to-cron-job_orig.jpg" alt="give permission to cron job" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​All the scripts must start with the line #!/bin/sh because it indicates the shell to use.<br>
<br>
Use cron through the /etc/cron.* directories aren't very useful, so I’m going to explain the second-way using crontab.<br>
<br>
If you remember the output when I listed the content of /etc/cron* you’ll see the following file: /etc/crontab<br>
<br>
You can schedule tasks in the file crontab, but first, you must learn the following:
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/how-to-schedule-a-cron-job-in-linux_orig.jpg' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/how-to-schedule-a-cron-job-in-linux_orig.jpg" alt="how to schedule a cron job in linux" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​If you analyze the content of crontab file, you can identify 7 fields in the lines after “# run-parts”, I mean the following ( the first line after “# run parts”):<br>
<br>
​table<br>
</div>

<div id="934263687172266790">
<div>
<style type="text/css">
        #element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table-wrapper {
  padding: 20px 0;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table {
  width: 100%;
  border: 1px solid #C9CDCF;
  border-spacing: 0;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table td.cell {
  border-right: 1px solid #C9CDCF;
  border-bottom: 1px solid #C9CDCF;
  word-break: break-word;
  background-color: #FFFFFF;
  width: 14.285714285714%;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table td.cell .paragraph {
  width: 90%;
  margin: 0 5%;
  padding-bottom: 10px;
  padding-top: 10px;
  text-align: center;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table.style-top tr:first-child td,
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table.style-side td:first-of-type {
  background-color: #F8F8F8;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table.style-top tr:first-child td .paragraph,
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table.style-side td:first-of-type .paragraph {
  font-weight: 700;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table tr:last-child td {
  border-bottom: none;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table td:last-of-type {
  border-right: none;
}
#element-2194e160-62ae-4aa9-b08f-2b56ad0464f5 .simple-table .empty-content-area-element {
  padding-left: 0px !important;
}

</style>

<div id="element-2194e160-62ae-4aa9-b08f-2b56ad0464f5" data-platform-element-id="702688850553606843-1.4.3" class="platform-element-contents">
<div class="simple-table-wrapper">
<table class="simple-table style-top">
<tr>
<td class="cell">
<div class="paragraph">
​<font>Field1</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
<span style="font-size: 12pt; background-color: transparent;">Field2</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>Field3</font>
</div>
</td>

<td class="cell">
<div class="paragraph">
<font>Field4</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
<font>Field5</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
<font>Field6</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
<font>Field7</font><br>
<span></span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
01
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">root</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>nice ...</font><br>
<span></span>
</div>
</td>
</tr>
</table>
</div>
</div>

<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script>
</div>
</div>

<div class="paragraph">
​The first five fields indicate time values, the sixth field indicates the user and the seventh indicates the command to execute, this last can be a script or a command (uname, ls, apt-get, etc).<br>
<br>
Time fields are following:<br>
</div>

<div id="522734921731054042">
<div>
<style type="text/css">
        #element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table-wrapper {
  padding: 20px 0;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table {
  width: 100%;
  border: 1px solid #C9CDCF;
  border-spacing: 0;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table td.cell {
  border-right: 1px solid #C9CDCF;
  border-bottom: 1px solid #C9CDCF;
  word-break: break-word;
  background-color: #FFFFFF;
  width: 20%;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table td.cell .paragraph {
  width: 90%;
  margin: 0 5%;
  padding-bottom: 10px;
  padding-top: 10px;
  text-align: center;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table.style-top tr:first-child td,
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table.style-side td:first-of-type {
  background-color: #F8F8F8;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table.style-top tr:first-child td .paragraph,
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table.style-side td:first-of-type .paragraph {
  font-weight: 700;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table tr:last-child td {
  border-bottom: none;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table td:last-of-type {
  border-right: none;
}
#element-ec7f5aec-c047-4dca-888a-c08557db135b .simple-table .empty-content-area-element {
  padding-left: 0px !important;
}

</style>

<div id="element-ec7f5aec-c047-4dca-888a-c08557db135b" data-platform-element-id="702688850553606843-1.4.3" class="platform-element-contents">
<div class="simple-table-wrapper">
<table class="simple-table style-top">
<tr>
<td class="cell">
<div class="paragraph">
​<font>minute</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>hour</font>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>day of month</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>month</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">day of week</span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
01
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>

<td class="cell">
<div class="paragraph">
*
</div>
</td>
</tr>
</table>
</div>
</div>

<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script>
</div>
</div>

<div class="paragraph">
​The accepted value for each field is:<br>
</div>

<div id="777106188119315098">
<div>
<style type="text/css">
        #element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table-wrapper {
  padding: 20px 0;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table {
  width: 100%;
  border: 1px solid #C9CDCF;
  border-spacing: 0;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table td.cell {
  border-right: 1px solid #C9CDCF;
  border-bottom: 1px solid #C9CDCF;
  word-break: break-word;
  background-color: #FFFFFF;
  width: 50%;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table td.cell .paragraph {
  width: 90%;
  margin: 0 5%;
  padding-bottom: 10px;
  padding-top: 10px;
  text-align: center;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table.style-top tr:first-child td,
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table.style-side td:first-of-type {
  background-color: #F8F8F8;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table.style-top tr:first-child td .paragraph,
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table.style-side td:first-of-type .paragraph {
  font-weight: 700;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table tr:last-child td {
  border-bottom: none;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table td:last-of-type {
  border-right: none;
}
#element-25ef96b0-52c7-4154-9e5f-50988223fdeb .simple-table .empty-content-area-element {
  padding-left: 0px !important;
}

</style>

<div id="element-25ef96b0-52c7-4154-9e5f-50988223fdeb" data-platform-element-id="702688850553606843-1.4.3" class="platform-element-contents">
<div class="simple-table-wrapper">
<table class="simple-table style-top">
<tr>
<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">minute</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">00 - 59</span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<span>hour</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">00 - 23</span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<font>day of month</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">1 - 31</span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<font>month</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>1 - 12</font><br>
<span></span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">day of week</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">1 - 7 (Monday: 1, Sunday: 7)</span>
</div>
</td>
</tr>
</table>
</div>
</div>

<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script>
</div>
</div>

<div class="paragraph">
If the value of one of these fields is “*”, it means all possibles values for the correspondent field, for example, * * * * * root /root/script.sh<br>
<br>
This task will be executed by root every minute, all days and all months.<br>
<br>
Crontab uses too special strings to define ranges of frequency:<br>
<br>
​table<br>
</div>

<div id="664276638281801131">
<div>
<style type="text/css">
        #element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table-wrapper {
  padding: 20px 0;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table {
  width: 100%;
  border: 1px solid #C9CDCF;
  border-spacing: 0;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table td.cell {
  border-right: 1px solid #C9CDCF;
  border-bottom: 1px solid #C9CDCF;
  word-break: break-word;
  background-color: #FFFFFF;
  width: 50%;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table td.cell .paragraph {
  width: 90%;
  margin: 0 5%;
  padding-bottom: 10px;
  padding-top: 10px;
  text-align: center;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table.style-top tr:first-child td,
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table.style-side td:first-of-type {
  background-color: #F8F8F8;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table.style-top tr:first-child td .paragraph,
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table.style-side td:first-of-type .paragraph {
  font-weight: 700;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table tr:last-child td {
  border-bottom: none;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table td:last-of-type {
  border-right: none;
}
#element-061b8d03-23f3-4569-9d19-d90bd9a380ab .simple-table .empty-content-area-element {
  padding-left: 0px !important;
}

</style>

<div id="element-061b8d03-23f3-4569-9d19-d90bd9a380ab" data-platform-element-id="702688850553606843-1.4.3" class="platform-element-contents">
<div class="simple-table-wrapper">
<table class="simple-table style-top">
<tr>
<td class="cell">
<div class="paragraph">
<font>@reboot</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">One time after boot</span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">@yearly</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>Once a year</font><br>
<span></span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<font>@annually</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>Same as @yearly</font><br>
<span></span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">@monthly</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">Once a month</span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<font>@weekly</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">Once a week</span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<font>@daily</font><br>
<span></span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>Daily</font><br>
<span></span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​<span style="font-size: 12pt; background-color: transparent;">@midnight</span>
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>Same as @daily</font><br>
<span></span>
</div>
</td>
</tr>

<tr>
<td class="cell">
<div class="paragraph">
​@hourly
</div>
</td>

<td class="cell">
<div class="paragraph">
​<font>Hourly</font><br>
<span></span>
</div>
</td>
</tr>
</table>
</div>
</div>

<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script>
</div>
</div>

<div class="paragraph">
​You just change the time fields for one of the special strings and then complete the rest, for example, @annually root dist-upgrade.<br>
<br>
This task should be executed each year automatically.<br>
<br>
Now you can add tasks to crontab, also you can make a .scripts directory at your /home and store your scripts in it, finally, you can add an entry for every script in the crontab file.<br>
<br>
Crontab can manage a tasks file for each user, you can test if your user has crontab tasks using the following command:
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/run-cron-task-hourly-daily-weekly-and-yearly_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/run-cron-task-hourly-daily-weekly-and-yearly_orig.png" alt="run cron job hourly, weekly, daily, yearly" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​You can schedule tasks in a file, just create it:<br>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/create-a-crontab-file_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/create-a-crontab-file_orig.png" alt="create a crontab file" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​When you have been created your crontab file, you must load it to cron typing the command:<br>
</div>

<div>
<div id="401317846745452509" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<div class='code'>
$ crontab your_crontab
</div>
</div>
</div>

<div class="paragraph">
​Cron is very powerful because after that you loaded a new crontab, you don't have to do anything, that’s all, cron load new tasks and crontab files automatically.<br>
<br>
The result of my crontab is a script that makes a file with dates generated every minute:
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/crontab-result-file_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/crontab-result-file_orig.png" alt="crontab result file" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%">
Script
</div>
</div>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/crontab-result-file-generated_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/crontab-result-file-generated_orig.png" alt="crontab result file generated" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%">
File generated
</div>
</div>
</div>

<div class="paragraph">
​Other options for crontab are the following:
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/crontab-options-and-commands_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/crontab-options-and-commands_orig.png" alt="crontab options and commands" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>

<div class="paragraph">
​Cron is the most powerful task scheduler that I know and it’s excellent because it isn’t just for Linux, it’s for all UNIX-like systems. If you manage a server, probably you’ll love cron, even if you’re a common user you’ll like cron, with cron you can schedule everything.<br>
<br>
If you want to know more about cron, you should see the man pages:<br>
</div>

<div>
<div id="715690350569274861" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml">
<div class='code'>
$ man cron<br>
$ man crontab
</div>
</div>
</div>

<div>
<div class="wsite-image wsite-image-border-none" style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='/uploads/2/1/1/5/21152474/crontab-man-pages-for-help_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'><img src="/uploads/2/1/1/5/21152474/crontab-man-pages-for-help_orig.png" alt="crontab man pages for help" style="width:auto;max-width:100%"></a>

<div style="display:block;font-size:90%"></div>
</div>
</div>


		</div>
	
			<div class="blog-post-footer"><hr>

<p style='font-size: 2em; padding: 1.5em 0 0.5em 0;'>Related topics</p><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js">
</script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-1925104690687996" data-ad-slot="3191286661"></ins> <script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
	
			<div class="blog-social  ">
		<div class="blog-social-item blog-fb-like"><fb:like href="http://www.linuxandubuntu.com/1/post/2017/05/what-is-crontab-and-how-to-automate-tasks-in-linux-with-crontab.html" width="90" layout="button_count" action="like" show_faces="false" share="false"></fb:like></div><div class="blog-social-item"><a class="twitter-share-button" href="http://twitter.com/share?url=http://www.linuxandubuntu.com/1/post/2017/05/what-is-crontab-and-how-to-automate-tasks-in-linux-with-crontab.html" data-text="What Is Crontab And How To Automate Tasks In Linux With Crontab - LinuxAndUbuntu - Linux News | Apps Reviews | Linux Tutorials HowTo" data-count="horizontal"></a></div>
		<div style="clear:both"></div>
	</div>

	
		<div class="blog-comments-bottom">
					<a href="http://www.linuxandubuntu.com/home/what-is-crontab-and-how-to-automate-tasks-in-linux-with-crontab#comments" data-disqus-identifier="578145403558120074" class="blog-link">Comments</a>

		</div>
	
		<div class="blog-post-separator"></div>
	</div>


    <a name="comments" id="comments"></a>
<div id="commentArea">
	<div class="blog-comment-area">
		
		<div id="disqus_thread"></div>
		<script type="text/javascript">
			(function() {
			// Light/Dark is decided by text color inheirited to comment system
			// and should be passed by theme setting
			document.getElementById("disqus_thread").style.color = (document.body.className.match('wsite-theme-light') ? "black" : "white");
	
			window.disqus_shortname = "linuxandubuntu";
			window.disqus_identifier = "";
	
			var dsq = document.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;
			dsq.src = "//" + disqus_shortname + ".disqus.com/embed.js";
			(document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
			})();
		</script>
		<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
		<a href="http://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>


	</div>
	<!-- bid-1: , path:  -->
</div>
 
<!-- bid: $blog_id --></div>
	</div>

	    </td>
	        <td class="blog-sidebar" valign="top">
	            <div id="505011975351111026-sidebar" class="column-blog">
	<div class="blog-sidebar-separator">
		<ul id="505011975351111026-sidebar-list" class="columnlist-blog" style="margin:0; padding: 0;">
			<div id="578850826350903807"><div><style type="text/css">
	#element-4be583e9-690e-418e-8c5f-fa3cc66644c3 .callout-box-wrapper {
  padding: 20px 0px;
  word-wrap: break-word;
}
#element-4be583e9-690e-418e-8c5f-fa3cc66644c3 .callout-box--standard {
  border: 1px solid #E0E0E0;
  background: #fff ff;
  padding: 20px 20px;
}
#element-4be583e9-690e-418e-8c5f-fa3cc66644c3 .callout-box--material {
  border: 1px solid #E0E0E0;
  background: #fff ff;
  padding: 20px 20px;
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}
#element-4be583e9-690e-418e-8c5f-fa3cc66644c3 .callout-base {
  border: 1px solid #E0E0E0;
  background: #fff ff;
  padding: 20px 20px;
}
#element-4be583e9-690e-418e-8c5f-fa3cc66644c3 .material {
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}

</style><div id="element-4be583e9-690e-418e-8c5f-fa3cc66644c3" data-platform-element-id="694046499467037623-1.2.6" class="platform-element-contents">
	<div class="callout-box-wrapper">
	<div class="callout-box--standard">
	    <div class="element-content">
	        <div style="width: auto"><div></div><div style="text-align:left;"><div style="height:10px;overflow:hidden"></div>
<span class="wsite-social wsite-social-default"><a class='first-child wsite-social-item wsite-social-facebook' href='https://www.facebook.com/linuxandubuntuofficial' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-twitter' href='https://www.twitter.com/linuxandubuntu' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-linkedin' href='https://www.linkedin.com/in/mohdsohail' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-flickr' href='https://www.flickr.com/people/153662320@N03/?rb=1' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-pinterest' href='http://www.pinterest.com/linuxandubuntu' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-plus' href='https://plus.google.com/+Linuxandubuntuweb/posts' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-rss' href='http://feeds.feedburner.com/linuxandubuntu' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='wsite-social-item wsite-social-youtube' href='https://www.youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg' target='_blank'><span class='wsite-social-item-inner'></span></a><a class='last-child wsite-social-item wsite-social-instagram' href='https://www.instagram.com/mohdsohail_123/' target='_blank'><span class='wsite-social-item-inner'></span></a></span>
<div style="height:10px;overflow:hidden"></div></div></div>
	    </div>
	</div>
</div>
</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>

<div><div style="height: 20px; overflow: hidden; width: 100%;"></div>
<hr class="styled-hr" style="width:100%;"></hr>
<div style="height: 20px; overflow: hidden; width: 100%;"></div></div>

<div><div id="712008999420323625" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- LinuxAndUbuntu -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-1925104690687996"
     data-ad-slot="5284681867"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



</div>

<div id="862800739943612217"><div><style type="text/css">
	#element-3ef1fff9-133a-4eea-8d6e-904f07e62d29 .callout-box-wrapper {
  padding: 20px 0px;
  word-wrap: break-word;
}
#element-3ef1fff9-133a-4eea-8d6e-904f07e62d29 .callout-box--standard {
  border: 1px solid #E0E0E0;
  background: #ccc cc;
  padding: 20px 20px;
}
#element-3ef1fff9-133a-4eea-8d6e-904f07e62d29 .callout-box--material {
  border: 1px solid #E0E0E0;
  background: #ccc cc;
  padding: 20px 20px;
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}
#element-3ef1fff9-133a-4eea-8d6e-904f07e62d29 .callout-base {
  border: 1px solid #E0E0E0;
  background: #ccc cc;
  padding: 20px 20px;
}
#element-3ef1fff9-133a-4eea-8d6e-904f07e62d29 .material {
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}

</style><div id="element-3ef1fff9-133a-4eea-8d6e-904f07e62d29" data-platform-element-id="694046499467037623-1.2.6" class="platform-element-contents">
	<div class="callout-box-wrapper">
	<div class="callout-box--standard">
	    <div class="element-content">
	        <div style="width: auto"><div></div><div class="wsite-search-element-outer"><div class="wsite-search-element-align-left" style="padding: 10px 0 10px 0">
  <form class="wsite-search-element-form" action="/apps/search" method="get">
    <div class="wsite-search-element">
      <input class="wsite-input wsite-search-element-input" type="text" name="q" placeholder="Search" autocomplete="off" />
      <span class="wsite-search-element-submit" title="Search"></span>
    </div>
  </form>
</div></div></div>
	    </div>
	</div>
</div>
</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>

<div><div id="434243777816392600" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- LinuxAndUbuntu -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-1925104690687996"
     data-ad-slot="5284681867"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>



</div>

<div class="wsite-spacer" style="height:33px;"></div>

<h2 class="wsite-content-title" style="text-align:left;"><font size="5">Most Read Articles</font></h2>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers'><img src="/uploads/2/1/1/5/21152474/published/120370050.jpg?1492664417" style="margin-top: 20px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px; max-width:100%" alt="5 Lightweight Linux For Old Computers" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers"><font size="2">5 Lightweight Linux For Old Computers</font></a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/8-best-ides-or-code-editors-for-linux'><img src="/uploads/2/1/1/5/21152474/published/214005563.jpg?1492664480" style="margin-top: 15px; margin-bottom: 0px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="8 Best IDEs Or Code Editors For Linux" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -0px; margin-bottom: 0px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/zorin-os-12-review-linuxandubuntu-distro-review-of-the-week"></a><a href="http://www.linuxandubuntu.com/home/8-best-ides-or-code-editors-for-linux"><font size="2">8 Best IDEs Or Code Editors For Linux</font></a><a href="http://www.linuxandubuntu.com/home/zorin-os-12-review-linuxandubuntu-distro-review-of-the-week"></a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/3-twitter-clients-for-linux-that-you-dont-want-to-miss'><img src="/uploads/2/1/1/5/21152474/7821028.png" style="margin-top: 15px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="3 best twitter clients for linux" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/3-twitter-clients-for-linux-that-you-dont-want-to-miss"><font size="2">3 Twitter Clients For Linux That You Don't Want To Miss</font></a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/ubuntu-vs-linux-mint-which-is-better-in-2016'><img src="/uploads/2/1/1/5/21152474/published/709180487.png?1492664550" style="margin-top: 15px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="﻿Ubuntu Vs. Linux Mint - Which Is Better in 2016?" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers"></a><a href="http://www.linuxandubuntu.com/home/ubuntu-vs-linux-mint-which-is-better-in-2016"><font size="2">&#65279;Ubuntu Vs. Linux Mint - Which Is Better in 2016</font></a><a href="http://www.linuxandubuntu.com/home/5-lightweight-linux-for-old-computers"></a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/dual-boot-ubuntu-15-04-14-10-and-windows-10-8-1-8-step-by-step-tutorial-with-screenshots'><img src="/uploads/2/1/1/5/21152474/5677486.png" style="margin-top: 15px; margin-bottom: 0px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="dual boot ubuntu and windows" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -0px; margin-bottom: 0px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/dual-boot-ubuntu-15-04-14-10-and-windows-10-8-1-8-step-by-step-tutorial-with-screenshots"><font size="2">Dual-Boot Ubuntu 15.04/14.10 And Windows 10/8.1/8: Step By Step Tutorial With Screenshots</font></a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<span class='imgPusher' style='float:left;height:0px'></span><span style='display: table;width:auto;position:relative;float:left;max-width:100%;;clear:left;margin-top:0px;*margin-top:0px'><a href='http://www.linuxandubuntu.com/home/5-best-linux-desktop-environments-with-pros-cons'><img src="/uploads/2/1/1/5/21152474/5301485.png" style="margin-top: 15px; margin-bottom: 10px; margin-left: 0px; margin-right: 10px; border-width:1px;padding:3px; max-width:100%" alt="dual boot ubuntu and windows" class="galleryImageBorder wsite-image" /></a><span style="display: table-caption; caption-side: bottom; font-size: 90%; margin-top: -10px; margin-bottom: 10px; text-align: center;" class="wsite-caption"></span></span>
<div class="paragraph" style="text-align:left;display:block;"><a href="http://www.linuxandubuntu.com/home/5-best-linux-desktop-environments-with-pros-cons"><font size="2">5 Best Linux Desktop Environments With Pros &amp; Cons</font></a></div>
<hr style="width:100%;clear:both;visibility:hidden;"></hr>

<div id="208354040506696420"><div><style type="text/css">
	#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-box-wrapper {
  padding: 20px 0px;
  word-wrap: break-word;
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-box--standard {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-box--material {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .callout-base {
  border: 1px solid #E0E0E0;
  background: #FAFAFA;
  padding: 20px 20px;
}
#element-66239272-0681-4f78-b18e-ac5eb66ed42f .material {
  box-shadow: 0 0 20px rgba(0,0,0,0.15);
}

</style><div id="element-66239272-0681-4f78-b18e-ac5eb66ed42f" data-platform-element-id="694046499467037623-1.2.6" class="platform-element-contents">
	<div class="callout-box-wrapper">
	<div class="callout-box--standard">
	    <div class="element-content">
	        <div style="width: auto"><div></div><div><div id="151769381861451707" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><!-- Place this tag in your head or just before your close body tag. -->
<script src="https://apis.google.com/js/platform.js" async defer></script>

<!-- Place this tag where you want the widget to render. -->
<div class="g-page" data-width="260" data-href="//plus.google.com/u/0/118431494181891907735" data-theme="dark" data-rel="publisher"></div></div>



</div></div>
	    </div>
	</div>
</div>
</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>

<div class="wsite-spacer" style="height:25px;"></div>

<div class="wsite-spacer" style="height:25px;"></div>

<h2 class="wsite-content-title" style="text-align:left;">Poll Results</h2>

<div><div style="height: 10px; overflow: hidden; width: 100%;"></div>
<hr class="styled-hr" style="width:100%;"></hr>
<div style="height: 10px; overflow: hidden; width: 100%;"></div></div>

<div><div id="849683871886453502" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><div style="background-color:#128188; padding: 1px; border-style:solid; border-radius:0px; border-width:1px; border-color:#ABA4A4;" align="center">

<font face="Aegean"color="white" size="4">
What is your favorite Linux Desktop Environment?</font> 

</p></div>



</div>

<div><div class="wsite-image wsite-image-border-thin " style="padding-top:10px;padding-bottom:15px;margin-left:0;margin-right:0;text-align:left">
<a href='/uploads/2/1/1/5/21152474/2690071_orig.png' rel='lightbox' onclick='if (!lightboxLoaded) return false'>
<img src="/uploads/2/1/1/5/21152474/2690071.png" alt="What is your favorite Linux Desktop Environment?" style="width:331;max-width:100%" />
</a>
<div style="display:block;font-size:90%"></div>
</div></div>

<div class="wsite-spacer" style="height:30.33334px;"></div>

<div class="wsite-spacer" style="height:34.33334px;"></div>

<h2 class="wsite-content-title" style="text-align:left;">Translate Our Site</h2>

<div><div id="857667866879550401" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><div style="background-color:#FCFCFC; padding: 5px; border-style:solid; border-radius:0px; border-width:1px; border-color:#ABA4A4;" align="center">
<br><br/><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL, gaTrack: true, gaId: 'UA-42740043-4'}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
        
<br /> <br />
<font color = "red">Notice  :</font> Please be careful, after translation commands will change.
</div></div>



</div>

<div id="317368027686760666"><div><style type="text/css">
	#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top {
  display: none;
  width: 60px;
  height: 60px;
  text-indent: -9999px;
  position: fixed;
  z-index: 999;
  bottom: 70px;
  background: #8c48b7 url("//marketplace.editmysite.com/elements/569198776394566218-1.0.1/assets/up-arrow.png") no-repeat center 43%;
  -webkit-border-radius: 30px;
  -moz-border-radius: 30px;
  border-radius: 30px;
}
#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top.back-to-top-left {
  left: 30px;
}
#element-cb6ceeb2-44e0-436f-9f02-623744191355 a.back-to-top.back-to-top-right {
  right: 30px;
}

</style><div id="element-cb6ceeb2-44e0-436f-9f02-623744191355" data-platform-element-id="569198776394566218-1.0.1" class="platform-element-contents">
	<a href="#" class="back-to-top back-to-top-left"></a>

</div>
<div style="clear:both;"></div><script type="text/javascript" class="element-script">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</script></div></div>
		</ul>
	</div>
</div>

	        </td>
	</tr>
</table>

</div>
</div>
      </div>
    </div>
	
	



    <div class="sticky-footer-push"></div>

  </div><!--/.wrapper-->

  <div id="footer-wrap">
    <div class="container"><div class='wsite-elements wsite-footer'>
<div><div class="wsite-multicol"><div class="wsite-multicol-table-wrap" style="margin:0 -15px;">
	<table class="wsite-multicol-table">
		<tbody class="wsite-multicol-tbody">
			<tr class="wsite-multicol-tr">
				<td class="wsite-multicol-col" style="width:45.638936570547%; padding:0 15px;">
					
						

<div><div class="wsite-multicol"><div class="wsite-multicol-table-wrap" style="margin:0 -15px;">
	<table class="wsite-multicol-table">
		<tbody class="wsite-multicol-tbody">
			<tr class="wsite-multicol-tr">
				<td class="wsite-multicol-col" style="width:57.196261682243%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">About LinuxAndUbuntu</h2>

<div class="paragraph" style="text-align:left;">&#8203;<span style="color:rgb(161, 161, 161)">&#8203;</span><span style="color:rgb(161, 161, 161)">LinuxAndUbuntu.com &nbsp;focuses on open source projects but &nbsp;specific on debian based distributions. We also give value to other linux distributions.</span></div>


					
				</td>				<td class="wsite-multicol-col" style="width:42.803738317757%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">Links</h2>

<div class="paragraph" style="text-align:left;"><a href="http://www.ubuntu.com" title="">Ubuntu.com</a></div>

<div class="paragraph" style="text-align:left;"><a href="/video-tutorials.html" title="">Video Tutorials</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/home/category/tutorials-howtos" title="">Tutorials &amp; HowTos</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/privacy-policy.html">Privacy Policy</a></div>

<div class="paragraph" style="text-align:left;"><a href="http://www.linuxandubuntu.com/contact-us.html">Contact us</a></div>


					
				</td>			</tr>
		</tbody>
	</table>
</div></div></div>

<div class="wsite-spacer" style="height:50px;"></div>

<div><div class="wsite-multicol"><div class="wsite-multicol-table-wrap" style="margin:0 -15px;">
	<table class="wsite-multicol-table">
		<tbody class="wsite-multicol-tbody">
			<tr class="wsite-multicol-tr">
				<td class="wsite-multicol-col" style="width:50%; padding:0 15px;">
					
						

<div><div class="wsite-image wsite-image-border-none " style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='http://blog.feedspot.com/linux_blogs/' target='_blank'>
<img src="/uploads/2/1/1/5/21152474/linuxandubuntu-transparent-1000px-linux_orig.png" alt="linuxandubuntu top 60 linux blog" style="width:auto;max-width:100%" />
</a>
<div style="display:block;font-size:90%"></div>
</div></div>


					
				</td>				<td class="wsite-multicol-col" style="width:50%; padding:0 15px;">
					
						

<div><div class="wsite-image wsite-image-border-none " style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:center">
<a href='http://blog.feedspot.com/ubuntu_blogs/' target='_blank'>
<img src="/uploads/2/1/1/5/21152474/linuxandubuntu-transparent-1000px-ubuntu_orig.png" alt="ubuntu top 25 blogs linuxandubuntu.com" style="width:auto;max-width:100%" />
</a>
<div style="display:block;font-size:90%"></div>
</div></div>


					
				</td>			</tr>
		</tbody>
	</table>
</div></div></div>


					
				</td>				<td class="wsite-multicol-col" style="width:31.508732009559%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">Like Us</h2>

<div><div id="645631142411644859" align="left" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Flinuxandubuntuofficial%2F&tabs&width=340&height=214&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId=522757631233307" width="340" height="214" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></div>



</div>

<div class="wsite-search-element-outer"><div class="wsite-search-element-align-left" style="padding: 10px 0 10px 0">
  <form class="wsite-search-element-form" action="/apps/search" method="get">
    <div class="wsite-search-element">
      <input class="wsite-input wsite-search-element-input" type="text" name="q" placeholder="Search" autocomplete="off" />
      <span class="wsite-search-element-submit" title="Search"></span>
    </div>
  </form>
</div></div>


					
				</td>				<td class="wsite-multicol-col" style="width:22.852331419894%; padding:0 15px;">
					
						

<h2 class="wsite-content-title" style="text-align:left;">More From LinuxAndUbuntu</h2>

<div class="paragraph" style="text-align:left;"><a href="/submit-article.html"><font size="2">Contribute &nbsp;Your Work</font></a><br /><a href="/contact-us.html">Advertise</a><br /><a href="/donate-now.html" target="_blank">Donate Us</a></div>

<h2 class="wsite-content-title" style="text-align:left;">RSS Feed</h2>

<div><div class="wsite-image wsite-image-border-none " style="padding-top:10px;padding-bottom:10px;margin-left:0px;margin-right:0px;text-align:left">
<a href='http://feeds.feedburner.com/linuxandubuntu' target='_blank'>
<img src="/uploads/2/1/1/5/21152474/4532422_orig.png" alt="Picture" style="width:auto;max-width:100%" />
</a>
<div style="display:block;font-size:90%"></div>
</div></div>


					
				</td>			</tr>
		</tbody>
	</table>
</div></div></div>

<div class="paragraph" style="text-align:left;"><font color="#d5d5d5"><a href="http://www.ubuntu.com/" target="_blank">Ubuntu</a>&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;is a registered trademark of &nbsp;<a href="http://canonical.com/">Canonical Ltd</a>.<br /><br />Any material in this site can not be reproduced without permission.</font></div></div></div>
  </div>

  <div class="navmobile-wrapper">
    <div id="navmobile" class="nav"><ul class="wsite-menu-default">
		<li id="pg473124243954054265" class="wsite-menu-item-wrap">
			<a
						href="/"
				class="wsite-menu-item"
				>
				Homepage
			</a>
			
		</li>
		<li id="pg369144760395742060" class="wsite-menu-item-wrap">
			<a
						href="/store.html"
				class="wsite-menu-item"
				>
				Store
			</a>
			
		</li>
		<li id="pg497719449939535530" class="wsite-menu-item-wrap">
			<a
						href="/video-tutorials.html"
				class="wsite-menu-item"
				>
				Video Tutorials
			</a>
			
		</li>
		<li id="pg394823265735430346" class="wsite-menu-item-wrap">
			<a
						href="/linux-themes.html"
				class="wsite-menu-item"
				>
				Linux Themes
			</a>
			
		</li>
		<li id="pg990585951625353780" class="wsite-menu-item-wrap">
			<a
						href="/faqs.html"
				class="wsite-menu-item"
				>
				FAQs
			</a>
			
		</li>
		<li id="pg868701769148141363" class="wsite-menu-item-wrap">
			<a
						href="/become-a-regular-writer.html"
				class="wsite-menu-item"
				>
				Become a Regular writer
			</a>
			
		</li>
		<li id="pg488323224446624077" class="wsite-menu-item-wrap">
			<a
						href="/contact-us.html"
				class="wsite-menu-item"
				>
				Contact Us
			</a>
			
		</li>
		<li id="pg225612336786093830" class="wsite-menu-item-wrap">
			<a
						href="/donate-now.html"
				class="wsite-menu-item"
				>
				Donate
			</a>
			
		</li>
		<li id="pg758006490901768922" class="wsite-menu-item-wrap">
			<a
						href="/block-adblock.html"
				class="wsite-menu-item"
				>
				Block Adblock
			</a>
			
		</li>
</ul>
</div>
  </div>

  <script type="text/javascript" src="/files/theme/mobile.js"></script>
  <script type="text/javascript" src="/files/theme/plugins.js"></script>
  <script type="text/javascript" src="/files/theme/custom.js"></script>
  
  <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54735dd100c86111"></script>

<!--Hellobar code-->
<script src="//my.hellobar.com/d40bc16125e026e2838a1c33da0b62ab276fdaa2.js" type="text/javascript" charset="utf-8" async="async"></script>

<script>
  (function (w,i,d,g,e,t,s) {w[d] = w[d]||[];t= i.createElement(g);
    t.async=1;t.src=e;s=i.getElementsByTagName(g)[0];s.parentNode.insertBefore(t, s);
  })(window, document, '_gscq','script','//widgets.getsitecontrol.com/25631/script.js');
</script>

<div id="dialog-region"></div>
		<!--STATCOUNTER.COM SITE TRACKER CODE STARTS HERE-->

<!-- Start of StatCounter Code for Weebly -->
<script type="text/javascript">
var sc_project=10160336; 
var sc_invisible=1; 
var sc_security="10341dd9"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="weebly
statistics" href="http://statcounter.com/weebly/"
target="_blank"><img class="statcounter"
src="http://c.statcounter.com/10160336/0/10341dd9/1/"
alt="weebly statistics"></a></div></noscript>
<!-- End of StatCounter Code for Weebly --><script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-7870337-1']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_setAllowLinker', true]);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wGA = '_gaq';

</script>

<script type="text/javascript" async=1>
	;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalSnowplowNamespace=p.GlobalSnowplowNamespace||[];
			p.GlobalSnowplowNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
			};p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
			n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,'script','//cdn2.editmysite.com/js/wsnbn/snowday262.js','snowday'));

	var r = [99, 104, 101, 99, 107, 111, 117, 116, 46, 40, 119, 101, 101, 98, 108, 121, 124, 101, 100, 105, 116, 109, 121, 115, 105, 116, 101, 41, 46, 99, 111, 109];
	var snPlObR = function(arr) {
		var s = '';
		for (var i = 0 ; i < arr.length ; i++){
			s = s + String.fromCharCode(arr[i]);
		}
		return s;
	};
	var s = snPlObR(r);

	var regEx = new RegExp(s);

	_W.Analytics = _W.Analytics || {'trackers': {}};
	_W.Analytics.trackers.wSP = 'snowday';
	_W.Analytics.user_id = '21152474';
	_W.Analytics.site_id = '208815729450551065';


	(function(app_id, ec_hostname, discover_root_domain) {
		var track = window[_W.Analytics.trackers.wSP];
		if (!track) return;
		track('newTracker', app_id, ec_hostname, {
			appId: app_id,
			post: true,
			platform: 'web',
			discoverRootDomain: discover_root_domain,
			cookieName: '_snow_',
			contexts: {
				webPage: true,
				performanceTiming: true,
				gaCookies: true
			},
			crossDomainLinker: function (linkElement) {
				return regEx.test(linkElement.href);
			}
		});
		track('trackPageView', _W.Analytics.user_id+':'+_W.Analytics.site_id);
		track('crossDomainLinker', function (linkElement) {
			return regEx.test(linkElement.href);
		});
	})(
		'_wn',
		'ec.editmysite.com',
		true
	);
</script>

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = "https://secure.quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-0dYLvhSGGqUWo",
labels:"l10,u21152474.u21152474s208815729450551065"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-0dYLvhSGGqUWo.gif?labels=l10,u21152474.u21152474s208815729450551065" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


<script>

	(function(jQuery) {
		try {
			if (jQuery) {
				jQuery('div.blog-social div.fb-like').attr('class', 'blog-social-item blog-fb-like');
				var $commentFrame = jQuery('#commentArea iframe');
				if ($commentFrame.length > 0) {
					var frameHeight = jQuery($commentFrame[0].contentWindow.document).height() + 50;
					$commentFrame.css('min-height', frameHeight + 'px');
				}
				if (jQuery('.product-button').length > 0){
					jQuery(document).ready(function(){
						jQuery('.product-button').parent().each(function(index, product){
							if(jQuery(product).attr('target') == 'paypal'){
								if (!jQuery(product).find('> [name="bn"]').length){
									jQuery('<input>').attr({
										type: 'hidden',
										name: 'bn',
										value: 'DragAndDropBuil_SP_EC'
									}).appendTo(product);
								}
							}
						});
					});
				}
			}
			else {
				// Prototype
				$$('div.blog-social div.fb-like').each(function(div) {
					div.className = 'blog-social-item blog-fb-like';
				});
				$$('#commentArea iframe').each(function(iframe) {
					iframe.style.minHeight = '410px';
				});
			}
		}
		catch(ex) {}
	})(window._W && _W.jQuery);

</script>
<div id="eu-cookie" class="notification" style="display: none;">
	<span id="eu-cookie-content"></span>
	<span id="eu-cookie-close">&#10005;</span>
</div>

<script type="text/javascript">
	(function($) {
		window.cookie_location = 'off';
		// this cookie_content should already be pre-encoded from CookieSettingView.js
		window.cookie_content = 'By using this site you consent to the use of cookies. Cookies can be managed in your browser or device settings.' || _W.stl('templates.publish.virtual-includes.footerCode_1');
		window.cookie_policy_key = '208815729450551065_cookie_policy';
		window.cookie_content_hash = 'e67c816bde33ee2f23878d228c1c751d80249811';

		if (!_W.getCookie(window.cookie_policy_key) || _W.getCookie(window.cookie_policy_key) !== window.cookie_content_hash){
			if (window.cookie_location === 'top' || window.cookie_location === 'bottom'){
				$('#eu-cookie-content').text(decodeURIComponent(window.cookie_content));
				(window.cookie_location === 'top') ? animateFromTop() : animateFromBottom();
				$('#eu-cookie').show();
			}
		}

		$('#eu-cookie-close').click(function(){
			_W.setCookie(window.cookie_policy_key, window.cookie_content_hash, 100000);
			$('#eu-cookie').hide();
		});

		function animateFromTop(){
			$('#eu-cookie').css({
				'top': '0px',
				'animation': 'reveal-top 1 2s'
			});
		}

		function animateFromBottom(){
			$('#eu-cookie').css({
				'bottom': '0px',
				'animation': 'reveal-bottom 1 2s'
			});
		}
	})(window._W && _W.jQuery);
</script>

<script type="text/javascript">
	var disqus_shortname = "linuxandubuntu";

	(function () {
	var s = document.createElement("script"); s.async = true;
	s.type = "text/javascript";
	s.src = "//" + disqus_shortname + ".disqus.com/count.js";
	(document.getElementsByTagName("HEAD")[0] || document.getElementsByTagName("BODY")[0]).appendChild(s);
	}());
</script>
<div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({
			appId : '190291501407',
			xfbml : true,
			version : 'v2.6'
		});

        // Set Facebook comment plugin's colorscheme based off of theme
		var comments = document.getElementsByClassName('facebook-comment-widget'),
			scheme = document.body.className.match('wsite-theme-light');

		for (var i = 0; i < comments.length; i++) {
			comments[i].setAttribute('colorscheme', scheme ? 'light' : 'dark');
		}

		var fbCommentCounts;

		FB.Event.subscribe('xfbml.render', function(){
			fbCommentCounts = jQuery('.fb_comments_count');
			for (var i = 0; i < fbCommentCounts.length; i++) {
				var commentText = (jQuery(fbCommentCounts[i]).text() == '1' ? "Comment" : "Comments");
				jQuery(fbCommentCounts[i]).parent().siblings('.fb_comment_count_label').text(commentText);
			}
		});

		var comment_callback = function(res) {
			FB.XFBML.parse(); // Refresh comment counters on page
		}

		FB.Event.subscribe('comment.create', comment_callback);
		FB.Event.subscribe('comment.remove', comment_callback);

	};

	(function(d, s, id){
		var js, fjs = d.getElementsByTagName(s)[0];
		if (d.getElementById(id)) {return;}
		js = d.createElement(s); js.id = id;
		js.src = "//connect.facebook.net/"+_W.facebookLocale+"/sdk.js";
		fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));
</script>
<script type='text/javascript'>
	(function() {
		function j(src, id) {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.async = true;
			s.src = src;
			if(id) {s.id=id};
			document.getElementsByTagName('head')[0].appendChild(s);
		}
		j('//platform.twi'+'tter.com/widgets.js');
	})()
</script>
	</body>
</html>
