<!DOCTYPE html><html lang=en-US><head><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1"><link rel=profile href=http://gmpg.org/xfn/11><title>Things To Remember Before Buying Web Hosting - LinuxAndUbuntu</title><meta name=robots content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link rel=canonical href=http://www.linuxandubuntu.com/home/buying-web-hosting><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Things To Remember Before Buying Web Hosting - LinuxAndUbuntu"><meta property=og:description content="Almost all web hosting companies claim to be the #1 in the business. When buying web hosting, there are some essential points to consider. Often somebody decides to buy a web hosting, he looks to buy a plan with everything unlimited. All companies guarantee to provide unlimited storage, unlimited bandwidth,..."><meta property=og:url content=http://www.linuxandubuntu.com/home/buying-web-hosting><meta property=og:site_name content=LinuxAndUbuntu><meta property=article:publisher content=https://facebook.com/linuxandubuntuofficial><meta property=article:section content="Web hosting"><meta property=article:published_time content=2020-04-05T08:16:09+00:00><meta property=article:modified_time content=2020-04-05T08:18:55+00:00><meta property=og:updated_time content=2020-04-05T08:18:55+00:00><meta property=og:image content="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?fit=1200%2C675"><meta property=og:image:secure_url content="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?fit=1200%2C675"><meta property=og:image:width content=1200><meta property=og:image:height content=675><meta name=twitter:card content=summary_large_image><meta name=twitter:description content="Almost all web hosting companies claim to be the #1 in the business. When buying web hosting, there are some essential points to consider. Often somebody decides to buy a web hosting, he looks to buy a plan with everything unlimited. All companies guarantee to provide unlimited storage, unlimited bandwidth,..."><meta name=twitter:title content="Things To Remember Before Buying Web Hosting - LinuxAndUbuntu"><meta name=twitter:site content=@linuxandubuntu><meta name=twitter:image content="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?fit=1200%2C675"><meta name=twitter:creator content=@linuxandubuntu> <script type=application/ld+json class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.linuxandubuntu.com/#website","url":"http://www.linuxandubuntu.com/","name":"LinuxAndUbuntu","inLanguage":"en-US","publisher":{"@id":"http://www.linuxandubuntu.com/#/schema/person/"},"potentialAction":[{"@type":"SearchAction","target":"http://www.linuxandubuntu.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?fit=1200%2C675","width":1200,"height":675,"caption":"things to consider before buying web hosting"},{"@type":"WebPage","@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#webpage","url":"http://www.linuxandubuntu.com/home/buying-web-hosting","name":"Things To Remember Before Buying Web Hosting - LinuxAndUbuntu","isPartOf":{"@id":"http://www.linuxandubuntu.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#primaryimage"},"datePublished":"2020-04-05T08:16:09+00:00","dateModified":"2020-04-05T08:18:55+00:00","breadcrumb":{"@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#breadcrumb"},"potentialAction":[{"@type":"ReadAction","target":["http://www.linuxandubuntu.com/home/buying-web-hosting"]}]},{"@type":"BreadcrumbList","@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"http://www.linuxandubuntu.com/","url":"http://www.linuxandubuntu.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"http://www.linuxandubuntu.com/home/buying-web-hosting","url":"http://www.linuxandubuntu.com/home/buying-web-hosting","name":"Things To Remember Before Buying Web Hosting"}}]},{"@type":"Article","@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#article","isPartOf":{"@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#webpage"},"author":{"@id":"http://www.linuxandubuntu.com/#/schema/person/a20c2349e091e28ddcb1a1709a6d2165"},"headline":"Things To Remember Before Buying Web Hosting","datePublished":"2020-04-05T08:16:09+00:00","dateModified":"2020-04-05T08:18:55+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#webpage"},"publisher":{"@id":"http://www.linuxandubuntu.com/#/schema/person/"},"image":{"@id":"http://www.linuxandubuntu.com/home/buying-web-hosting#primaryimage"},"articleSection":"Web hosting","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["http://www.linuxandubuntu.com/home/buying-web-hosting#respond"]}]},{"@type":["Person"],"@id":"http://www.linuxandubuntu.com/#/schema/person/a20c2349e091e28ddcb1a1709a6d2165","name":"Sohail","image":{"@type":"ImageObject","@id":"http://www.linuxandubuntu.com/#authorlogo","inLanguage":"en-US","url":"http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=96&d=mm&r=g","caption":"Sohail"},"description":"Mohd Sohail is a web developer and a Linux sysAdmin. He also loves to write how-to articles, applications reviews and loves to use new Linux distributions.","sameAs":[]}]}</script> <link rel=dns-prefetch href=//ajax.googleapis.com><link rel=dns-prefetch href=//fonts.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="LinuxAndUbuntu &raquo; Feed" href=http://www.linuxandubuntu.com/feed><link rel=alternate type=application/rss+xml title="LinuxAndUbuntu &raquo; Comments Feed" href=http://www.linuxandubuntu.com/comments/feed><link rel=alternate type=application/rss+xml title="LinuxAndUbuntu &raquo; Things To Remember Before Buying Web Hosting Comments Feed" href=http://www.linuxandubuntu.com/home/buying-web-hosting/feed> <script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.linuxandubuntu.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};
/*! This file is auto-generated */
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style>img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel=stylesheet id=plugin_name-admin-ui-css-css  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/smoothness/jquery-ui.css?ver=4.6.4' type=text/css media><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/fe663.css media=all><link rel=stylesheet id=wp-block-library-css  href=https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/style.min.css type=text/css media=all><style id=wp-block-library-inline-css>.has-text-align-justify{text-align:justify}</style><link rel=stylesheet id=wp-block-library-theme-css  href=https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/theme.min.css type=text/css media=all><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/2f137.css media=all><link rel=stylesheet id=penci-fonts-css  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMukta+Vaani%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CTeko%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMegrim%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CNunito%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext' type=text/css media=all><link rel=stylesheet id=penci-font-nunitovfbeta-css  href='//fonts.googleapis.com/earlyaccess/nunitovfbeta.css?ver=6.5.7' type=text/css media=all><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/d6466.css media=all><style id=penci-style-inline-css>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</style><!--[if lt IE 9]><link rel=stylesheet id=vc_lte_ie9-css  href='http://www.linuxandubuntu.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.2' type=text/css media=screen> <![endif]--><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/d49e0.css media=all><style id=an_style-inline-css>.JYmXhhXimcmy-bg{display:none;position:fixed;z-index:100;top:0;left:0;width:100%;height:100%;background:#000;background:rgba(0,0,0,0.75)}.JYmXhhXimcmy{visibility:hidden;position:fixed;z-index:101;top:100px;right:0;left:0;max-width:640px;margin-right:auto;margin-left:auto;background:#fff;-webkit-box-shadow:0 3px 5px 2px rgba(0,0,0,0.25);box-shadow:0 3px 5px 2px rgba(0,0,0,0.25);font-family:Arial,Helvetica,sans-serif}.JYmXhhXimcmy-default,.JYmXhhXimcmy-ok{padding:30px
30px 15px}.JYmXhhXimcmy-image{overflow:hidden;position:relative;width:100%}.JYmXhhXimcmy-image .JYmXhhXimcmy-left{position:absolute;top:0;left:0;width:50%;height:100%}.JYmXhhXimcmy-image .JYmXhhXimcmy-right{float:right;width:50%;padding:30px}.JYmXhhXimcmy.small{width:200px;margin-left:-140px}.JYmXhhXimcmy.medium{width:400px;margin-left:-240px}.JYmXhhXimcmy.large{width:600px;margin-left:-340px}.JYmXhhXimcmy.xlarge{width:800px;margin-left:-440px}.close-JYmXhhXimcmy{display:inline-block;position:absolute;top:15px;right:15px;width:30px;height:30px;color:#bbb;font-size:32px;font-weight:700;line-height:30px;text-align:center;cursor:pointer;-webkit-transition:0.3s;transition:0.3s}.close-JYmXhhXimcmy:hover{color:#252b37}.JYmXhhXimcmy
h1{margin-bottom:15px;padding:0
30px;color:#252b37;font-size:28px;line-height:1.25;text-align:center}.JYmXhhXimcmy-right
h1{padding:0
30px 0 0;text-align:left}.JYmXhhXimcmy
p{margin-bottom:15px;color:#333745;font-size:14px}.JYmXhhXimcmy p
a{color:#ff6160}.JYmXhhXimcmy-right .close-modal,.JYmXhhXimcmy-footer .close-modal{padding:15px
!important;border-radius:0 !important;background-color:#ff6160;font-size:14px;letter-spacing:2px !important;-webkit-transition:0.3s;transition:0.3s}.JYmXhhXimcmy-right .close-modal:hover,.JYmXhhXimcmy-footer .close-modal:hover{background-color:#252b37 !important}.JYmXhhXimcmy-footer .grey-button-modal{margin-right:15px;background-color:#a5a5a5}.JYmXhhXimcmy-footer{display:block;padding:15px
30px;background-color:#eff4f7;text-align:right}@media only screen and (max-width: 640px){.JYmXhhXimcmy{right:5%;left:5%;max-width:90%}.JYmXhhXimcmy-default{padding:20px}.JYmXhhXimcmy-image .JYmXhhXimcmy-left{width:100%;height:250px}.JYmXhhXimcmy-image .JYmXhhXimcmy-right{float:left;width:100%;margin-top:250px;padding:20px}.JYmXhhXimcmy
h1{margin-bottom:10px;font-size:20px}.JYmXhhXimcmy-right
h1{padding:0}.JYmXhhXimcmy
p{margin-bottom:10px}.close-JYmXhhXimcmy{color:#fcfcfc;background-color:#252b37}.close-JYmXhhXimcmy:hover{color:#252b37;background-color:#fcfcfc}.JYmXhhXimcmy-footer{padding:15px
20px}}@media only screen and (max-width: 480px){.JYmXhhXimcmy-image .JYmXhhXimcmy-left{height:200px}.JYmXhhXimcmy-image .JYmXhhXimcmy-right{margin-top:200px}.JYmXhhXimcmy-footer{text-align:center}.JYmXhhXimcmy-footer .close-modal{width:80%;margin:5px
10%}}</style><link rel=stylesheet id=jetpack_css-css  href=https://c0.wp.com/p/jetpack/8.3/css/jetpack.css type=text/css media=all> <script>!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://steadfastsystem.com/v2/0/byg1NxaQB869wUh0ENt-wJttqsaNAU0F0ut_Zl1SpNnGDd5fcTmr1OFdstGphgRLnNY7O5wbR0aUU2aVEsGE0aHUxvaOydf-P6uBeYY80V7S_3deQfvYQ2tt183yjL5P13bv8XaCQ",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script><script src=https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery.js></script> <script src=https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery-migrate.min.js></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/f292e.js></script> <script>var wpp_object={"ajaxurl":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","copyText":"Copied !","voteText":"Vote(s)"};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/31fbb.js></script> <link rel=EditURI type=application/rsd+xml title=RSD href=http://www.linuxandubuntu.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=http://www.linuxandubuntu.com/wp-includes/wlwmanifest.xml><link rel=shortlink href='http://www.linuxandubuntu.com/?p=22074'><link rel=alternate type=application/json+oembed href="http://www.linuxandubuntu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting"><link rel=alternate type=text/xml+oembed href="http://www.linuxandubuntu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting&#038;format=xml"><link rel=amphtml href=http://www.linuxandubuntu.com/home/amp/buying-web-hosting> <script>var portfolioDataJs=portfolioDataJs||[];var penciBlocksArray=[];var PENCILOCALCACHE={};(function(){"use strict";PENCILOCALCACHE={data:{},remove:function(ajaxFilterItem){delete PENCILOCALCACHE.data[ajaxFilterItem];},exist:function(ajaxFilterItem){return PENCILOCALCACHE.data.hasOwnProperty(ajaxFilterItem)&&PENCILOCALCACHE.data[ajaxFilterItem]!==null;},get:function(ajaxFilterItem){return PENCILOCALCACHE.data[ajaxFilterItem];},set:function(ajaxFilterItem,cachedData){PENCILOCALCACHE.remove(ajaxFilterItem);PENCILOCALCACHE.data[ajaxFilterItem]=cachedData;}};})();function penciBlock(){this.atts_json='';this.content='';}</script> <link rel=dns-prefetch href=//i0.wp.com><link rel=dns-prefetch href=//i1.wp.com><link rel=dns-prefetch href=//i2.wp.com><link rel=dns-prefetch href=//c0.wp.com><style>img#wpstats{display:none}</style><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"organization","@id":"#organization","logo":"","url":"http:\/\/www.linuxandubuntu.com\/","name":"LinuxAndUbuntu","description":""}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WebSite","name":"LinuxAndUbuntu","alternateName":"","url":"http:\/\/www.linuxandubuntu.com\/"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Sidebar Right","alternateName":"Add widgets here to display them on blog and single","url":"http:\/\/www.linuxandubuntu.com\/home\/buying-web-hosting"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Sidebar Left","alternateName":"Add widgets here to display them on page","url":"http:\/\/www.linuxandubuntu.com\/home\/buying-web-hosting"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Footer Column #1","alternateName":"Add widgets here to display them in the first column of the footer","url":"http:\/\/www.linuxandubuntu.com\/home\/buying-web-hosting"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Footer Column #2","alternateName":"Add widgets here to display them in the second column of the footer","url":"http:\/\/www.linuxandubuntu.com\/home\/buying-web-hosting"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WPSideBar","name":"Footer Column #3","alternateName":"Add widgets here to display them in the third column of the footer","url":"http:\/\/www.linuxandubuntu.com\/home\/buying-web-hosting"}</script><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"BlogPosting","headline":"Things To Remember Before Buying Web Hosting","description":"Almost all web hosting companies claim to be the #1 in the business. When buying web hosting, there are some essential points to consider. Often somebody decides to buy a web hosting, he looks to buy a plan with everything unlimited. All companies guarantee to provide unlimited storage, unlimited bandwidth,...","datePublished":"2020-04-05","datemodified":"2020-04-05","mainEntityOfPage":"http:\/\/www.linuxandubuntu.com\/home\/buying-web-hosting","image":{"@type":"ImageObject","url":"https:\/\/i0.wp.com\/www.linuxandubuntu.com\/wp-content\/uploads\/2020\/04\/things-to-consider-before-buying-web-hosting-2.png?fit=1200%2C675","width":1200,"height":675},"publisher":{"@type":"Organization","name":"LinuxAndUbuntu"},"author":{"@type":"Person","@id":"#person-Sohail","name":"Sohail"}}</script><meta property=fb:app_id content=348280475330978><meta name=generator content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."> <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:'/'};OneSignal.setDefaultNotificationUrl("http://www.linuxandubuntu.com");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options['wordpress']=true;oneSignal_options['appId']='a1705b21-de0a-4fad-92c1-6bb270274512';oneSignal_options['welcomeNotification']={};oneSignal_options['welcomeNotification']['title']="";oneSignal_options['welcomeNotification']['message']="";oneSignal_options['subdomainName']="linuxandubuntu";oneSignal_options['persistNotification']=false;oneSignal_options['promptOptions']={};oneSignal_options['promptOptions']['actionMessage']='Subscribe to our push notifications and never miss any latest article.';OneSignal.init(window._oneSignalInitOptions);OneSignal.showSlidedownPrompt();});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault();};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,false);}
if(document.readyState==='complete'){documentInitOneSignal();}
else{window.addEventListener("load",function(event){documentInitOneSignal();});}</script> <style>html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image{display:none}</style> <script>document.documentElement.classList.add('jetpack-lazy-images-js-enabled');</script> <link rel=icon href="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=32%2C32" sizes=32x32><link rel=icon href="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=192%2C192" sizes=192x192><link rel=apple-touch-icon href="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=180%2C180"><meta name=msapplication-TileImage content="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=270%2C270"> <noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><style>a.custom-button.pencisc-button{background:transparent;color:#D3347B;border:2px
solid #D3347B;line-height:36px;padding:0
20px;font-size:14px;font-weight:bold}a.custom-button.pencisc-button:hover{background:#D3347B;color:#fff;border:2px
solid #D3347B}a.custom-button.pencisc-button.pencisc-small{line-height:28px;font-size:12px}a.custom-button.pencisc-button.pencisc-large{line-height:46px;font-size:18px}</style></head><body class="post-template-default single single-post postid-22074 single-format-standard group-blog header-sticky penci_enable_ajaxsearch penci_sticky_content_sidebar sidebar-right penci-single-style-1 penci-autoload-prev penci-caption-above-img wpb-js-composer js-comp-ver-6.0.2 vc_responsive"><div id=page class=site><div class=site-header-wrapper><div class="header__top header--s2"><div class="penci-container-fluid header-top__container"><div class=site-branding><h2 class="site-title"><a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></h2></div><div class=header__banner> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:inline-block;width:728px;height:90px data-ad-client=ca-pub-1925104690687996 data-ad-slot=8182063423></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div></div><header id=masthead class="site-header header--s2" data-height=80 itemscope=itemscope itemtype=http://schema.org/WPHeader><div class="penci-container-fluid header-content__container"><nav id=site-navigation class="main-navigation pencimn-slide_down" itemscope itemtype=http://schema.org/SiteNavigationElement><ul id=menu-main-menu class=menu><li id=menu-item-9637 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9637"><a href=http://www.linuxandubuntu.com itemprop=url>Home</a></li><li id=menu-item-16021 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu penci-megamenu-fullwidth menu-item-16021"><a href=http://www.linuxandubuntu.com/home/category/distros itemprop=url>Linux Distributions</a><ul class=sub-menu><li id=menu-item-0 class=menu-item-0><div class=penci-megamenu><div class="penci-content-megamenu penci-content-megamenu-style-1"><div class="penci-mega-latest-posts col-mn-8 mega-row-1 "><div class="penci-mega-row penci-mega-162 row-active" data-current=1 data-blockUid=penci_megamenu__81355 ><div id=penci_megamenu__81355block_content class="penci-block_content penci-mega-row_content"><div class="penci-mega-post penci-mega-post-1 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Linux-Mint-20-Ulyana.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/linux-mint-20-codenamed-ulyana title="Linux Mint 20 Codenamed Ulyana &#038; More"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/linux-mint-20-codenamed-ulyana>Linux Mint 20 Codenamed Ulyana &#038; More</a></h3></div></div><div class="penci-mega-post penci-mega-post-2 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/03/Obarun-Arch-without-systemd.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/obarun-arch-based-linux-distro-without-systemd title="Obarun &#8211; An Arch Based Linux Distro Without Systemd"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/obarun-arch-based-linux-distro-without-systemd>Obarun &#8211; An Arch Based Linux Distro Without&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-3 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/01/Zorin-Grid.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/zorin-grid title="Zorin OS to release Zorin Grid for centralized management of Linux desktops"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/zorin-grid>Zorin OS to release Zorin Grid for centralized&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-4 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/12/Linux-Mint-19.3-Tricia-Beta-Released.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/linux-mint-19-3-tricia-beta title="Linux Mint 19.3 &#8220;Tricia&#8221; Beta Available To Download"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/linux-mint-19-3-tricia-beta>Linux Mint 19.3 &#8220;Tricia&#8221; Beta Available To Download</a></h3></div></div><div class="penci-mega-post penci-mega-post-5 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/11/ZorinOS-15-Lite.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/zorin-os-15-lite-best-replacement-for-windows-7 title="Zorin OS 15 Lite &#8211; The Best Replacement For Windows 7"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/zorin-os-15-lite-best-replacement-for-windows-7>Zorin OS 15 Lite &#8211; The Best Replacement&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-6 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/fedora-31-desktop.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/fedora-31-released title="Fedora 31 Released"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/fedora-31-released>Fedora 31 Released</a></h3></div></div><div class="penci-mega-post penci-mega-post-7 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/tails-4.0-released.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/tails-4-0-released title="Tails 4.0 Released"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/tails-4-0-released>Tails 4.0 Released</a></h3></div></div><div class="penci-mega-post penci-mega-post-8 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><a class="penci-image-holder  penci-lazy"  data-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/ubuntu-19.10-eoan-ermine.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/ubuntu-19-10-eoan-ermine-released title="What&#8217;s New In Ubuntu 19.10 &#8216;Eoan Ermine&#8217;"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/ubuntu-19-10-eoan-ermine-released>What&#8217;s New In Ubuntu 19.10 &#8216;Eoan Ermine&#8217;</a></h3></div></div><div class="penci-loader-effect penci-loading-animation-9"><div class=penci-loading-circle><div class="penci-loading-circle1 penci-loading-circle-inner"></div><div class="penci-loading-circle2 penci-loading-circle-inner"></div><div class="penci-loading-circle3 penci-loading-circle-inner"></div><div class="penci-loading-circle4 penci-loading-circle-inner"></div><div class="penci-loading-circle5 penci-loading-circle-inner"></div><div class="penci-loading-circle6 penci-loading-circle-inner"></div><div class="penci-loading-circle7 penci-loading-circle-inner"></div><div class="penci-loading-circle8 penci-loading-circle-inner"></div><div class="penci-loading-circle9 penci-loading-circle-inner"></div><div class="penci-loading-circle10 penci-loading-circle-inner"></div><div class="penci-loading-circle11 penci-loading-circle-inner"></div><div class="penci-loading-circle12 penci-loading-circle-inner"></div></div></div></div> <script>if(typeof(penciBlock)==="undefined"){function penciBlock(){this.atts_json='';this.content='';}}var penciBlocksArray=penciBlocksArray||[];var PENCILOCALCACHE=PENCILOCALCACHE||{};var penci_megamenu__81355=new penciBlock();penci_megamenu__81355.blockID="penci_megamenu__81355";penci_megamenu__81355.atts_json='{"showposts":8,"style_pag":"next_prev","post_types":"post","block_id":"penci_megamenu__81355","paged":1,"unique_id":"penci_megamenu__81355","shortcode_id":"megamenu","cat_id":162,"tax":"category","category_ids":"","taxonomy":""}';penciBlocksArray.push(penci_megamenu__81355);</script> <span class=penci-slider-nav> <a class="penci-mega-pag penci-slider-prev penci-pag-disabled" data-block_id=penci_megamenu__81355block_content href=#><i class="fa fa-angle-left"></i></a> <a class="penci-mega-pag penci-slider-next " data-block_id=penci_megamenu__81355block_content href=#><i class="fa fa-angle-right"></i></a> </span></div><div class="penci-loader-effect penci-loading-animation-9"><div class=penci-loading-circle><div class="penci-loading-circle1 penci-loading-circle-inner"></div><div class="penci-loading-circle2 penci-loading-circle-inner"></div><div class="penci-loading-circle3 penci-loading-circle-inner"></div><div class="penci-loading-circle4 penci-loading-circle-inner"></div><div class="penci-loading-circle5 penci-loading-circle-inner"></div><div class="penci-loading-circle6 penci-loading-circle-inner"></div><div class="penci-loading-circle7 penci-loading-circle-inner"></div><div class="penci-loading-circle8 penci-loading-circle-inner"></div><div class="penci-loading-circle9 penci-loading-circle-inner"></div><div class="penci-loading-circle10 penci-loading-circle-inner"></div><div class="penci-loading-circle11 penci-loading-circle-inner"></div><div class="penci-loading-circle12 penci-loading-circle-inner"></div></div></div></div></div></div></li></ul></li><li id=menu-item-21700 class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu penci-megamenu-width1080 menu-item-21700"><a href=http://www.linuxandubuntu.com/home/category/linux/themes itemprop=url>Linux Themes</a><ul class=sub-menu><li class=menu-item-0><div class=penci-megamenu><div class="penci-content-megamenu penci-content-megamenu-style-1"><div class="penci-mega-latest-posts col-mn-5 mega-row-1 "><div class="penci-mega-row penci-mega-3892 row-active" data-current=1 data-blockUid=penci_megamenu__40964 ><div id=penci_megamenu__40964block_content class="penci-block_content penci-mega-row_content"><div class="penci-mega-post penci-mega-post-1 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-lazy"  data-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/unity-8-theme-for-ubuntu-unity-1.jpg?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/unity-8-theme-for-ubuntu-unity title="﻿Unity 8 Theme For Ubuntu Unity"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/unity-8-theme-for-ubuntu-unity>﻿Unity 8 Theme For Ubuntu Unity</a></h3></div></div><div class="penci-mega-post penci-mega-post-2 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-lazy"  data-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/osx-theme-for-ubuntu-linux.jpg?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/make-linux-look-like-osx-with-osx-arc-collection title="Make Linux Look Like OSX With OSX Arc Collection"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/make-linux-look-like-osx-with-osx-arc-collection>Make Linux Look Like OSX With OSX Arc&#8230;</a></h3></div></div><div class="penci-mega-post penci-mega-post-3 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-lazy"  data-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/10/plataro-master-icons-for-ubuntu.png?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/plataro-master-icon-theme-install-in-ubuntu-1604 title="Plataro Master Icon Theme Install In Ubuntu 16.04"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/plataro-master-icon-theme-install-in-ubuntu-1604>Plataro Master Icon Theme Install In Ubuntu 16.04</a></h3></div></div><div class="penci-mega-post penci-mega-post-4 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-lazy"  data-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/07/10-best-icon-themes-for-linux.jpg?resize=280%2C186" data-delay href=http://www.linuxandubuntu.com/home/10-best-icon-themes-for-linux title="10 Best Icon Themes For Linux"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/10-best-icon-themes-for-linux>10 Best Icon Themes For Linux</a></h3></div></div><div class="penci-mega-post penci-mega-post-5 penci-imgtype-landscape"><div class=penci-mega-thumbnail><a class=mega-cat-name href=http://www.linuxandubuntu.com/home/category/linux/themes>Themes</a><a class="penci-image-holder  penci-lazy"  data-src=http://www.linuxandubuntu.com/wp-content/themes/pennews/images/no-thumb.jpg data-delay href=http://www.linuxandubuntu.com/home/adwaita-grey-31411-theme-updated-install-in-ubuntu title="Adwaita-Grey 3.14.11 Theme Updated Install In Ubuntu"></a></div><div class="penci-mega-meta penci-mega-hide-date"><h3 class="post-mega-title entry-title"> <a href=http://www.linuxandubuntu.com/home/adwaita-grey-31411-theme-updated-install-in-ubuntu>Adwaita-Grey 3.14.11 Theme Updated Install In Ubuntu</a></h3></div></div><div class="penci-loader-effect penci-loading-animation-9"><div class=penci-loading-circle><div class="penci-loading-circle1 penci-loading-circle-inner"></div><div class="penci-loading-circle2 penci-loading-circle-inner"></div><div class="penci-loading-circle3 penci-loading-circle-inner"></div><div class="penci-loading-circle4 penci-loading-circle-inner"></div><div class="penci-loading-circle5 penci-loading-circle-inner"></div><div class="penci-loading-circle6 penci-loading-circle-inner"></div><div class="penci-loading-circle7 penci-loading-circle-inner"></div><div class="penci-loading-circle8 penci-loading-circle-inner"></div><div class="penci-loading-circle9 penci-loading-circle-inner"></div><div class="penci-loading-circle10 penci-loading-circle-inner"></div><div class="penci-loading-circle11 penci-loading-circle-inner"></div><div class="penci-loading-circle12 penci-loading-circle-inner"></div></div></div></div> <script>if(typeof(penciBlock)==="undefined"){function penciBlock(){this.atts_json='';this.content='';}}var penciBlocksArray=penciBlocksArray||[];var PENCILOCALCACHE=PENCILOCALCACHE||{};var penci_megamenu__40964=new penciBlock();penci_megamenu__40964.blockID="penci_megamenu__40964";penci_megamenu__40964.atts_json='{"showposts":5,"style_pag":"next_prev","post_types":"post","block_id":"penci_megamenu__40964","paged":1,"unique_id":"penci_megamenu__40964","shortcode_id":"megamenu","cat_id":3892,"tax":"category","category_ids":"","taxonomy":""}';penciBlocksArray.push(penci_megamenu__40964);</script> <span class=penci-slider-nav> <a class="penci-mega-pag penci-slider-prev penci-pag-disabled" data-block_id=penci_megamenu__40964block_content href=#><i class="fa fa-angle-left"></i></a> <a class="penci-mega-pag penci-slider-next " data-block_id=penci_megamenu__40964block_content href=#><i class="fa fa-angle-right"></i></a> </span></div><div class="penci-loader-effect penci-loading-animation-9"><div class=penci-loading-circle><div class="penci-loading-circle1 penci-loading-circle-inner"></div><div class="penci-loading-circle2 penci-loading-circle-inner"></div><div class="penci-loading-circle3 penci-loading-circle-inner"></div><div class="penci-loading-circle4 penci-loading-circle-inner"></div><div class="penci-loading-circle5 penci-loading-circle-inner"></div><div class="penci-loading-circle6 penci-loading-circle-inner"></div><div class="penci-loading-circle7 penci-loading-circle-inner"></div><div class="penci-loading-circle8 penci-loading-circle-inner"></div><div class="penci-loading-circle9 penci-loading-circle-inner"></div><div class="penci-loading-circle10 penci-loading-circle-inner"></div><div class="penci-loading-circle11 penci-loading-circle-inner"></div><div class="penci-loading-circle12 penci-loading-circle-inner"></div></div></div></div></div></div></li></ul></li><li id=menu-item-17077 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17077"><a href=http://www.linuxandubuntu.com/home/category/linux-tutorials itemprop=url>Linux Tutorials</a></li><li id=menu-item-8337 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-8337"><a href=http://www.linuxandubuntu.com/faqs itemprop=url>Linux FAQs</a></li><li id=menu-item-9733 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9733"><a href=http://www.linuxandubuntu.com/advertise itemprop=url>Advertise</a></li><li id=menu-item-9636 class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9636"><a href=http://www.linuxandubuntu.com/contact-us itemprop=url>Contact us</a></li></ul></nav></div></header></div><div class=penci-header-mobile ><div class=penci-header-mobile_container> <button class="menu-toggle navbar-toggle" aria-expanded=false><span class=screen-reader-text>Primary Menu</span><i class="fa fa-bars"></i></button><div class=site-branding><div class=site-title><a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></div></div></div></div><div id=content class=site-content><div id=primary class=content-area><main id=main class=site-main ><div class=penci-container><div class="penci-container__content penci-con_sb1_sb2"><div class="penci-wide-content penci-content-novc penci-sticky-content penci-content-single-inner"><div class=theiaStickySidebar><div class="penci-content-post noloaddisqus " data-url=http://www.linuxandubuntu.com/home/buying-web-hosting data-id=22074 data-title> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-1925104690687996 data-ad-slot=7903274511 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script><br><div class="penci_breadcrumbs "><ul itemscope itemtype=http://schema.org/BreadcrumbList><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem><a class=home href=http://www.linuxandubuntu.com itemprop=item><span itemprop=name>Home</span></a><meta itemprop=position content=1></li><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem><i class="fa fa-angle-right"></i><a href=http://www.linuxandubuntu.com/home/category/web-hosting itemprop=item><span itemprop=name>Web hosting</span></a><meta itemprop=position content=2></li><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem><i class="fa fa-angle-right"></i><a href=http://www.linuxandubuntu.com/home/buying-web-hosting itemprop=item><span itemprop=name>Things To Remember Before Buying Web Hosting</span></a><meta itemprop=position content=3></li></ul></div><article id=post-22074 class="penci-single-artcontent noloaddisqus post-22074 post type-post status-publish format-standard has-post-thumbnail hentry category-web-hosting penci-post-item"><header class="entry-header penci-entry-header penci-title-"><div class=penci-entry-categories><span class=penci-cat-links><a href=http://www.linuxandubuntu.com/home/category/web-hosting rel="category tag">Web hosting</a></span></div><h1 class="entry-title penci-entry-title penci-title-">Things To Remember Before Buying Web Hosting</h1><div class="entry-meta penci-entry-meta"> <span class="entry-meta-item penci-byline">by <span class="author vcard"><a class="url fn n" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span></span><span class="entry-meta-item penci-posted-on"><i class="fa fa-clock-o"></i><time class="entry-date published" datetime=2020-04-05T13:48:55+05:30>April 5, 2020</time><time class=updated datetime=2020-04-05T13:48:55+05:30>April 5, 2020</time></span><span class="entry-meta-item penci-comment-count"><a class=penci_pmeta-link href=http://www.linuxandubuntu.com/home/buying-web-hosting#respond><i class="la la-comments"></i>0</a></span></div></header><div class="entry-media penci-entry-media"><div class="post-format-meta "><div class="post-image penci-standard-format"><img width=960 height=540 src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?fit=960%2C540" class="attachment-penci-thumb-960-auto size-penci-thumb-960-auto wp-post-image jetpack-lazy-image" alt="things to consider before buying web hosting" data-lazy-srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?w=1200 1200w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?resize=300%2C169 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?resize=1024%2C576 1024w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?resize=768%2C432 768w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?resize=960%2C540 960w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?resize=711%2C400 711w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?resize=585%2C329 585w" data-lazy-sizes="(max-width: 960px) 100vw, 960px" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/things-to-consider-before-buying-web-hosting-2.png?fit=960%2C540&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7></div></div></div><div class="penci-entry-content entry-content"><p>Almost all <strong>web hosting companies</strong> claim to be the #1 in the business. When <strong>buying web hosting</strong>, there are some essential points to consider. Often somebody decides to buy a web hosting, he looks to buy a plan with everything unlimited.</p><p>All companies guarantee to provide unlimited storage, unlimited bandwidth, unlimited emails, and so on. But is that really the case? Or should you look for everything unlimited in a web hosting plan? Let&#8217;s talk about this one-by-one.</p><h2>Unlimited storage</h2><div class=wp-block-image><figure class="aligncenter size-large"><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?fit=1024%2C683" alt="server cloud storage" class="wp-image-22282 jetpack-lazy-image" data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?w=1920 1920w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=300%2C200 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=1024%2C683 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=768%2C512 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=1536%2C1024 1536w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=450%2C300 450w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=480%2C320 480w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=280%2C186 280w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=960%2C640 960w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=600%2C400 600w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=585%2C390 585w" data-lazy-sizes="(max-width: 1400px) 100vw, 1400px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?fit=1024%2C683&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?fit=1024%2C683" alt="server cloud storage" class=wp-image-22282 srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?w=1920 1920w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=300%2C200 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=1024%2C683 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=768%2C512 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=1536%2C1024 1536w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=450%2C300 450w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=480%2C320 480w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=280%2C186 280w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=960%2C640 960w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=600%2C400 600w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/server-cloud-storage.jpg?resize=585%2C390 585w" sizes="(max-width: 1400px) 100vw, 1400px"></noscript><figcaption>server cloud storage</figcaption></figure></div><p><strong>Storage capacity</strong> should never be the #1 factor when buying a web hosting plan for a normal website. Most providers claim to provide unlimited storage in their &#8220;Recommended plans&#8221; aka. &#8220;Most popular plans&#8221;. We will talk about the reality of unlimited storage in a bit.</p><p>Obviously the amount of storage your website needs depends upon the content you&#8217;re going to host on your website. If you are hosting a simple WordPress blog, do not worry about the storage capacity as you will have plenty of storage for images, and smaller videos on the basic plan.</p><p>Only times when you need more storage is when hosting videos or large files on your server. In that case, you will not want to buy a shared hosting. You will need to go for either VPS or a dedicated server. VPS and dedicated servers are the best for storage &amp; data processing as you can upgrade server anytime.</p><p>Also, in shared hosting, unlimited storage feature is like the zeros in <strong>1.000000</strong>. There are six zeros in the number but worth nothing. Shared hosting plans may feature unlimited storage but they set a cap on Inode.</p><p>An Inode is a file on your server. It could be a text file, html page, image, video, etc. Inode limit cancels out the unlimited storage feature. Most companies set Inode limit from 100,000 to 250,000 which means you can not save more than the set Inode limit on your server.</p><p>After the Inode limit is reached, your website will start to suffer. It will not be able to create cache files, server logs will not be saved and the server will throw errors. Host frequently checks for accounts using more than the threshold limit and suspend such accounts if necessary.</p><p>So when you need more storage, go for VPS or a dedicated server as there is no Inode limit there. You can also upgrade your storage anytime you need it.</p><h2>Unlimited bandwidth &amp; emails</h2><div class=wp-block-image><figure class="aligncenter size-large"><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?fit=1024%2C683" alt="LAN cable" class="wp-image-22283 jetpack-lazy-image" data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?w=1280 1280w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=300%2C200 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=1024%2C683 1024w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=768%2C512 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=450%2C300 450w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=480%2C320 480w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=280%2C186 280w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=960%2C641 960w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=600%2C400 600w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=585%2C390 585w" data-lazy-sizes="(max-width: 1280px) 100vw, 1280px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?fit=1024%2C683&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?fit=1024%2C683" alt="LAN cable" class=wp-image-22283 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?w=1280 1280w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=300%2C200 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=1024%2C683 1024w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=768%2C512 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=450%2C300 450w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=480%2C320 480w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=280%2C186 280w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=960%2C641 960w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=600%2C400 600w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/LAN-cable.jpg?resize=585%2C390 585w" sizes="(max-width: 1280px) 100vw, 1280px"></noscript></figure></div><p>Unlimited bandwidth &amp; emails are highlighted features in almost all web hosting plans. Bandwidth is the amount of data transferred from your server to the user. Like unlimited storage, unlimited bandwidth is also not included in basic plans.</p><p>Like unlimited storage isn&#8217;t truly unlimited, unlimited bandwidth is also not unlimited. There is a limit that they consider normal and only allow the bandwidth in that limit. It may sound strange but it&#8217;s the reality. Anyway, for your specific case, if your website is not a special application that requires too much data to pull from the internet or send it to the user, you can go with the basic plan.</p><p>While looking for web hosting for a normal blog, you can ignore the bandwidth option. Just go with the basic one and later on you can upgrade to a higher plan. For now, save money for your new business.</p><p>Most companies provide a few free email accounts with the basic plan. If you have multiple webmasters, you may need to buy more email accounts. Here you can choose if you need more emails and then go with the plan that provides enough email accounts for you. Also, do not forget the storage they provide for emails. In free accounts, some hosting companies only provide 50MB space for each email account.</p><p>Also, make sure that the hosting provider has tools to protect you from spam emails. They frequently scan emails for any malicious attachment and properly move spam to the spam folder.</p><h2>Unlimited database</h2><div class=wp-block-image><figure class="aligncenter size-large"><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?w=1400" alt="Database schema" class="wp-image-22294 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?w=640 640w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?resize=300%2C262 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?resize=458%2C400 458w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?resize=585%2C511 585w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?w=1400&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?w=1400" alt="Database schema" class=wp-image-22294 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?w=640 640w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?resize=300%2C262 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?resize=458%2C400 458w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/Database-schema-1.png?resize=585%2C511 585w" sizes="(max-width: 640px) 100vw, 640px" data-recalc-dims=1></noscript></figure></div><p>Most web hosting providers support MySQL database. This database is different from the disk storage(though it is saved on the same disk). Database is where your website saves posts, products, and other website content. For each website, you need at least one database. If you are hosting one website, you will need one database.</p><h2>Unlimited websites</h2><p>Unlimited website is also one of the most attractive features. Most hosting companies include unlimited website in advanced plan. Only go for this feature if you want to host multiple websites.</p><h3>Cons of unlimited website</h3><p>Unlimited website feature comes at a cost. It does not matter which plan you buy, as I said above most web hosting companies put limits on all the services they provide. If you cross the limit, your account will be flagged for review and may even be suspended. Hosting multiple websites on one server is both performance and security risk. If one of your websites is compromised, others are also at risk.</p><h2>Focus on your needs</h2><p>All the features I mentioned above are important for some type of users but not all. If any of the features you like, go with it but bear in mind that it is not unlimited.</p><p>Analyze your website&#8217;s needs. Do not fall into the &#8220;unlimited trap&#8221;. If you need 10GB storage, just go for the basic plan and save money. You can always upgrade your hosting if you need more storage, more bandwidth, and more websites.</p><h2>How to select hosting provider?</h2><h3>Live customer support</h3><p>All the features I mentioned and those did not mention are provided by every hosting provider. So what hosting company should you go with?</p><div class=wp-block-image><figure class="aligncenter size-large"><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?fit=1024%2C576" alt="live customer support" class="wp-image-22297 jetpack-lazy-image" data-lazy-srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?w=1920 1920w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=300%2C169 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=1024%2C576 1024w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=768%2C432 768w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=1536%2C864 1536w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=960%2C540 960w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=711%2C400 711w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=585%2C329 585w" data-lazy-sizes="(max-width: 1400px) 100vw, 1400px" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?fit=1024%2C576&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?fit=1024%2C576" alt="live customer support" class=wp-image-22297 srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?w=1920 1920w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=300%2C169 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=1024%2C576 1024w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=768%2C432 768w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=1536%2C864 1536w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=960%2C540 960w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=711%2C400 711w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2020/04/live-customer-support.png?resize=585%2C329 585w" sizes="(max-width: 1400px) 100vw, 1400px"></noscript></figure></div><p>First thing first. Make sure there is a live support system. Live support is the most important feature that you should be looking for. When your website goes down or runs into any other type of error, your host should help you fix the problem immediately.</p><h3>Server uptime</h3><p>Secondly, check the server uptime. You can do that by reading existing customer reviews and service reviews by other bloggers.</p><h3>Latest technologies + easy to use cPanel</h3><p>Double check that the hosting company has all the latest versions of the tools available in the repository. For example, if you are hosting a WordPress blog, the latest version of PHP should be available.</p><p>cPanel is the dashboard of your hosting. Make sure that cPanel is easy to use by asking them for a demo.</p><h3>Affordable pricing</h3><p>Many web hosting cost you the earth for their basic plans. So view each service&#8217;s plan carefully and find the one that has enough features for your needs and also affordable.</p><h3>Tools to migrate your existing site</h3><p>If you are migrating the existing website to another host, then make sure that the host provides tools to make the migration process easier and secure. Usually, the migration process is not difficult but any tiny mistake can corrupt the entire website database.</p><h2>Conclusion</h2><p>To conclude this, just think of <strong>buying web hosting</strong> as buying a house. The bigger the house the costlier it is. You do not want to buy a house that is bigger than your needs plus you&#8217;ll have to spend a ton of money on that.</p><p>Also do not forget the unlimited terms that I have just talked about in the article. Users love to see unlimited in the plan so companies have worked around it. They have included unlimited terms without actually implementing it into the services.</p><div style=height:47px aria-hidden=true class=wp-block-spacer></div><div class=wp-block-coblocks-alert><p class=wp-block-coblocks-alert__title><strong>Also read</strong></p><p class=wp-block-coblocks-alert__text>Read our <a href=http://www.linuxandubuntu.com/home/category/setup-web-server target=_blank rel="noreferrer noopener">web server setup series</a> for setting up your own server from scratch.</p></div></div><footer class=penci-entry-footer><div class=penci-source-via-tags-wrap></div><span class="penci-social-buttons penci-social-share-footer penci-social-share-center"><a href=# class="penci-post-like penci_post-meta_item  single-like-button penci-social-item like" data-post_id=22074 title=Like data-like=Like data-unlike=Unlike><i class="fa fa-thumbs-o-up"></i><span class=penci-share-number>0</span></a><a class="penci-social-item facebook" target=_blank rel=noopener title href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting"><i class="fa fa-facebook"></i></a><a class="penci-social-item twitter" target=_blank rel=noopener title href="https://twitter.com/intent/tweet?text=Things%20To%20Remember%20Before%20Buying%20Web%20Hosting%20-%20http://www.linuxandubuntu.com/home/buying-web-hosting"><i class="fa fa-twitter"></i></a><a class="penci-social-item google_plus" target=_blank rel=noopener title href="https://plus.google.com/share?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting"><i class="fa fa-google-plus"></i></a><a class="penci-social-item pinterest" target=_blank rel=noopener title href="http://pinterest.com/pin/create/button?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting&#038;media=http%3A%2F%2Fwww.linuxandubuntu.com%2Fwp-content%2Fuploads%2F2020%2F04%2Fthings-to-consider-before-buying-web-hosting-2.png&#038;description=Things%20To%20Remember%20Before%20Buying%20Web%20Hosting"><i class="fa fa-pinterest"></i></a><a class="penci-social-item linkedin" target=_blank rel=noopener title href="https://www.linkedin.com/shareArticle?mini=true&#038;url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting&#038;title=Things%20To%20Remember%20Before%20Buying%20Web%20Hosting"><i class="fa fa-linkedin"></i></a><a class="penci-social-item tumblr" target=_blank rel=noopener title href="https://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting&#038;name=Things%20To%20Remember%20Before%20Buying%20Web%20Hosting"><i class="fa fa-tumblr"></i></a><a class="penci-social-item reddit" target=_blank rel=noopener title href="https://reddit.com/submit?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting&#038;title=Things%20To%20Remember%20Before%20Buying%20Web%20Hosting"><i class="fa fa-reddit"></i></a><a class="penci-social-item telegram" target=_blank rel=noopener title href="https://telegram.me/share/url?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Fbuying-web-hosting&#038;text=Things%20To%20Remember%20Before%20Buying%20Web%20Hosting"><i class="fa fa-telegram"></i></a><a class="penci-social-item email" target=_blank rel=noopener href="mailto:?subject=Things%20To%20Remember%20Before%20Buying%20Web%20Hosting&#038;BODY=http://www.linuxandubuntu.com/home/buying-web-hosting"><i class="fa fa-envelope"></i></a></span></footer></article><div style="margin: 20px 0px; padding: 10px 5px; background: #F6F7F2; border-top: 2px solid #000;"><p>Our sponsor - Deploy your server within <strong>3 minutes</strong></p> <a href=http://www.linuxandubuntu.com/recommends/massivegrid target=_blank><picture> <source type=image/webp srcset=http://www.linuxandubuntu.com/wp-content/uploads/2019/10/MassiveGRID-Banner.jpg.webp> <img src=http://www.linuxandubuntu.com/wp-content/uploads/2019/10/MassiveGRID-Banner.jpg> </picture> </img></a></div> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-1925104690687996 data-ad-slot=3191286661></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script><hr><div class="penci-post-author penci_media_object"><div class="author-img penci_mobj__img"> <img alt src="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=100&#038;d=mm&#038;r=g" class="avatar avatar-100 photo jetpack-lazy-image" height=100 width=100 data-lazy-srcset="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=200&#038;d=mm&#038;r=g 2x" data-lazy-src="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=100&amp;is-pending-load=1#038;d=mm&#038;r=g"><img alt src='http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=100&#038;d=mm&#038;r=g' class='avatar avatar-100 photo' height=100 width=100></div><div class="penci-author-content penci_mobj__body"><h5><a href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye title="Posts by Sohail" rel=author>Sohail</a></h5><div class=author-description> Mohd Sohail is a web developer and a Linux sysAdmin. He also loves to write how-to articles, applications reviews and loves to use new Linux distributions.</div><div class=author-socials></div></div></div><div id=wordpress-22074-comment class="active multi-wordpress-comment penci-tab-pane" ><div class="post-comments  post-comments-22074  no-comment-yet" id=comments><div id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel=nofollow id=cancel-comment-reply-link href=/home/buying-web-hosting#respond style=display:none;>Cancel Reply</a></small></h3><form action=http://www.linuxandubuntu.com/wp-comments-post.php method=post id=commentform class=comment-form novalidate><p class=comment-form-comment><textarea id=comment name=comment cols=45 rows=8 placeholder="Your Comment" aria-required=true></textarea></p><p class=comment-form-author><input id=author name=author type=text value placeholder=Name* size=30 aria-required=true></p><p class=comment-form-email><input id=email name=email type=text value placeholder=Email* size=30 aria-required=true></p><p class=comment-form-url><input id=url name=url type=text value placeholder=Website size=30></p><p class=comment-form-cookies-consent><input id=wp-comment-cookies-consent name=wp-comment-cookies-consent type=checkbox value=yes> <label for=wp-comment-cookies-consent>Save my name, email, and website in this browser for the next time I comment.</label></p><p class=form-submit><input name=submit type=submit id=submit class=submit value=Submit> <input type=hidden name=comment_post_ID value=22074 id=comment_post_ID> <input type=hidden name=comment_parent id=comment_parent value=0></p><p style="display: none;"><input type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=8e55965e50></p><p style="display: none;"><input type=hidden id=ak_js name=ak_js value=172></p></form></div></div></div></div><div id=penci-infinite-handle data-offset=0 data-postidCurrent=22074 data-postidLoaded=22074 class=penci-single-loadmore> <span class=penci-three-bounce> <span class=one></span> <span class=two></span> <span class=three></span> </span></div></div></div><aside class="widget-area widget-area-1 penci-sticky-sidebar penci-sidebar-widgets"><div class=theiaStickySidebar><div id=penci_custom_html-2 class="widget_text widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_custom_html"><div class="textwidget custom-html-widget"><script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:inline-block;width:336px;height:280px data-ad-client=ca-pub-1925104690687996 data-ad-slot=5196807437></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><style>#penci_custom_html-2.widget{padding:0
!important;background-color:transparent !important}#penci_custom_html-2.style-title-8:not(.footer-widget) .penci-block__title:before,#penci_custom_html-2.style-title-1:not(.footer-widget) .penci-block__title:before{right:0;left:0}</style><div id=search-4 class="widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_search"><form method=get class=search-form action=http://www.linuxandubuntu.com/ > <label> <span class=screen-reader-text>Search for:</span> <input type=search class=search-field placeholder="Enter keyword..." value name=s> </label> <button type=submit class=search-submit> <i class="fa fa-search"></i> <span class=screen-reader-text>Search</span> </button></form></div><div id=penci_custom_html-3 class="widget_text widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_custom_html"><div class="textwidget custom-html-widget"><script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:inline-block;width:336px;height:280px data-ad-client=ca-pub-1925104690687996 data-ad-slot=8811004412></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><style>#penci_custom_html-3.widget{padding:0
!important;background-color:transparent !important}#penci_custom_html-3.style-title-8:not(.footer-widget) .penci-block__title:before,#penci_custom_html-3.style-title-1:not(.footer-widget) .penci-block__title:before{right:0;left:0}</style><div id=recent-posts-4 class="widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_recent_entries"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>Recent Posts</span></h4></div><ul><li> <a href=http://www.linuxandubuntu.com/home/buying-web-hosting aria-current=page>Things To Remember Before Buying Web Hosting</a></li><li> <a href=http://www.linuxandubuntu.com/home/set-up-canonical-livepatch-on-ubuntu>How To Set Up Canonical Livepatch On Ubuntu 20.04 &#8220;Focal Fossa&#8221;</a></li><li> <a href=http://www.linuxandubuntu.com/home/how-to-upgrade-to-ubuntu-20-04-focal-fossa>How To Upgrade To Ubuntu 20.04 &#8220;Focal Fossa&#8221;</a></li><li> <a href=http://www.linuxandubuntu.com/home/ubuntu-20-04-focal-fossa-beta-released>Ubuntu 20.04 &#8220;Focal Fossa&#8221; Beta Released</a></li><li> <a href=http://www.linuxandubuntu.com/home/contact-form-7-datepicker-vulnerability>Contact Form 7 Datepicker Taken down from WordPress Plugin Repository</a></li><li> <a href=http://www.linuxandubuntu.com/home/shared-hosting-vs-dedicated-hosting>Shared hosting Vs. Dedicated hosting</a></li><li> <a href=http://www.linuxandubuntu.com/home/linux-mint-20-codenamed-ulyana>Linux Mint 20 Codenamed Ulyana &#038; More</a></li><li> <a href=http://www.linuxandubuntu.com/home/obarun-arch-based-linux-distro-without-systemd>Obarun &#8211; An Arch Based Linux Distro Without Systemd</a></li></ul></div><div id=penci_custom_html-4 class="widget_text widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_custom_html"><div class="textwidget custom-html-widget"><script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:inline-block;width:300px;height:600px data-ad-client=ca-pub-1925104690687996 data-ad-slot=8856775759></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><style>#penci_custom_html-4.widget{padding:0
!important;background-color:transparent !important}#penci_custom_html-4.style-title-8:not(.footer-widget) .penci-block__title:before,#penci_custom_html-4.style-title-1:not(.footer-widget) .penci-block__title:before{right:0;left:0}</style><div id=penci_block_7__6190978 class="penci-block-vc penci-block_7 penci__general-meta widget penci-block-vc penci-widget-sidebar style-title-1 style-title-left penci-block-vc penci-widget penci-block_7 penci-widget__block_7 left penci-imgtype-landscape penci-link-filter-hidden penci-vc-column-1" data-current=1 data-blockUid=penci_block_7__6190978 ><div class=penci-block-heading><h3 class="penci-block__title"><a href=http://www.linuxandubuntu.com/home/category/hacking-with-kali-linux title="Ongoing series">Ongoing series</a ></h3></div><div id=penci_block_7__6190978block_content class=penci-block_content><div class="penci-block_content__items penci-block-items__1"><article class="hentry penci-post-item"><div class=penci-post-item__inner><div class=penci_post_thumb><a class="penci-image-holder  penci-lazy penci-image_has_icon"  data-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/04/install-kali-linux-on-virtualbox.jpg?resize=480%2C316" data-delay href=http://www.linuxandubuntu.com/home/install-kali-linux title="Install Kali Linux &#8211; The Quickest Way"></a></div><div class=penci_post_content><h3 class="penci__post-title entry-title"><a href=http://www.linuxandubuntu.com/home/install-kali-linux title=" Install Kali Linux &#8211; The Quickest Way ">Install Kali Linux &#8211; The Quickest Way</a></h3><div class=penci-schema-markup><span class="author vcard"><a class="url fn n" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span><time class="entry-date published" datetime=2019-04-29T00:00:00+05:30>April 29, 2019</time><time class=updated datetime=2019-12-13T03:29:34+05:30>December 13, 2019</time></div><div class=penci_post-meta><span class="entry-meta-item penci-byline">by <span class="author vcard"><a class="url fn n penci_pmeta-link" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span></span><span class="entry-meta-item penci-posted-on"><i class="fa fa-clock-o"></i><time class="entry-date published" datetime=2019-12-13T03:29:34+05:30>December 13, 2019</time><time class=updated datetime=2019-12-13T03:29:34+05:30>December 13, 2019</time></span><span class="entry-meta-item penci-comment-count"><a class=penci_pmeta-link href=http://www.linuxandubuntu.com/home/install-kali-linux#respond><i class="la la-comments"></i>0</a></span></div></div></div></article><article class="hentry penci-post-item"><div class=penci-post-item__inner><div class=penci_post_thumb><a class="penci-image-holder  penci-lazy penci-image_has_icon"  data-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/04/hacking-with-kali-linux.jpg?resize=480%2C320" data-delay href=http://www.linuxandubuntu.com/home/hacking-with-kali-linux title="Hacking With Kali Linux"></a></div><div class=penci_post_content><h3 class="penci__post-title entry-title"><a href=http://www.linuxandubuntu.com/home/hacking-with-kali-linux title=" Hacking With Kali Linux ">Hacking With Kali Linux</a></h3><div class=penci-schema-markup><span class="author vcard"><a class="url fn n" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span><time class="entry-date published" datetime=2019-04-23T00:00:00+05:30>April 23, 2019</time><time class=updated datetime=2019-12-13T03:27:27+05:30>December 13, 2019</time></div><div class=penci_post-meta><span class="entry-meta-item penci-byline">by <span class="author vcard"><a class="url fn n penci_pmeta-link" href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye>Sohail</a></span></span><span class="entry-meta-item penci-posted-on"><i class="fa fa-clock-o"></i><time class="entry-date published" datetime=2019-12-13T03:27:27+05:30>December 13, 2019</time><time class=updated datetime=2019-12-13T03:27:27+05:30>December 13, 2019</time></span><span class="entry-meta-item penci-comment-count"><a class=penci_pmeta-link href=http://www.linuxandubuntu.com/home/hacking-with-kali-linux#comments><i class="la la-comments"></i>9 </a></span></div></div></div></article></div><div class="penci-loader-effect penci-loading-animation-9"><div class=penci-loading-circle><div class="penci-loading-circle1 penci-loading-circle-inner"></div><div class="penci-loading-circle2 penci-loading-circle-inner"></div><div class="penci-loading-circle3 penci-loading-circle-inner"></div><div class="penci-loading-circle4 penci-loading-circle-inner"></div><div class="penci-loading-circle5 penci-loading-circle-inner"></div><div class="penci-loading-circle6 penci-loading-circle-inner"></div><div class="penci-loading-circle7 penci-loading-circle-inner"></div><div class="penci-loading-circle8 penci-loading-circle-inner"></div><div class="penci-loading-circle9 penci-loading-circle-inner"></div><div class="penci-loading-circle10 penci-loading-circle-inner"></div><div class="penci-loading-circle11 penci-loading-circle-inner"></div><div class="penci-loading-circle12 penci-loading-circle-inner"></div></div></div></div></div><style>@media screen and (min-width: 768px ){}#penci_block_7__6190978 .penci-pmore-link .more-link{font-family:"Mukta Vaani";font-weight:500}#penci_block_7__6190978 .penci-subcat-filter .penci-subcat-item a,#penci_block_7__6190978 .penci-subcat-list .flexMenu-viewMore>a{font-family:"Roboto";font-weight:400}</style><script>if(typeof(penciBlock)==="undefined"){function penciBlock(){this.atts_json='';this.content='';}}var penciBlocksArray=penciBlocksArray||[];var PENCILOCALCACHE=PENCILOCALCACHE||{};var penci_block_7__6190978=new penciBlock();penci_block_7__6190978.blockID="penci_block_7__6190978";penci_block_7__6190978.atts_json='{"build_query":"post_type:post|size:5|categories:649","add_title_icon":"","title_i_align":"left","title_icon":"","image_type":"landscape","image_ratio":"","image_size":"penci-thumb-480-320","block_title_meta_settings":"","block_title_align":"left","block_title_off_uppercase":"","block_title_wborder_left_right":"5px","block_title_wborder":"3px","post_title_trimword_settings":"","post_standard_title_length":"12","hide_comment":"","hide_post_date":"","hide_icon_post_format":"","hide_author":"","hide_review_piechart":"","show_readmore":"","show_count_view":"","dis_bg_block":"","enable_stiky_post":"","show_order_number":"","style_pag":"","limit_loadmore":"3","readmore_css":"","pagination_css":"","loadmore_css":"","disable_bg_load_more":"","custom_markup_1":"","ajax_filter_type":"","ajax_filter_selected":"","ajax_filter_childselected":"","ajax_filter_number_item":"5","infeed_ads__order":"","block_id":"penci-widget__block_7-2","penci_show_desk":"Yes","penci_show_tablet":"Yes","penci_show_mobile":"Yes","paged":1,"unique_id":"penci_block_7__6190978","shortcode_id":"block_7","category_ids":"","taxonomy":""}';penci_block_7__6190978.content="";penciBlocksArray.push(penci_block_7__6190978);</script> </div></aside></div></div></main></div></div><footer id=colophon class=site-footer itemscope itemtype=http://schema.org/WPFooter><meta itemprop=name content="Webpage footer for LinuxAndUbuntu"><meta itemprop=description content><meta itemprop=keywords content="Data Protection, Copyright Data"><meta itemprop=copyrightYear content=2020><meta itemprop=copyrightHolder content=LinuxAndUbuntu><div id=footer__sidebars class="footer__sidebars footer__sidebar-col-3 footer__sidebars-style-3"><div class="footer__sidebars-inner penci-container-fluid"><div class=row><div id=footer-1 class="footer-sidebar-item footer-1 penci-col-4"><div id=text-3 class="widget footer-widget penci-block-vc penci-fwidget-sidebar style-title-3 style-title-left widget_text"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>About LinuxAndUbuntu</span></h4></div><div class=textwidget><div class=paragraph>​​LinuxAndUbuntu.com  focuses on open source projects but  specific on debian based distributions. We also give value to other linux distributions.</div></div></div></div><div id=footer-2 class="footer-sidebar-item footer-2 penci-col-4"><div id=text-9 class="widget footer-widget penci-block-vc penci-fwidget-sidebar style-title-3 style-title-left widget_text"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>Links</span></h4></div><div class=textwidget><div class=paragraph><a title href=http://www.ubuntu.com/ target=_blank rel="noopener noreferrer">Ubuntu.com</a></div><div><a href=https://linuxmint.com/ target=_blank rel="noopener noreferrer">Linux Mint</a></div><div><a title href=http://www.linuxandubuntu.com/home/category/linux-tutorials target=_blank rel="noopener noreferrer">Tutorials &amp; HowTos</a></div></div></div></div><div id=footer-3 class="footer-sidebar-item footer-3 penci-col-4"><div id=text-10 class="widget footer-widget penci-block-vc penci-fwidget-sidebar style-title-3 style-title-left widget_text"><div class=penci-block-heading><h4 class="widget-title penci-block__title"><span>More From LinuxAndUbuntu</span></h4></div><div class=textwidget><div class=paragraph><a href=http://www.linuxandubuntu.com/advertise/ target=_blank rel="noopener noreferrer">Advertise</a></div><div><a href=http://www.linuxandubuntu.com/become-a-regular-writer/ target=_blank rel="noopener noreferrer">Become a LinuxAndUbuntu writer</a></div><div><a href=http://www.linuxandubuntu.com/privacy-policy/ target=_blank rel="noopener noreferrer">Privacy Policy</a></div></div></div></div></div></div></div><div class="footer__bottom style-1"><div class="footer__bottom_container footer__sidebars-inner penci-container-fluid"><div class=footer__logo> <a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></div><div class=footer__social-media> <a class="social-media-item socail_media__facebook" target=_blank href=https://www.facebook.com/linuxandubuntuofficial title=Facebook rel=noopener><span class=socail-media-item__content><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target=_blank href=https://twitter.com/linuxandubuntu title=Twitter rel=noopener><span class=socail-media-item__content><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a><a class="social-media-item socail_media__pinterest" target=_blank href=http://www.pinterest.com/linuxandubuntu title=Pinterest rel=noopener><span class=socail-media-item__content><i class="fa fa-pinterest"></i><span class="social_title screen-reader-text">Pinterest</span></span></a><a class="social-media-item socail_media__linkedin" target=_blank href=https://www.linkedin.com/in/mohdsohail title=Linkedin rel=noopener><span class=socail-media-item__content><i class="fa fa-linkedin"></i><span class="social_title screen-reader-text">Linkedin</span></span></a><a class="social-media-item socail_media__youtube" target=_blank href=https://youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg title=Youtube rel=noopener><span class=socail-media-item__content><i class="fa fa-youtube-play"></i><span class="social_title screen-reader-text">Youtube</span></span></a><a class="social-media-item socail_media__rss" target=_blank href=http://www.linuxandubuntu.com/feed/rss title=Rss rel=noopener><span class=socail-media-item__content><i class="fa fa-rss"></i><span class="social_title screen-reader-text">Rss</span></span></a></div></div></div><div class=footer__copyright_menu><div class="footer__sidebars-inner penci-container-fluid penci_bottom-sub penci_has_copyright"><div class=site-info> @2019 - www.linuxandubuntu.com. All Right Reserved. Powered by <a href="https://portal.massivegrid.com/link.php?id=2" target=_blank>MassiveGRID</a> on <a href=http://wordpress.org target=_blank>WordPress</a></div></div></div></footer></div><aside class="mobile-sidebar "><div id=sidebar-nav-logo> <a href=http://www.linuxandubuntu.com/ rel=home>LinuxAndUbuntu</a></div><div class="header-social sidebar-nav-social"><div class=inner-header-social> <a class="social-media-item socail_media__facebook" target=_blank href=https://www.facebook.com/linuxandubuntuofficial title=Facebook rel=noopener><span class=socail-media-item__content><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target=_blank href=https://twitter.com/linuxandubuntu title=Twitter rel=noopener><span class=socail-media-item__content><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a><a class="social-media-item socail_media__pinterest" target=_blank href=http://www.pinterest.com/linuxandubuntu title=Pinterest rel=noopener><span class=socail-media-item__content><i class="fa fa-pinterest"></i><span class="social_title screen-reader-text">Pinterest</span></span></a><a class="social-media-item socail_media__linkedin" target=_blank href=https://www.linkedin.com/in/mohdsohail title=Linkedin rel=noopener><span class=socail-media-item__content><i class="fa fa-linkedin"></i><span class="social_title screen-reader-text">Linkedin</span></span></a><a class="social-media-item socail_media__youtube" target=_blank href=https://youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg title=Youtube rel=noopener><span class=socail-media-item__content><i class="fa fa-youtube-play"></i><span class="social_title screen-reader-text">Youtube</span></span></a><a class="social-media-item socail_media__rss" target=_blank href=http://www.linuxandubuntu.com/feed/rss title=Rss rel=noopener><span class=socail-media-item__content><i class="fa fa-rss"></i><span class="social_title screen-reader-text">Rss</span></span></a></div></div><nav class=mobile-navigation itemscope itemtype=http://schema.org/SiteNavigationElement><ul id=primary-menu-mobile class=primary-menu-mobile><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9637"><a href=http://www.linuxandubuntu.com>Home</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16021"><a href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21700"><a href=http://www.linuxandubuntu.com/home/category/linux/themes>Linux Themes</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17077"><a href=http://www.linuxandubuntu.com/home/category/linux-tutorials>Linux Tutorials</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-8337"><a href=http://www.linuxandubuntu.com/faqs>Linux FAQs</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9733"><a href=http://www.linuxandubuntu.com/advertise>Advertise</a></li><li class="menu-have-icon menu-icon-type-fontawesome menu-item menu-item-type-post_type menu-item-object-page menu-item-9636"><a href=http://www.linuxandubuntu.com/contact-us>Contact us</a></li></ul></nav></aside> <a id=close-sidebar-nav class=header-1><i class="fa fa-close"></i></a> <a href=# id=scroll-to-top><i class="fa fa-angle-up"></i></a><div class="penci-wrap-gprd-law penci-wrap-gprd-law-close"><div class=penci-gprd-law><p> This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish.	<a class=penci-gprd-accept href=#>Accept</a>		<a class=penci-gprd-more href=http://www.linuxandubuntu.com/privacy-policy>Read More</a></p></div></div><div id=uFCRJPGCbOoC class=JYmXhhXimcmy style="background:#dddddd;z-index:9999999; "></div> <script>/*<![CDATA[*/var anOptions={"anOptionChoice":"2","anOptionStats":"1","anOptionAdsSelectors":"","anOptionCookie":"1","anOptionCookieLife":"30","anPageRedirect":"","anPermalink":"undefined","anOptionModalEffect":"fadeAndPop","anOptionModalspeed":"350","anOptionModalclose":true,"anOptionModalOverlay":"rgba( 0,0,0,0.8 )","anAlternativeActivation":false,"anAlternativeElement":"","anAlternativeText":"<p><strong>AdBlock detected!<\/strong><\/p>\n<p>Please add <a href=\"http:\/\/www.linuxandubuntu.com\">www.linuxandubuntu.com<\/a>\u00a0to your adblocking whitelist or disable your adblocking software.<\/p>\n","anAlternativeClone":"2","anAlternativeProperties":"","anOptionModalShowAfter":0,"anPageMD5":"","anSiteID":0,"modalHTML":"<div class=\"JYmXhhXimcmy-default\">\n\t<h1 style=\"\">Adblocker detected! Please consider reading this notice.<\/h1>\n\t<p>We've detected that you are using AdBlock Plus or some other adblocking software which is preventing the page from fully loading.<\/p>\n<p>We don't have any banner, Flash, animation, obnoxious sound, or popup ad. We do not implement these annoying types of ads!<\/p>\n<p>We need money to operate the site, and almost all of it comes from our online advertising.<\/p>\n<p><strong>Please add <a title=\"LinuxAndUbuntu\" href=\"http:\/\/www.linuxandubuntu.com\" target=\"_blank\" rel=\"noopener\">www.linuxandubuntu.com<\/a> to your ad blocking whitelist or disable your adblocking software.<\/strong><\/p>\n<p>If you do not want to disable your adblocker, just close this popup and keep browsing the site.<\/p>\n<p>Thanks for visiting!<\/p>\n<\/div>\n<a class=\"close-modal close-JYmXhhXimcmy\">&#215;<\/a>"}/*]]>*/</script><div id=adsense class=an-sponsored style="position:absolute; z-index:-1; height:1px; width:1px; visibility: hidden; top: -1px; left: 0;"><img class=an-advert-banner alt=sponsored src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7></div> <script>var snp_f=[];var snp_hostname=new RegExp(location.host);var snp_http=new RegExp("^(http|https)://","i");var snp_cookie_prefix='';var snp_separate_cookies=false;var snp_ajax_url='http://www.linuxandubuntu.com/wp-admin/admin-ajax.php';var snp_domain_url='http://www.linuxandubuntu.com';var snp_ajax_nonce='38431b3b2a';var snp_ajax_ping_time=1000;var snp_ignore_cookies=false;var snp_enable_analytics_events=false;var snp_is_mobile=false;var snp_enable_mobile=false;var snp_use_in_all=false;var snp_excluded_urls=[];snp_excluded_urls.push('');</script> <div class=snp-root> <input type=hidden id=snp_popup value> <input type=hidden id=snp_popup_id value> <input type=hidden id=snp_popup_theme value> <input type=hidden id=snp_exithref value> <input type=hidden id=snp_exittarget value><div id=snppopup-welcome class="snp-pop-22072 snppopup"><input type=hidden class=snp_open value=load><input type=hidden class=snp_close value=manual><input type=hidden class=snp_show_on_exit value=2><input type=hidden class=snp_exit_js_alert_text value><input type=hidden class=snp_exit_scroll_down value=10><input type=hidden class=snp_exit_scroll_up value=10><input type=hidden class=snp_open_scroll value=10><input type=hidden class=snp_optin_redirect_url value="https://click.linksynergy.com/deeplink?id=6VhySHJY1WI&mid=39197&murl=https%3A%2F%2Fwww.udemy.com%2Fcourse%2Flinux-administration-bootcamp%2F"><input type=hidden class=snp_optin_form_submit value=single><input type=hidden class=snp_show_cb_button value=yes><input type=hidden class=snp_popup_id value=22072><input type=hidden class=snp_popup_theme value=theme_image><input type=hidden class=snp_overlay value=disabled><input type=hidden class=snp_cookie_conversion value=30><input type=hidden class=snp_cookie_close value=-1><div class="snp-fb snp-theme-image"><div class=snp-content><div class=snp-content-inner> <picture> <source type=image/webp srcset=http://www.linuxandubuntu.com/wp-content/uploads/2020/04/Copy-of-Copy-of-Subscribe-To-Get.png.webp> <img src=http://www.linuxandubuntu.com/wp-content/uploads/2020/04/Copy-of-Copy-of-Subscribe-To-Get.png alt> </picture><div class=snp-subscribe><form action=# method=post class=" snp-subscribeform snp_subscribeform"> <input type=hidden name=np_custom_name1 value> <input type=hidden name=np_custom_name2 value><fieldset> <input type=text name=email id=email placeholder="enter your e-mail..." class="snp-field snp-field-email"> <button type=submit class=snp-subscribe-button>Subscribe Now!</button></fieldset></form></div></div></div></div><style>.snp-pop-22072 .snp-theme-image{width:450px}.snp-pop-22072 .snp-theme-image{min-height:300px}.snp-pop-22072 .snp-theme-image{background:;background-image:-moz-radial-gradient(50% 50%, circle contain, ,  500%);background-image:-webkit-radial-gradient(50% 50%, circle contain, ,  500%);background-image:-o-radial-gradient(50% 50%, circle contain, ,  500%);background-image:-ms-radial-gradient(50% 50%, circle contain, ,  500%);background-image:radial-gradient(50% 50%, circle contain, ,  500%)}.snp-pop-22072 .snp-theme-image .snp-powered{}.snp-pop-22072 .snp-theme-image .snp-subscribe-button{background:#24ab97;background-image:-webkit-linear-gradient(top, #24ab97 0, #14e0d2 100%);background-image:-moz-linear-gradient(top, #24ab97 0, #14e0d2 100%);background-image:-ms-linear-gradient(top, #24ab97 0, #14e0d2 100%);background-image:-o-linear-gradient(top, #24ab97 0, #14e0d2 100%);background-image:linear-gradient(top, #24ab97 0, #14e0d2 100%);color:#fff}</style></div></div> <script src=https://c0.wp.com/c/5.4/wp-includes/js/jquery/ui/core.min.js></script> <script src=https://c0.wp.com/c/5.4/wp-includes/js/jquery/ui/datepicker.min.js></script> <script>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/c33ba.js></script> <script src=https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js></script> <script>var wpcf7={"apiSettings":{"root":"http:\/\/www.linuxandubuntu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/0fef6.js></script> <script>var thirsty_global_vars={"home_url":"\/\/www.linuxandubuntu.com","ajax_url":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"recommends","link_prefixes":{"1":"recommends"},"post_id":"22074","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/86e9b.js></script> <script>/*<![CDATA[*/var PENCILOCALIZE={"ajaxUrl":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","nonce":"354f3de9ab","errorMsg":"Something wrong happened. Please try again.","login":"Email Address","password":"Password","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","prevNumber":"1","minlengthSearch":"0","linkTitle":"View More","linkTextAll":"Menu","linkText":"More"};/*]]>*/</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/168b5.js></script> <script src=https://c0.wp.com/c/5.4/wp-includes/js/comment-reply.min.js></script> <script src=https://c0.wp.com/p/jetpack/8.3/_inc/build/lazy-images/js/lazy-images.min.js></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/3bdc5.js></script> <script>var ajax_object={"nonce":"64be9715fc","ajaxurl":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php"};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/071d0.js></script> <script src=https://c0.wp.com/c/5.4/wp-includes/js/wp-embed.min.js></script> <script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.4' async=async></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/26eb3.js></script> <script src=https://c0.wp.com/c/5.4/wp-includes/js/imagesloaded.min.js></script> <script src=https://c0.wp.com/c/5.4/wp-includes/js/masonry.min.js></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/fd31b.js></script> <script>/*<![CDATA[*/EnlighterJS_Config={"selector":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"language":"generic","theme":"godzilla","indent":2,"hover":"hoverEnabled","showLinenumbers":true,"rawButton":true,"infoButton":true,"windowButton":true,"rawcodeDoubleclick":false,"grouping":true,"cryptex":{"enabled":false,"email":"mail@example.tld"}};!function(){var a=function(a){var b="Enlighter Error: ";console.error?console.error(b+a):console.log&&console.log(b+a)};return window.addEvent?"undefined"==typeof EnlighterJS?void a("Javascript Resources not loaded yet!"):"undefined"==typeof EnlighterJS_Config?void a("Configuration not loaded yet!"):void window.addEvent("domready",function(){EnlighterJS.Util.Init(EnlighterJS_Config.selector.block,EnlighterJS_Config.selector.inline,EnlighterJS_Config)}):void a("MooTools Framework not loaded yet!")}();;/*]]>*/</script><script src=https://stats.wp.com/e-202015.js async=async defer=defer></script> <script>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:8.3',blog:'164016613',post:'22074',tz:'5.5',srv:'www.linuxandubuntu.com'}]);_stq.push(['clickTrackerInit','164016613','22074']);</script>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-42740043-3"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-42740043-3');</script>  <script>var sc_project=10160336;var sc_invisible=1;var sc_security="10341dd9";</script> <script
src=https://www.statcounter.com/counter/counter.js
async></script> <noscript><div class=statcounter><a title="Web Analytics" href=https://statcounter.com/ target=_blank><img class=statcounter src=https://c.statcounter.com/10160336/0/10341dd9/1/ alt="Web Analytics"></a></div></noscript></body></html>