<!DOCTYPE html> <!--[if IE 8]><html class="ie ie8" lang=en-US prefix="og: http://ogp.me/ns#"> <![endif]--> <!--[if IE 9]><html class="ie ie9" lang=en-US prefix="og: http://ogp.me/ns#"> <![endif]--> <!--[if gt IE 9]><!--><html lang=en-US prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head><meta charset=UTF-8><meta http-equiv=X-UA-Compatible content="IE=edge"><meta name=viewport content="width=device-width, initial-scale=1.0"><link rel=pingback href=http://www.linuxandubuntu.com/xmlrpc.php><title>Install Nextcloud - Free &amp; Open Source Cloud Storage Solution - LinuxAndUbuntu</title><link rel=canonical href=http://www.linuxandubuntu.com/home/install-nextcloud-free-open-source-cloud-solution><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Install Nextcloud - Free &amp; Open Source Cloud Storage Solution - LinuxAndUbuntu"><meta property=og:description content="Nextcloud is a free and open-source cloud storage platform one can easily setup. It is the best free &amp; open-source alternative to Google Drive or Dropbox."><meta property=og:url content=http://www.linuxandubuntu.com/home/install-nextcloud-free-open-source-cloud-solution><meta property=og:site_name content=LinuxAndUbuntu><meta property=article:publisher content=https://facebook.com/linuxandubuntuofficial><meta property=article:section content=Nextcloud><meta property=article:published_time content=2019-09-15T22:08:54+00:00><meta property=article:modified_time content=2019-09-15T22:23:36+00:00><meta property=og:updated_time content=2019-09-15T22:23:36+00:00><meta property=og:image content="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/install-nextcloud-cloud-storage-solution.png?fit=809%2C400"><meta property=og:image:secure_url content="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/install-nextcloud-cloud-storage-solution.png?fit=809%2C400"><meta property=og:image:width content=809><meta property=og:image:height content=400><meta property=og:image:alt content="install nextcloud cloud storage solution"><meta name=twitter:card content=summary_large_image><meta name=twitter:description content="Nextcloud is a free and open-source cloud storage platform one can easily setup. It is the best free &amp; open-source alternative to Google Drive or Dropbox."><meta name=twitter:title content="Install Nextcloud - Free &amp; Open Source Cloud Storage Solution - LinuxAndUbuntu"><meta name=twitter:site content=@linuxandubuntu><meta name=twitter:image content="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/install-nextcloud-cloud-storage-solution.png?fit=809%2C400"><meta name=twitter:creator content=@linuxandubuntu> <script type=application/ld+json>{"@context":"https:\/\/schema.org","@type":"Person","url":"http:\/\/www.linuxandubuntu.com\/","sameAs":["https:\/\/facebook.com\/linuxandubuntuofficial","https:\/\/www.youtube.com\/channel\/UCq1rZSfOlhl1poyvRx-sYrg?view_as=subscriber","https:\/\/pinterest.com\/linuxandubuntu","https:\/\/twitter.com\/linuxandubuntu"],"@id":"#person","name":"Mohd Sohail"}</script> <link rel=dns-prefetch href=//s0.wp.com><link rel=dns-prefetch href=//fonts.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="LinuxAndUbuntu &raquo; Feed" href=http://www.linuxandubuntu.com/feed><link rel=alternate type=application/rss+xml title="LinuxAndUbuntu &raquo; Comments Feed" href=http://www.linuxandubuntu.com/comments/feed><link rel=alternate type=application/rss+xml title="LinuxAndUbuntu &raquo; Install Nextcloud &#8211; Free &#038; Open Source Cloud Storage Solution Comments Feed" href=http://www.linuxandubuntu.com/home/install-nextcloud-free-open-source-cloud-solution/feed> <script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.linuxandubuntu.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style>img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel=stylesheet id=wp-block-library-css  href=https://c0.wp.com/c/5.2.3/wp-includes/css/dist/block-library/style.min.css type=text/css media=all><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/597e0.css media=all><style id=wp-polls-inline-css>.wp-polls
.pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url('http://www.linuxandubuntu.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');border:1px
solid #c8c8c8}</style><!--[if lt IE 9]><link rel=stylesheet id=vc_lte_ie9-css  href='http://www.linuxandubuntu.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.2' type=text/css media=screen> <![endif]--><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/3cb18.css media=all><link crossorigin=anonymous rel=stylesheet id=better-framework-main-fonts-css  href='https://fonts.googleapis.com/css?family=Nunito:400%7COpen+Sans:400%7CMegrim:400%7CRoboto:500,400,400italic' type=text/css media=all><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/2e589.css media=all><style id=an_style-inline-css>.WfgKEImJDjab-bg{display:none;position:fixed;z-index:100;top:0;left:0;width:100%;height:100%;background:#000;background:rgba(0,0,0,.75)}.WfgKEImJDjab{visibility:hidden;position:fixed;z-index:101;top:100px;right:0;left:0;max-width:640px;margin-right:auto;margin-left:auto;background:#fff;-webkit-box-shadow:0 3px 5px 2px rgba(0,0,0,.25);box-shadow:0 3px 5px 2px rgba(0,0,0,.25);font-family:Arial,Helvetica,sans-serif}.WfgKEImJDjab-default,.WfgKEImJDjab-ok{padding:30px
30px 15px}.WfgKEImJDjab-image{overflow:hidden;position:relative;width:100%}.WfgKEImJDjab-image .WfgKEImJDjab-left{position:absolute;top:0;left:0;width:50%;height:100%}.WfgKEImJDjab-image .WfgKEImJDjab-right{float:right;width:50%;padding:30px}.WfgKEImJDjab.small{width:200px;margin-left:-140px}.WfgKEImJDjab.medium{width:400px;margin-left:-240px}.WfgKEImJDjab.large{width:600px;margin-left:-340px}.WfgKEImJDjab.xlarge{width:800px;margin-left:-440px}.close-WfgKEImJDjab{display:inline-block;position:absolute;top:15px;right:15px;width:30px;height:30px;color:#bbb;font-size:32px;font-weight:700;line-height:30px;text-align:center;cursor:pointer;-webkit-transition:.3s;transition:.3s}.close-WfgKEImJDjab:hover{color:#252b37}.WfgKEImJDjab
h1{margin-bottom:15px;padding:0
30px;color:#252b37;font-size:28px;line-height:1.25;text-align:center}.WfgKEImJDjab-right
h1{padding:0
30px 0 0;text-align:left}.WfgKEImJDjab
p{margin-bottom:15px;color:#333745;font-size:14px}.WfgKEImJDjab p
a{color:#ff6160}.WfgKEImJDjab-right .close-modal,.WfgKEImJDjab-footer .close-modal{padding:15px!important;border-radius:0!important;background-color:#ff6160;font-size:14px;letter-spacing:2px!important;-webkit-transition:.3s;transition:.3s}.WfgKEImJDjab-right .close-modal:hover,.WfgKEImJDjab-footer .close-modal:hover{background-color:#252b37!important}.WfgKEImJDjab-footer .grey-button-modal{margin-right:15px;background-color:#a5a5a5}.WfgKEImJDjab-footer{display:block;padding:15px
30px;background-color:#eff4f7;text-align:right}@media only screen and (max-width:640px){.WfgKEImJDjab{right:5%;left:5%;max-width:90%}.WfgKEImJDjab-default{padding:20px}.WfgKEImJDjab-image .WfgKEImJDjab-left{width:100%;height:250px}.WfgKEImJDjab-image .WfgKEImJDjab-right{float:left;width:100%;margin-top:250px;padding:20px}.WfgKEImJDjab
h1{margin-bottom:10px;font-size:20px}.WfgKEImJDjab-right
h1{padding:0}.WfgKEImJDjab
p{margin-bottom:10px}.close-WfgKEImJDjab{color:#fcfcfc;background-color:#252b37}.close-WfgKEImJDjab:hover{color:#252b37;background-color:#fcfcfc}.WfgKEImJDjab-footer{padding:15px
20px}}@media only screen and (max-width:480px){.WfgKEImJDjab-image .WfgKEImJDjab-left{height:200px}.WfgKEImJDjab-image .WfgKEImJDjab-right{margin-top:200px}.WfgKEImJDjab-footer{text-align:center}.WfgKEImJDjab-footer .close-modal{width:80%;margin:5px
10%}}</style><link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/b7466.css media=all><style id=__EPYT__style-inline-css>.epyt-gallery-thumb{width:33.333%}</style><link rel=stylesheet id=jetpack_css-css  href=https://c0.wp.com/p/jetpack/7.7.2/css/jetpack.css type=text/css media=all> <script>!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://steadfastsystem.com/v2/0/byg1NxaQB869wUh0ENt-wJttqsaNAU0F0ut_Zl1SpNnGDd5fcTmr1OFdstGphgRLnNY7O5wbR0aUU2aVEsGE0aHUxvaOydf-P6uBeYY80V7S_3deQfvYQ2tt183yjL5P13bv8XaCQ",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script><script src=https://c0.wp.com/c/5.2.3/wp-includes/js/jquery/jquery.js></script> <script async src=https://c0.wp.com/c/5.2.3/wp-includes/js/jquery/jquery-migrate.min.js></script> <script async src='http://www.linuxandubuntu.com/wp-content/plugins/insert-post-ads/js/gdpr.js?#038;ver=5.2.3'></script> <!--[if lt IE 9]> <script async src='http://www.linuxandubuntu.com/wp-content/plugins/better-adsmanager/includes/libs/better-framework/assets/js/html5shiv.min.js?#038;ver=3.10.16'></script> <![endif]--> <!--[if lt IE 9]> <script async src='http://www.linuxandubuntu.com/wp-content/plugins/better-adsmanager/includes/libs/better-framework/assets/js/respond.min.js?#038;ver=3.10.16'></script> <![endif]--> <script>var _EPYT_={"ajaxurl":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","security":"348f4f6f9c","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/www.linuxandubuntu.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"http:\/\/www.linuxandubuntu.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"13.1.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};</script> <script async src='http://www.linuxandubuntu.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?#038;ver=13.1.1'></script> <link rel=https://api.w.org/ href=http://www.linuxandubuntu.com/wp-json/><link rel=EditURI type=application/rsd+xml title=RSD href=http://www.linuxandubuntu.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=http://www.linuxandubuntu.com/wp-includes/wlwmanifest.xml><link rel=shortlink href='http://www.linuxandubuntu.com/?p=16382'><link rel=alternate type=application/json+oembed href="http://www.linuxandubuntu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution"><link rel=alternate type=text/xml+oembed href="http://www.linuxandubuntu.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution&#038;format=xml"><link rel=dns-prefetch href=//i0.wp.com><link rel=dns-prefetch href=//i1.wp.com><link rel=dns-prefetch href=//i2.wp.com><link rel=dns-prefetch href=//c0.wp.com><style>img#wpstats{display:none}</style><link rel=apple-touch-icon sizes=76x76 href=/apple-touch-icon.png><link rel=icon type=image/png sizes=32x32 href=/favicon-32x32.png><link rel=icon type=image/png sizes=16x16 href=/favicon-16x16.png><link rel=manifest href=/site.webmanifest><link rel=mask-icon href=/safari-pinned-tab.svg color=#5bbad5><meta name=msapplication-TileColor content=#00aba9><meta name=theme-color content=#ffffff> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-1925104690687996",enable_page_level_ads:true});</script> <meta name=google-site-verification content=j0ObInWlWjWTRmzl2eUOA7iH-5aSe1JbCeQ7xYwpw2I><meta name=yandex-verification content=420e098c00f2304f><meta name=p:domain_verify content=c5e409ee073e5f764568a980985f7b9a><meta name=generator content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."> <script src=https://cdn.onesignal.com/sdks/OneSignalSDK.js async></script> <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:'/'};OneSignal.setDefaultNotificationUrl("http://www.linuxandubuntu.com");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options['wordpress']=true;oneSignal_options['appId']='a1705b21-de0a-4fad-92c1-6bb270274512';oneSignal_options['autoRegister']=true;oneSignal_options['welcomeNotification']={};oneSignal_options['welcomeNotification']['title']="";oneSignal_options['welcomeNotification']['message']="";oneSignal_options['subdomainName']="linuxandubuntu";oneSignal_options['persistNotification']=false;oneSignal_options['promptOptions']={};oneSignal_options['promptOptions']['actionMessage']='Subscribe to our push notifications and never miss any latest article.';OneSignal.init(window._oneSignalInitOptions);});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault();};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,false);}
if(document.readyState==='complete'){documentInitOneSignal();}
else{window.addEventListener("load",function(event){documentInitOneSignal();});}</script> <style>html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image{display:none}</style> <script>document.documentElement.classList.add('jetpack-lazy-images-js-enabled');</script> <link rel=amphtml href=http://www.linuxandubuntu.com/home/install-nextcloud-free-open-source-cloud-solution/amp><script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"Organization","@id":"#organization","url":"http:\/\/www.linuxandubuntu.com\/","name":"LinuxAndUbuntu","description":""}</script> <script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"WebSite","name":"LinuxAndUbuntu","alternateName":"","url":"http:\/\/www.linuxandubuntu.com\/"}</script> <script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"BlogPosting","headline":"Install Nextcloud - Free & Open Source Cloud Storage Solution","description":"Nextcloud is a free and open-source cloud storage platform one can easily setup. It is the best free & open-source alternative to Google Drive or Dropbox.","datePublished":"2019-09-16","dateModified":"2019-09-16","author":{"@type":"Person","@id":"#person-Sohail","name":"Sohail"},"image":{"@type":"ImageObject","url":"https:\/\/i1.wp.com\/www.linuxandubuntu.com\/wp-content\/uploads\/2019\/09\/install-nextcloud-cloud-storage-solution.png?fit=809%2C400","width":809,"height":400},"interactionStatistic":[{"@type":"InteractionCounter","interactionType":"http:\/\/schema.org\/CommentAction","userInteractionCount":"0"}],"publisher":{"@id":"#organization"},"mainEntityOfPage":"http:\/\/www.linuxandubuntu.com\/home\/install-nextcloud-free-open-source-cloud-solution"}</script> <link rel=stylesheet href=http://www.linuxandubuntu.com/wp-content/cache/minify/938cd.css media=all><link rel=icon href="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=32%2C32" sizes=32x32><link rel=icon href="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=192%2C192" sizes=192x192><link rel=apple-touch-icon-precomposed href="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=180%2C180"><meta name=msapplication-TileImage content="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/06/cropped-linuxandubuntu-logo.png?fit=270%2C270"><style>.sidebar-ads{padding:0px!important;background:transparent!important;border:0px!important}</style> <noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body class="post-template-default single single-post postid-16382 single-format-standard bs-theme bs-publisher bs-publisher-clean-tech active-light-box active-top-line ltr close-rh page-layout-2-col-right full-width active-sticky-sidebar main-menu-sticky active-ajax-search single-prim-cat-3832 single-cat-3832  bs-hide-ha wpb-js-composer js-comp-ver-6.0.2 vc_responsive bs-ll-d" dir=ltr><div class="main-wrap content-main-wrap"><header id=header class="site-header header-style-2 full-width" itemscope=itemscope itemtype=http://schema.org/WPHeader><div class=header-inner><div class=content-wrap><div class=container><div class=row><div class=row-height><div class="logo-col col-xs-4"><div class=col-inside><div id=site-branding class=site-branding><p id=site-title class="logo h1 text-logo"> <a href=http://www.linuxandubuntu.com/ itemprop=url rel=home> LinuxAndUbuntu	</a></p></div></div></div><div class="sidebar-col col-xs-8"><div class=col-inside><aside id=sidebar class=sidebar role=complementary itemscope=itemscope itemtype=http://schema.org/WPSideBar><div class="pyhlt pyhlt-clearfix pyhlt-pubadban pyhlt-show-desktop pyhlt-show-tablet-portrait pyhlt-show-tablet-landscape pyhlt-show-phone pyhlt-loc-header_aside_logo pyhlt-align-right pyhlt-column-1"><div id=pyhlt-15997-165846747 class="pyhlt-container pyhlt-type-code " itemscope itemtype=https://schema.org/WPAdBlock data-adid=15997 data-type=code><div id=pyhlt-15997-165846747-place></div><script src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script><script>var betterads_screen_width=document.body.clientWidth;betterads_el=document.getElementById('pyhlt-15997-165846747');if(betterads_el.getBoundingClientRect().width){betterads_el_width_raw=betterads_el_width=betterads_el.getBoundingClientRect().width;}else{betterads_el_width_raw=betterads_el_width=betterads_el.offsetWidth;}var size=["125","125"];if(betterads_el_width>=728)betterads_el_width=["728","90"];else if(betterads_el_width>=468)betterads_el_width=["468","60"];else if(betterads_el_width>=336)betterads_el_width=["336","280"];else if(betterads_el_width>=300)betterads_el_width=["300","250"];else if(betterads_el_width>=250)betterads_el_width=["250","250"];else if(betterads_el_width>=200)betterads_el_width=["200","200"];else if(betterads_el_width>=180)betterads_el_width=["180","150"];if(betterads_screen_width>=1140){document.getElementById('pyhlt-15997-165846747-place').innerHTML='<ins class=adsbygoogle style=display:inline-block;width:728px;height:90px  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8182063423 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=1019&&betterads_screen_width<1140){document.getElementById('pyhlt-15997-165846747-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8182063423 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=768&&betterads_screen_width<1019){document.getElementById('pyhlt-15997-165846747-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8182063423 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width<768){document.getElementById('pyhlt-15997-165846747-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8182063423 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}</script></div></div></aside></div></div></div></div></div></div></div><div id=menu-main class="menu main-menu-wrapper show-search-item menu-actions-btn-width-1" role=navigation itemscope=itemscope itemtype=http://schema.org/SiteNavigationElement><div class=main-menu-inner><div class=content-wrap><div class=container><nav class=main-menu-container><ul id=main-navigation class="main-menu menu bsm-pure clearfix"><li id=menu-item-9637 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home better-anim-fade menu-item-9637"><a href=http://www.linuxandubuntu.com>Home</a></li><li id=menu-item-16021 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-term-162 better-anim-fade menu-item-has-children menu-item-has-mega menu-item-mega-tabbed-grid-posts menu-item-16021"><a href=http://www.linuxandubuntu.com/home/category/distros>Linux Distributions</a><div class="mega-menu tabbed-grid-posts"><div class="content-wrap clearfix"><ul class=tabs-section><li class=active> <a href=http://www.linuxandubuntu.com/home/category/distros data-target=#mtab-793792632-162 data-toggle=tab aria-expanded=true class=term-162> <i class="fa fa-angle-right"></i> All	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/centos data-target=#mtab-793792632-3507 data-deferred-init=340690239 data-toggle=tab data-deferred-event=mouseenter class=term-3507> <i class="fa fa-angle-right"></i> CentOS	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/fedora data-target=#mtab-793792632-2012 data-deferred-init=1379054757 data-toggle=tab data-deferred-event=mouseenter class=term-2012> <i class="fa fa-angle-right"></i> Fedora	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/ubuntu data-target=#mtab-793792632-1775 data-deferred-init=562150987 data-toggle=tab data-deferred-event=mouseenter class=term-1775> <i class="fa fa-angle-right"></i> Ubuntu	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/mx-linux data-target=#mtab-793792632-1214 data-deferred-init=1259222757 data-toggle=tab data-deferred-event=mouseenter class=term-1214> <i class="fa fa-angle-right"></i> MX Linux	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/zorin-os data-target=#mtab-793792632-3618 data-deferred-init=1039906933 data-toggle=tab data-deferred-event=mouseenter class=term-3618> <i class="fa fa-angle-right"></i> Zorin OS	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/deepin-os data-target=#mtab-793792632-3823 data-deferred-init=618688664 data-toggle=tab data-deferred-event=mouseenter class=term-3823> <i class="fa fa-angle-right"></i> Deepin OS	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/arch-linux data-target=#mtab-793792632-942 data-deferred-init=1704736666 data-toggle=tab data-deferred-event=mouseenter class=term-942> <i class="fa fa-angle-right"></i> Arch Linux	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/kali-linux data-target=#mtab-793792632-3489 data-deferred-init=1761998106 data-toggle=tab data-deferred-event=mouseenter class=term-3489> <i class="fa fa-angle-right"></i> Kali Linux	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/linux-mint data-target=#mtab-793792632-1213 data-deferred-init=1410048359 data-toggle=tab data-deferred-event=mouseenter class=term-1213> <i class="fa fa-angle-right"></i> Linux Mint	</a></li><li> <a href=http://www.linuxandubuntu.com/home/category/distros/ubuntu-budgie data-target=#mtab-793792632-982 data-deferred-init=1349684805 data-toggle=tab data-deferred-event=mouseenter class=term-982> <i class="fa fa-angle-right"></i> Ubuntu Budgie	</a></li></ul><div class=tab-content><div class="tab-pane bs-tab-anim bs-tab-animated active" id=mtab-793792632-162><div class="bs-pagination-wrapper main-term-162 next_prev "><div class="listing listing-grid listing-grid-1 clearfix columns-3"><div class="post-16755 type-post format-standard has-post-thumbnail  simple-grid  listing-item listing-item-grid listing-item-grid-1 main-term-3618"><div class=item-inner><div class="featured clearfix"><div class="term-badges floated"><span class="term-badge term-3618"><a href=http://www.linuxandubuntu.com/home/category/distros/zorin-os>Zorin OS</a></span></div>		<a alt="windows modern" title="Zorin OS 15 More Beautiful &#038; Useful Than Ever" style="background-image: url(https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/windows-modern.png?resize=357%2C210);" data-bsrjs=https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/windows-modern-750x430.png						class=img-holder href=http://www.linuxandubuntu.com/home/zorin-os-15></a></div><p class=title>		<a href=http://www.linuxandubuntu.com/home/zorin-os-15 class="post-title post-url"> Zorin OS 15 More Beautiful &#038; Useful Than Ever	</a></p></div></div ><div class="post-16716 type-post format-standard has-post-thumbnail  simple-grid  listing-item listing-item-grid listing-item-grid-1 main-term-3489"><div class=item-inner><div class="featured clearfix"><div class="term-badges floated"><span class="term-badge term-3489"><a href=http://www.linuxandubuntu.com/home/category/distros/kali-linux>Kali Linux</a></span></div>		<a alt="kali linux black screen on boot" title="[Fixed] Kali Linux Stuck At Black Screen On Boot" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/kali-linux-black-screen-on-boot.png?resize=357%2C210);" data-bsrjs=https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/kali-linux-black-screen-on-boot-750x400.png						class=img-holder href=http://www.linuxandubuntu.com/home/kali-linux-stuck-at-black-screen-on-boot></a></div><p class=title>		<a href=http://www.linuxandubuntu.com/home/kali-linux-stuck-at-black-screen-on-boot class="post-title post-url"> [Fixed] Kali Linux Stuck At Black Screen On Boot	</a></p></div></div ><div class="post-16334 type-post format-standard has-post-thumbnail  simple-grid  listing-item listing-item-grid listing-item-grid-1 main-term-1213"><div class=item-inner><div class="featured clearfix"><div class="term-badges floated"><span class="term-badge term-1213"><a href=http://www.linuxandubuntu.com/home/category/distros/linux-mint>Linux Mint</a></span></div>		<a alt="linux mint tara released" title="Linux Mint 19.2 &#8220;Tina&#8221; Released" style="background-image: url(https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/08/linux-mint-19.2-tara-released.png?resize=357%2C210);" data-bsrjs=https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/08/linux-mint-19.2-tara-released-750x400.png						class=img-holder href=http://www.linuxandubuntu.com/home/linux-mint-19-2-tina-released></a></div><p class=title>		<a href=http://www.linuxandubuntu.com/home/linux-mint-19-2-tina-released class="post-title post-url"> Linux Mint 19.2 &#8220;Tina&#8221; Released	</a></p></div></div ></div></div><div class="bs-pagination bs-ajax-pagination next_prev main-term-162 clearfix"> <script>var bs_ajax_paginate_1870246831='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":"162","_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"1b2d9df"}';</script> <a class="btn-bs-pagination prev disabled" rel=prev data-id=1870246831 title=Previous> <i class="fa fa-angle-left" aria-hidden=true></i> Prev	</a> <a rel=next class="btn-bs-pagination next" data-id=1870246831 title=Next> Next <i class="fa fa-angle-right" aria-hidden=true></i> </a></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-3507><div class="bs-pagination-wrapper main-term-3507 next_prev "><div class=bs-deferred-load-wrapper id=bsd_340690239> <script>var bs_deferred_loading_bsd_340690239='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":3507,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"dc65dca"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-2012><div class="bs-pagination-wrapper main-term-2012 next_prev "><div class=bs-deferred-load-wrapper id=bsd_1379054757> <script>var bs_deferred_loading_bsd_1379054757='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":2012,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"12bdfdb"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-1775><div class="bs-pagination-wrapper main-term-1775 next_prev "><div class=bs-deferred-load-wrapper id=bsd_562150987> <script>var bs_deferred_loading_bsd_562150987='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":1775,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"43a600b"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-1214><div class="bs-pagination-wrapper main-term-1214 next_prev "><div class=bs-deferred-load-wrapper id=bsd_1259222757> <script>var bs_deferred_loading_bsd_1259222757='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":1214,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"b1254b6"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-3618><div class="bs-pagination-wrapper main-term-3618 next_prev "><div class=bs-deferred-load-wrapper id=bsd_1039906933> <script>var bs_deferred_loading_bsd_1039906933='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":3618,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"cca50fe"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-3823><div class="bs-pagination-wrapper main-term-3823 next_prev "><div class=bs-deferred-load-wrapper id=bsd_618688664> <script>var bs_deferred_loading_bsd_618688664='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":3823,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"0c7927c"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-942><div class="bs-pagination-wrapper main-term-942 next_prev "><div class=bs-deferred-load-wrapper id=bsd_1704736666> <script>var bs_deferred_loading_bsd_1704736666='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":942,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"61c604f"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-3489><div class="bs-pagination-wrapper main-term-3489 next_prev "><div class=bs-deferred-load-wrapper id=bsd_1761998106> <script>var bs_deferred_loading_bsd_1761998106='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":3489,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"538b51f"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-1213><div class="bs-pagination-wrapper main-term-1213 next_prev "><div class=bs-deferred-load-wrapper id=bsd_1410048359> <script>var bs_deferred_loading_bsd_1410048359='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":1213,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"40fada4"}';</script> </div></div></div><div class="tab-pane bs-tab-anim bs-deferred-container" id=mtab-793792632-982><div class="bs-pagination-wrapper main-term-982 next_prev "><div class=bs-deferred-load-wrapper id=bsd_1349684805> <script>var bs_deferred_loading_bsd_1349684805='{"query":{"paginate":"next_prev","show_label":1,"order_by":"date","count":3,"category":982,"_layout":{"state":"1|1|0","page":"2-col-right"}},"type":"wp_query","view":"Publisher::bs_pagin_ajax_tabbed_mega_grid_posts","current_page":1,"ajax_url":"\/wp-admin\/admin-ajax.php","remove_duplicates":"0","paginate":"next_prev","_layout":{"state":"1|1|0","page":"2-col-right"},"_bs_pagin_token":"650f78d"}';</script> </div></div></div></div></div></div></li><li id=menu-item-11548 class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-11548"><a href=http://www.linuxandubuntu.com/video-tutorials>Video Tutorials</a></li><li id=menu-item-8337 class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-8337"><a href=http://www.linuxandubuntu.com/faqs>Linux FAQs</a></li><li id=menu-item-9733 class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-9733"><a href=http://www.linuxandubuntu.com/advertise>Advertise</a></li><li id=menu-item-9636 class="menu-item menu-item-type-post_type menu-item-object-page better-anim-fade menu-item-9636"><a href=http://www.linuxandubuntu.com/contact-us>Contact us</a></li></ul><div class="menu-action-buttons width-1"><div class="search-container close"> <span class=search-handler><i class="fa fa-search"></i></span><div class="search-box clearfix"><form role=search method=get class="search-form clearfix" action=http://www.linuxandubuntu.com> <input type=search class=search-field placeholder=Search... value name=s title="Search for:" autocomplete=off> <input type=submit class=search-submit value=Search></form></div></div></div></nav></div></div></div></div></header><div class="rh-header clearfix light deferred-block-exclude"><div class="rh-container clearfix"><div class="menu-container close"> <span class=menu-handler><span class=lines></span></span></div><div class="logo-container rh-text-logo"> <a href=http://www.linuxandubuntu.com/ itemprop=url rel=home> LinuxAndUbuntu	</a></div></div></div><nav role=navigation aria-label=Breadcrumbs class="bf-breadcrumb clearfix bc-top-style"><div class="container bf-breadcrumb-container"><ul class=bf-breadcrumb-items itemscope itemtype=http://schema.org/BreadcrumbList><meta name=numberOfItems content=4><meta name=itemListOrder content=Ascending><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem class="bf-breadcrumb-item bf-breadcrumb-begin"><a itemprop=item href=http://www.linuxandubuntu.com rel="home""><span itemprop=name>Home</span><meta itemprop=position content=1></a></li><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem class=bf-breadcrumb-item><a itemprop=item href=http://www.linuxandubuntu.com/home ><span itemprop=name>Home</span><meta itemprop=position content=2></a></li><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem class=bf-breadcrumb-item><a itemprop=item href=http://www.linuxandubuntu.com/home/category/nextcloud ><span itemprop=name>Nextcloud</span><meta itemprop=position content=3></a></li><li itemprop=itemListElement itemscope itemtype=http://schema.org/ListItem class="bf-breadcrumb-item bf-breadcrumb-end"><span itemprop=name>Install Nextcloud &#8211; Free &#038; Open Source Cloud Storage Solution</span><meta itemprop=position content=4><meta itemprop=item content=http://www.linuxandubuntu.com/home/install-nextcloud-free-open-source-cloud-solution></li></ul></div></nav><div class=content-wrap><main id=content class=content-container><div class="container layout-2-col layout-2-col-1 layout-right-sidebar layout-bc-before post-template-1"><div class="row main-section"><div class="col-sm-8 content-column"><div class=single-container><article id=post-16382 class="post-16382 post type-post status-publish format-standard has-post-thumbnail  category-nextcloud single-post-content "><div class="pyhlt pyhlt-clearfix pyhlt-above-post-box pyhlt-pubadban pyhlt-show-desktop pyhlt-show-tablet-portrait pyhlt-show-tablet-landscape pyhlt-show-phone pyhlt-loc-post_box_above pyhlt-align-center pyhlt-column-1"><div id=pyhlt-15995-1834058748 class="pyhlt-container pyhlt-type-code " itemscope itemtype=https://schema.org/WPAdBlock data-adid=15995 data-type=code><div id=pyhlt-15995-1834058748-place></div><script>var betterads_screen_width=document.body.clientWidth;betterads_el=document.getElementById('pyhlt-15995-1834058748');if(betterads_el.getBoundingClientRect().width){betterads_el_width_raw=betterads_el_width=betterads_el.getBoundingClientRect().width;}else{betterads_el_width_raw=betterads_el_width=betterads_el.offsetWidth;}var size=["125","125"];if(betterads_el_width>=728)betterads_el_width=["728","90"];else if(betterads_el_width>=468)betterads_el_width=["468","60"];else if(betterads_el_width>=336)betterads_el_width=["336","280"];else if(betterads_el_width>=300)betterads_el_width=["300","250"];else if(betterads_el_width>=250)betterads_el_width=["250","250"];else if(betterads_el_width>=200)betterads_el_width=["200","200"];else if(betterads_el_width>=180)betterads_el_width=["180","150"];if(betterads_screen_width>=1140){document.getElementById('pyhlt-15995-1834058748-place').innerHTML='<ins class=adsbygoogle style=display:block;  data-ad-client=ca-pub-1925104690687996  data-ad-slot=7903274511  data-full-width-responsive=true  data-ad-format=auto ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=1019&&betterads_screen_width<1140){document.getElementById('pyhlt-15995-1834058748-place').innerHTML='<ins class=adsbygoogle style=display:block;  data-ad-client=ca-pub-1925104690687996  data-ad-slot=7903274511  data-full-width-responsive=true  data-ad-format=auto ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=768&&betterads_screen_width<1019){document.getElementById('pyhlt-15995-1834058748-place').innerHTML='<ins class=adsbygoogle style=display:block;  data-ad-client=ca-pub-1925104690687996  data-ad-slot=7903274511  data-full-width-responsive=true  data-ad-format=auto ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width<768){document.getElementById('pyhlt-15995-1834058748-place').innerHTML='<ins class=adsbygoogle style=display:block;  data-ad-client=ca-pub-1925104690687996  data-ad-slot=7903274511  data-full-width-responsive=true  data-ad-format=auto ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}</script></div></div><div class="post-header post-tp-1-header"><h1 class="single-post-title"> <span class=post-title itemprop=headline>Install Nextcloud &#8211; Free &#038; Open Source Cloud Storage Solution</span></h1><div class="single-post-excerpt post-excerpt-at"><p>Nextcloud is a free and open-source cloud storage platform one can easily setup. It is the best free &#038; open-source alternative to Google Drive or Dropbox.</p></div><div class="post-meta-wrap clearfix"><div class="term-badges "><span class="term-badge term-3832"><a href=http://www.linuxandubuntu.com/home/category/nextcloud>Nextcloud</a></span></div><div class="post-meta single-post-meta"> <a href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye title="Browse Author Articles" class="post-author-a post-author-avatar"> <img alt src="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=26&amp;d=mm&amp;r=g" class="avatar avatar-26 photo avatar-default jetpack-lazy-image" height=26 width=26 data-lazy-src="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=26&amp;d=mm&amp;r=g&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img alt src='http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=26&d=mm&r=g' class='avatar avatar-26 photo avatar-default' height=26 width=26></noscript><span class=post-author-name>By <b>Sohail</b></span>		</a> <span class=time><time class="post-published updated" datetime=2019-09-16T03:53:36+00:00>Last updated <b>Sep 16, 2019</b></time></span> <a href=http://www.linuxandubuntu.com/home/install-nextcloud-free-open-source-cloud-solution#respond title="Leave a comment on: &ldquo;Install Nextcloud &#8211; Free &#038; Open Source Cloud Storage Solution&rdquo;" class=comments><i class="fa fa-comments-o"></i> 0</a></div></div><div class=single-featured></div></div><div class="entry-content clearfix single-post-content"><div class="continue-reading-content close"><p>It is said that the data is the new oil of the modern world. We all know how companies mine data and sell it to other companies. Not only that but recently the use of cloud storage has also risen up which means people have now started using cloud storage to store their important data.</p><p>Google, Microsoft, Apple, Yandex, and almost all other major companies provide cloud storage solutions. All of these services provide a free plan for personal use but if you&#8217;re a business, then you&#8217;ll need to pay a huge amount of money to expand your storage.</p><p>Even after you subscribe to their premium services, your data stays on their servers and they can control it however they want which make these companies more powerful. Recently, <a href=https://nextcloud.com/blog/eu-governments-choose-independence-from-us-cloud-providers-with-nextcloud/>Europian Governments</a> have begun to deploy their own cloud solutions rather than picking any foreign-based company.</p><div class=zNmhlyue style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><p>Our sponsor - Deploy your server within <strong>3 minutes</strong></p> <a href=http://www.linuxandubuntu.com/recommends/digitalocean><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=1170" data-recalc-dims=1 data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 class=" jetpack-lazy-image"><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src='https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=1170' data-recalc-dims=1></img></noscript></a></div><p>Deploying your own cloud solution is not only less costly but it gives owner complete control over their data. One of the best ways to setup a self-hosted cloud solution is Nextcloud.</p><p>Nextcloud is a <a href=https://nextcloud.com/ target=_blank rel="noreferrer noopener" aria-label="free and open-source cloud storage platform (opens in a new tab)">free and open-source cloud storage platform</a> one can easily setup. It is the best free &amp; open-source alternative to Google Drive or Dropbox.</p><p>Like any other popular cloud service, you can deploy Nextcloud and have your family or employee use it on any device they have including, Android, iOS etc.</p><p>In this article, we are going to setup Nextcloud on a VPS(Virtual private server).</p><h2>System Requirements</h2><p>Nextcloud can be setup on all major Linux distributions.</p><ul><li><strong>Ubuntu 18.04 LTS</strong>&nbsp;(Recommended)</li><li><strong>Red Hat Enterprise Linux 7</strong>&nbsp;(Recommended)</li><li>Debian 8 (Jessie), 9 (Stretch)</li><li>SUSE Linux Enterprise Server 11 with SP3 &amp; 12</li><li>openSUSE Leap 42.1+</li><li>CentOS 7</li></ul><p>Database requirements</p><ul><li><strong>MySQL 5.x or MariaDB 5.5+</strong>&nbsp;(recommended)</li><li>Oracle Database 11g (<em>only as part of an enterprise subscription</em>)</li><li>PostgreSQL 9/10</li><li>SQLite (<em>only recommended for testing and minimal-instances</em>)</li></ul><p>Server</p><ul><li><strong>Apache 2.4 with</strong>&nbsp;<code>mod_php</code>&nbsp;<strong>or</strong>&nbsp;<code>php-fpm</code>&nbsp;(recommended)</li><li>nginx with&nbsp;<code>php-fpm</code></li></ul><p>PHP version</p><ul><li><strong>7.0</strong></li><li><strong>7.1</strong></li><li><strong>7.2</strong></li></ul><h2>For setting up Nextcloud on localhost</h2><p>If you want to setup Nextcloud for your home or local network, then read the following articles on installing Linux distribution &amp; setting up LAMP on it.</p><p>I prefer to use Ubuntu latest LTS version for all my projects.</p><div class=wp-block-coblocks-alert><p class=wp-block-coblocks-alert__title><strong>Setup server</strong></p><p class=wp-block-coblocks-alert__text>Install Ubuntu Minimal version.<br><a href=http://www.linuxandubuntu.com/home/ubuntu-minimal-install>Ubuntu Minimal Install</a></p></div><p>Once we have installed Ubuntu, we can install other required packages for Nextcloud.</p><p>If you are setting up Nextcloud on localhost, you can follow these steps without any problems. If you are a small or big company, you need to have a server with a static ip address.</p><p style=text-align:left>For the purpose of this article, I am going to setup a Ubuntu 18.04 droplet on <a href=http://www.linuxandubuntu.com/recommends/digitalocean>Digitalocean</a>. It takes minutes to create a server up and running on <a href=http://www.linuxandubuntu.com/recommends/digitalocean>Digitalocean</a>.</p><h3>Create a Ubuntu Server on Digitalocean</h3><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?w=1170" alt="Create Ubuntu server on digitalocean" class="wp-image-16661 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?w=809 809w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?resize=300%2C214 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?resize=768%2C549 768w" data-lazy-sizes="(max-width: 809px) 100vw, 809px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?w=1170" alt="Create Ubuntu server on digitalocean" class=wp-image-16661 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?w=809 809w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?resize=300%2C214 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-58-25.png?resize=768%2C549 768w" sizes="(max-width: 809px) 100vw, 809px" data-recalc-dims=1></noscript><figcaption>Create Ubuntu server on Digitalocean</figcaption></figure><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?w=1170" alt="Select server location on Digitalocean" class="wp-image-16662 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?w=811 811w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?resize=300%2C228 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?resize=768%2C583 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?resize=86%2C64 86w" data-lazy-sizes="(max-width: 811px) 100vw, 811px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?w=1170" alt="Select server location on Digitalocean" class=wp-image-16662 srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?w=811 811w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?resize=300%2C228 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?resize=768%2C583 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-15-23-59-54.png?resize=86%2C64 86w" sizes="(max-width: 811px) 100vw, 811px" data-recalc-dims=1></noscript><figcaption>Select server location on Digitalocean</figcaption></figure><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?w=1170" alt="Finalize &amp; Create server" class="wp-image-16663 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?w=800 800w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?resize=300%2C187 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?resize=768%2C478 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?w=1170" alt="Finalize &amp; Create server" class=wp-image-16663 srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?w=800 800w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?resize=300%2C187 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-02-43.png?resize=768%2C478 768w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims=1></noscript><figcaption>Finalize &amp; Create server</figcaption></figure><p>It takes 2 to 3 minutes for the server to be ready to connect. Once the server is ready, it shows the ip address on the dashboard. The setup process automatically creates a root user and sends the password to the user&#8217;s registered email.</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?w=1170" alt="Server running on Digitalocean" class="wp-image-16665 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?w=824 824w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?resize=300%2C189 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?resize=768%2C483 768w" data-lazy-sizes="(max-width: 824px) 100vw, 824px" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?w=1170" alt="Server running on Digitalocean" class=wp-image-16665 srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?w=824 824w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?resize=300%2C189 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-09-54.png?resize=768%2C483 768w" sizes="(max-width: 824px) 100vw, 824px" data-recalc-dims=1></noscript><figcaption>Server running on Digitalocean</figcaption></figure><p>From the dashboard copy the IP address of the server and login using SSH.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>ssh root@165.22.184.143</pre><p>You&#8217;ll asked to type your password. Simply copy the password from the email sent to your registered email id and paste it here.</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-29-11.png?w=1170" alt="Login to server using SSH" class="wp-image-16667 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-29-11.png?w=736 736w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-29-11.png?resize=300%2C199 300w" data-lazy-sizes="(max-width: 736px) 100vw, 736px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-29-11.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-29-11.png?w=1170" alt="Login to server using SSH" class=wp-image-16667 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-29-11.png?w=736 736w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-29-11.png?resize=300%2C199 300w" sizes="(max-width: 736px) 100vw, 736px" data-recalc-dims=1></noscript><figcaption>Login to server using SSH</figcaption></figure><p>For security purposes, the default password must be changed when you login on the server for the first time. So after you are logged in to your server, you&#8217;ll be asked to retype your current password and enter a new password.</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-31-32.png?w=1170" alt="Set a new root password" class="wp-image-16668 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-31-32.png?w=736 736w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-31-32.png?resize=300%2C199 300w" data-lazy-sizes="(max-width: 736px) 100vw, 736px" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-31-32.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-31-32.png?w=1170" alt="Set a new root password" class=wp-image-16668 srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-31-32.png?w=736 736w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-31-32.png?resize=300%2C199 300w" sizes="(max-width: 736px) 100vw, 736px" data-recalc-dims=1></noscript><figcaption>Set a new root password</figcaption></figure><div class="wp-block-coblocks-alert is-style-info" style=background-color:><p class=wp-block-coblocks-alert__title><strong>Notice</strong></p><p class=wp-block-coblocks-alert__text>Make a strong password. Include string, numbers, and symbols to make it strong.<br><br>You can check your password strength <a href=http://password-checker.online-domain-tools.com/ target=_blank rel="noreferrer noopener" aria-label=" (opens in a new tab)">here</a>. This tool shows the time different system takes in cracking your password. It is very important to use this tool to figure out the strength of your passwords.</p></div><h3>Create a new user account on Ubuntu</h3><p>By default, the server creation process creates a root user. It is not recommended to use root all the time. We can create a new server user and give it sudo access to make it perform administrative tasks.</p><p>To create a new user, we use &#8216;adduser&#8217; command.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>adduser username</pre><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-32-55.png?w=1170" alt="Create a new server user" class="wp-image-16669 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-32-55.png?w=736 736w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-32-55.png?resize=300%2C199 300w" data-lazy-sizes="(max-width: 736px) 100vw, 736px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-32-55.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-32-55.png?w=1170" alt="Create a new server user" class=wp-image-16669 srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-32-55.png?w=736 736w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-32-55.png?resize=300%2C199 300w" sizes="(max-width: 736px) 100vw, 736px" data-recalc-dims=1></noscript><figcaption>Create a new server user</figcaption></figure><h3>Add user to sudo group</h3><p>Until this point, you won&#8217;t be able to use sudo with the newly created account. Add the new user account to sudo group.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>usermod -aG sudo sandy</pre><p>It is all done! We now have a server running with a new user account that can use sudo. 🙂</p><p>You can login to the new user account from the current session using the following command or log out of the root user and create a new session.</p><p>To login from the current session &#8211;</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>su - sandy
Replace sandy with your username.</pre><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-39-29.png?w=1170" alt="Login to new user account" class="wp-image-16670 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-39-29.png?w=736 736w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-39-29.png?resize=300%2C199 300w" data-lazy-sizes="(max-width: 736px) 100vw, 736px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-39-29.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-39-29.png?w=1170" alt="Login to new user account" class=wp-image-16670 srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-39-29.png?w=736 736w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-00-39-29.png?resize=300%2C199 300w" sizes="(max-width: 736px) 100vw, 736px" data-recalc-dims=1></noscript><figcaption>Login to new user account</figcaption></figure><p>Login to new server user</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>ssh sandy@165.22.184.143</pre><h3>Update your Server</h3><p>The very first thing to do after logging in to the server is to update it. We use apt package manager to update Ubuntu Linux.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>sudo apt update &amp;&amp; sudo apt upgrade -y</pre><p>The update process may take a long time depending on your internet speed. If you&#8217;re using VPS like in my case, it won&#8217;t take more than 3 minutes.</p><p>Once the server finishes installing updates, reboot the server using the following command &#8211;</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>sudo reboot</pre><p>Reboot usually takes 30s-1m. So try logging in to the server after 1 minute.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>ssh sandy@165.22.184.143</pre><p>Now our server is ready and we can start to prepare Nextcloud installation.</p><h3>Install Nextcloud Requirements</h3><p>Copy and paste the following commands to install PHP7.2 + extensions and apache web server.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>sudo apt install php7.2 php7.2-zip php7.2-zip php7.2-xml php7.2-gd php7.2-curl php7.2-mbstring php7.2-mysql mysql-server
sudo apt install apache2</pre><p>After the installation completes, visit your server ip address in web browser. If you are setting up Nextcloud on your local server, visit <code>localhost</code> or <code>127.0.0.1</code>.</p><p>You should see the following page &#8211;</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=1024%2C558" alt="Apache server running on Ubuntu server" class="wp-image-16673 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=1024%2C558 1024w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=300%2C163 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=768%2C418 768w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?w=1360 1360w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=1024%2C558&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=1024%2C558" alt="Apache server running on Ubuntu server" class=wp-image-16673 srcset="https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=1024%2C558 1024w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=300%2C163 300w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?resize=768%2C418 768w, https://i0.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-08-18.png?w=1360 1360w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims=1></noscript><figcaption>Apache server running on Ubuntu server</figcaption></figure><p>If you do not see the above page, check that apache server running status.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>sudo service apache2 status</pre><p>You should have the following output in terminal &#8211;</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?w=1170" alt="Apache running status" class="wp-image-16674 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?w=880 880w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?resize=300%2C222 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?resize=768%2C568 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?resize=86%2C64 86w" data-lazy-sizes="(max-width: 880px) 100vw, 880px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?w=1170" alt="Apache running status" class=wp-image-16674 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?w=880 880w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?resize=300%2C222 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?resize=768%2C568 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-13-45.png?resize=86%2C64 86w" sizes="(max-width: 880px) 100vw, 880px" data-recalc-dims=1></noscript><figcaption>Apache running status</figcaption></figure><p>As you can see above, the <strong>apache is active</strong>. If you see it inactive, it means the apache service is not running. Start apache using the following command &#8211;</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>sudo service apache2 start</pre><p>If you still do not see the Ubuntu apache page, make sure that you&#8217;ve followed all the above steps correctly.</p><p>Setup apache configuration file for Nextcloud.</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>sudo nano /etc/apache2/apache2.conf</pre><p>Change the following lines &#8211;</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>&lt;Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
&lt;/Directory>
</pre><p>To</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>&lt;Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
&lt;/Directory></pre><h3>Create Mysql user and database for Nextcloud</h3><p>Login to mysql cli &#8211;</p><pre class=EnlighterJSRAW data-enlighter-language=generic data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>sudo mysql</pre><p>It will log you into your mysql root account. The next we need to create a new user account &amp; database and grant user all privileges over the database.</p><pre class=EnlighterJSRAW data-enlighter-language=sql data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>CREATE USER 'sohail'@'localhost' IDENTIFIED BY 'some_pass';
GRANT ALL PRIVILEGES ON *.* TO 'sohail'@'localhost' WITH GRANT OPTION;

CREATE database nextcloud;
GRANT ALL PRIVILEGES ON nextcloud.* TO 'sohail'@'localhost';
FLUSH PRIVILEGES;</pre><h2>Install Nextcloud</h2><p>There are multiple ways we can install &amp; setup Nextcloud on our server but the easiest is using the web installer. Nextcloud team has built an easy to use web installer to install and setup the service easily.</p><p>All we need to do is download the web installer and run the setup from web browser.</p><p>Download web installer using <code>wget</code> and move it in <code>/var/www/html</code> directory.</p><pre class=EnlighterJSRAW data-enlighter-language=shell data-enlighter-theme data-enlighter-highlight data-enlighter-linenumbers data-enlighter-lineoffset data-enlighter-title data-enlighter-group>wget https://download.nextcloud.com/server/installer/setup-nextcloud.php &amp;&amp; sudo mv setup-nextcloud.php /var/www/html

Make the apache server own the server directory to avoid any permission related issues.

sudo chown -R www-data /var/www/html</pre><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?w=1170" alt="Download Nextcloud web installer" class="wp-image-16676 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?w=880 880w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?resize=300%2C222 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?resize=768%2C568 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?resize=86%2C64 86w" data-lazy-sizes="(max-width: 880px) 100vw, 880px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?w=1170" alt="Download Nextcloud web installer" class=wp-image-16676 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?w=880 880w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?resize=300%2C222 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?resize=768%2C568 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-31-05.png?resize=86%2C64 86w" sizes="(max-width: 880px) 100vw, 880px" data-recalc-dims=1></noscript><figcaption>Download Nextcloud web installer</figcaption></figure><p>To start the setup, open the web setup in web browser.</p><pre class=wp-block-code><code>http://your-ip-address/setup-nextcloud.php

My server ip is - 165.22.184.143

If you are setting up on your local server, visit localhost/setup-nextcloud.php or 127.0.0.1/setup-nextcloud.php

http://165.22.184.143/setup-nextcloud.php</code></pre><p>The setup page will open. You can now easily follow the on-screen instructions to setup Nextcloud. But don&#8217;t worry, I will also guide you through the complete setup.</p><p>Click next to check all the dependencies.</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=1024%2C558" alt="Nextcloud web installer" class="wp-image-16677 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=1024%2C558 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=300%2C163 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=768%2C418 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?w=1360 1360w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=1024%2C558&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=1024%2C558" alt="Nextcloud web installer" class=wp-image-16677 srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=1024%2C558 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=300%2C163 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?resize=768%2C418 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-36-34.png?w=1360 1360w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims=1></noscript><figcaption>Nextcloud web installer</figcaption></figure><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=1024%2C558" alt="Nextcloud install directory" class="wp-image-16679 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=1024%2C558 1024w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=300%2C163 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=768%2C418 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?w=1360 1360w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=1024%2C558&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=1024%2C558" alt="Nextcloud install directory" class=wp-image-16679 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=1024%2C558 1024w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=300%2C163 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?resize=768%2C418 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-47-37.png?w=1360 1360w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims=1></noscript><figcaption>Nextcloud install directory</figcaption></figure><p>If you want to install Nextcloud in a sub-directory, then you can enter the directory name here otherwise enter &#8216;.&#8217; (without quotes) to install it in the root directory.</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=1024%2C558" alt="Nextcloud installation completed" class="wp-image-16680 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=1024%2C558 1024w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=300%2C163 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=768%2C418 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?w=1360 1360w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=1024%2C558&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=1024%2C558" alt="Nextcloud installation completed" class=wp-image-16680 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=1024%2C558 1024w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=300%2C163 300w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?resize=768%2C418 768w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-01-49-04.png?w=1360 1360w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims=1></noscript><figcaption>Nextcloud installation completed</figcaption></figure><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=1024%2C558" alt="Create Nextcloud admin account &amp; setup Database &amp; storage" class="wp-image-16681 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=1024%2C558 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=300%2C163 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=768%2C418 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?w=1360 1360w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=1024%2C558&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=1024%2C558" alt="Create Nextcloud admin account &amp; setup Database &amp; storage" class=wp-image-16681 srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=1024%2C558 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=300%2C163 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?resize=768%2C418 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-26-56.png?w=1360 1360w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims=1></noscript><figcaption>Create Nextcloud admin account &amp; setup Database &amp; storage</figcaption></figure><p>As you can see I have used mysql database credentials I created above. Finally click &#8216;Finish setup&#8217; button. And that is all.</p><p>If everything setup correctly, you will be redirected to Nextcloud main page.</p><figure class=wp-block-image><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=1024%2C558" alt="Nextcloud storage" class="wp-image-16682 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=1024%2C558 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=300%2C163 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=768%2C418 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?w=1360 1360w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=1024%2C558&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=1024%2C558" alt="Nextcloud storage" class=wp-image-16682 srcset="https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=1024%2C558 1024w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=300%2C163 300w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?resize=768%2C418 768w, https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/Screenshot-from-2019-09-16-02-27-40.png?w=1360 1360w" sizes="(max-width: 1024px) 100vw, 1024px" data-recalc-dims=1></noscript><figcaption>Nextcloud storage</figcaption></figure><p>As you can see the interface is very similar to Dropbox and Google drive. The only difference is that the data you store here is never going to be used by anyone else. It is your data and you can control it.</p><p>As your cloud storage has more and more users, you can expand your server size easily on <a href=http://www.linuxandubuntu.com/recommends/digitalocean>Digitalocean</a>.</p><figure class=wp-block-image><a href=http://www.linuxandubuntu.com/recommends/digitalocean target=_blank rel="noreferrer noopener"><img onerror="this.src=&#039;http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg&#039;" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=1170" alt=digitalocean class="wp-image-16694 jetpack-lazy-image" data-recalc-dims=1 data-lazy-srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=728 728w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?resize=300%2C37 300w" data-lazy-sizes="(max-width: 728px) 100vw, 728px" data-lazy-src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=1170&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img onerror="this.src='http://www.linuxandubuntu.com/wp-content/plugins/replace-broken-images/images/default.jpg'" src="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=1170" alt=digitalocean class=wp-image-16694 srcset="https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?w=728 728w, https://i2.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/digitalocean.png?resize=300%2C37 300w" sizes="(max-width: 728px) 100vw, 728px" data-recalc-dims=1></noscript></a></figure><p>So this was the basic setup of Nextcloud, a free and open source cloud platform. I will be covering more articles on making Nextcloud more useful.</p><p>If you have any question regarding any step described above, do not hesitate asking it in the comment section below.</p></div><div class=continue-reading-container><a href=# class="continue-reading-btn btn">Continue Reading</a></div></div><div class="post-share single-post-share bottom-share clearfix style-4"><div class=post-share-btn-group> <a href=http://www.linuxandubuntu.com/home/install-nextcloud-free-open-source-cloud-solution#respond class="post-share-btn post-share-btn-comments comments" title="Leave a comment on: &ldquo;Install Nextcloud &#8211; Free &#038; Open Source Cloud Storage Solution&rdquo;"><i class="bf-icon fa fa-comments" aria-hidden=true></i> <b class=number>0</b></a></div><div class="share-handler-wrap "> <span class="share-handler post-share-btn rank-default"> <i class="bf-icon  fa fa-share-alt"></i>		<b class=text>Share</b> </span> <span class="social-item facebook"><a href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-facebook','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-facebook"></i></span></a></span><span class="social-item twitter"><a href="https://twitter.com/share?text=Install+Nextcloud+%26%238211%3B+Free+%26%23038%3B+Open+Source+Cloud+Storage+Solution @linuxandubuntu&url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-twitter','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-twitter"></i></span></a></span><span class="social-item telegram"><a href="https://telegram.me/share/url?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution&text=Install+Nextcloud+%26%238211%3B+Free+%26%23038%3B+Open+Source+Cloud+Storage+Solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-telegram','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-send"></i></span></a></span><span class="social-item reddit"><a href="https://reddit.com/submit?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution&title=Install+Nextcloud+%26%238211%3B+Free+%26%23038%3B+Open+Source+Cloud+Storage+Solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-reddit','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-reddit-alien"></i></span></a></span><span class="social-item whatsapp"><a href="whatsapp://send?text=Install+Nextcloud+%26%238211%3B+Free+%26%23038%3B+Open+Source+Cloud+Storage+Solution %0A%0A http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-whatsapp','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-whatsapp"></i></span></a></span><span class="social-item pinterest"><a href="https://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution&media=https://i1.wp.com/www.linuxandubuntu.com/wp-content/uploads/2019/09/install-nextcloud-cloud-storage-solution.png?fit=809%2C400&description=Install+Nextcloud+%26%238211%3B+Free+%26%23038%3B+Open+Source+Cloud+Storage+Solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-pinterest','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-pinterest"></i></span></a></span><span class="social-item email"><a href="mailto:?subject=Install+Nextcloud+%26%238211%3B+Free+%26%23038%3B+Open+Source+Cloud+Storage+Solution&body=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-email','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-envelope-open"></i></span></a></span><span class="social-item linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.linuxandubuntu.com%2Fhome%2Finstall-nextcloud-free-open-source-cloud-solution&title=Install+Nextcloud+%26%238211%3B+Free+%26%23038%3B+Open+Source+Cloud+Storage+Solution" target=_blank rel="nofollow noreferrer" class=bs-button-el onclick="window.open(this.href, 'share-linkedin','left=50,top=50,width=600,height=320,toolbar=0'); return false;"><span class=icon><i class="bf-icon fa fa-linkedin"></i></span></a></span></div></div></article><div class="pyhlt pyhlt-clearfix pyhlt-post-before-author pyhlt-pubadban pyhlt-show-desktop pyhlt-show-tablet-portrait pyhlt-show-tablet-landscape pyhlt-show-phone pyhlt-loc-post_before_author_box pyhlt-align-center pyhlt-column-1"><div id=pyhlt-15999-1679748322 class="pyhlt-container pyhlt-type-code " itemscope itemtype=https://schema.org/WPAdBlock data-adid=15999 data-type=code><div id=pyhlt-15999-1679748322-place></div><script>var betterads_screen_width=document.body.clientWidth;betterads_el=document.getElementById('pyhlt-15999-1679748322');if(betterads_el.getBoundingClientRect().width){betterads_el_width_raw=betterads_el_width=betterads_el.getBoundingClientRect().width;}else{betterads_el_width_raw=betterads_el_width=betterads_el.offsetWidth;}var size=["125","125"];if(betterads_el_width>=728)betterads_el_width=["728","90"];else if(betterads_el_width>=468)betterads_el_width=["468","60"];else if(betterads_el_width>=336)betterads_el_width=["336","280"];else if(betterads_el_width>=300)betterads_el_width=["300","250"];else if(betterads_el_width>=250)betterads_el_width=["250","250"];else if(betterads_el_width>=200)betterads_el_width=["200","200"];else if(betterads_el_width>=180)betterads_el_width=["180","150"];if(betterads_screen_width>=1140){document.getElementById('pyhlt-15999-1679748322-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width_raw+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=3191286661  data-ad-format=autorelaxed></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=1019&&betterads_screen_width<1140){document.getElementById('pyhlt-15999-1679748322-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width_raw+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=3191286661  data-ad-format=autorelaxed></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=768&&betterads_screen_width<1019){document.getElementById('pyhlt-15999-1679748322-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width_raw+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=3191286661  data-ad-format=autorelaxed></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width<768){document.getElementById('pyhlt-15999-1679748322-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width_raw+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=3191286661  data-ad-format=autorelaxed></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}</script></div></div><section class="post-author clearfix"> <a href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye title="Browse Author Articles"> <span class=post-author-avatar itemprop=image><img alt src="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=80&amp;d=mm&amp;r=g" class="avatar avatar-80 photo avatar-default jetpack-lazy-image" height=80 width=80 data-lazy-src="http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=80&amp;d=mm&amp;r=g&amp;is-pending-load=1" srcset=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7><noscript><img alt src='http://0.gravatar.com/avatar/05f563d2668e75e6eb8583a57b531383?s=80&d=mm&r=g' class='avatar avatar-80 photo avatar-default' height=80 width=80></noscript></span> </a><div class="author-title heading-typo"> <a class=post-author-url href=http://www.linuxandubuntu.com/home/author/kathin-username-hai-ye><span class=post-author-name>Sohail</span></a></div><div class=author-links><ul class=author-social-icons></ul></div><div class=post-author-bio itemprop=description><p>Mohd Sohail is a web developer and a Linux sysAdmin. He also loves to write how-to articles, applications reviews and loves to use new Linux distributions.</p></div></section><section class="next-prev-post clearfix"><div class=prev-post><p class="pre-title heading-typo"><i class="fa fa-arrow-left"></i> Prev Post</p><p class="title heading-typo"><a href=http://www.linuxandubuntu.com/home/linux-mint-19-2-tina-released rel=prev>Linux Mint 19.2 &#8220;Tina&#8221; Released</a></p></div><div class=next-post><p class="pre-title heading-typo">Next Post <i class="fa fa-arrow-right"></i></p><p class="title heading-typo"><a href=http://www.linuxandubuntu.com/home/kali-linux-stuck-at-black-screen-on-boot rel=next>[Fixed] Kali Linux Stuck At Black Screen On Boot</a></p></div></section></div><section id=comments-template-16382 class=comments-template><div id=respond class=comment-respond><p id=reply-title class=comment-reply-title><div class="section-heading sh-t2 sh-s1" ><span class=h-text>Leave A Reply</span></div> <small><a rel=nofollow id=cancel-comment-reply-link href=/home/install-nextcloud-free-open-source-cloud-solution#respond style=display:none;>Cancel Reply</a></small></p><form action=http://www.linuxandubuntu.com/wp-comments-post.php method=post id=commentform class=comment-form novalidate><div class=note-before><p>Your email address will not be published.</p></div><p class=comment-wrap><textarea name=comment class=comment id=comment cols=45 rows=10 aria-required=true placeholder="Your Comment"></textarea></p><p class=author-wrap><input name=author class=author id=author type=text value size=45  aria-required=true placeholder="Your Name *"></p><p class=email-wrap><input name=email class=email id=email type=text value size=45  aria-required=true placeholder="Your Email *"></p><p class=comment-form-cookies-consent><input id=wp-comment-cookies-consent name=wp-comment-cookies-consent type=checkbox value=yes><label for=wp-comment-cookies-consent>Save my name, email, and website in this browser for the next time I comment.</label></p><div class=g-recaptcha-wrap style="padding:10px 0 10px 0"><div class=g-recaptcha data-sitekey=6LdsoK0UAAAAAHILc8yP37NhmBNvr0j4FONYEU2G></div></div><p class=form-submit><input name=submit type=submit id=comment-submit class=comment-submit value="Post Comment"> <input type=hidden name=comment_post_ID value=16382 id=comment_post_ID> <input type=hidden name=comment_parent id=comment_parent value=0></p><p style="display: none;"><input type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=4a2c211f2a></p><p style="display: none;"><input type=hidden id=ak_js name=ak_js value=132></p></form></div></section></div><div class="col-sm-4 sidebar-column sidebar-column-primary"><aside id=sidebar-primary-sidebar class=sidebar role=complementary aria-label="Primary Sidebar Sidebar" itemscope=itemscope itemtype=http://schema.org/WPSideBar><div id=pyhlt-4 class=" sidebar-ads h-ni w-nt primary-sidebar-widget widget widget_pyhlt"><div class="pyhlt pyhlt-clearfix  pyhlt-align-center pyhlt-column-1"><div id=pyhlt-16002-626221053 class="pyhlt-container pyhlt-type-code " itemscope itemtype=https://schema.org/WPAdBlock data-adid=16002 data-type=code><div id=pyhlt-16002-626221053-place></div><script>var betterads_screen_width=document.body.clientWidth;betterads_el=document.getElementById('pyhlt-16002-626221053');if(betterads_el.getBoundingClientRect().width){betterads_el_width_raw=betterads_el_width=betterads_el.getBoundingClientRect().width;}else{betterads_el_width_raw=betterads_el_width=betterads_el.offsetWidth;}var size=["125","125"];if(betterads_el_width>=728)betterads_el_width=["728","90"];else if(betterads_el_width>=468)betterads_el_width=["468","60"];else if(betterads_el_width>=336)betterads_el_width=["336","280"];else if(betterads_el_width>=300)betterads_el_width=["300","250"];else if(betterads_el_width>=250)betterads_el_width=["250","250"];else if(betterads_el_width>=200)betterads_el_width=["200","200"];else if(betterads_el_width>=180)betterads_el_width=["180","150"];if(betterads_screen_width>=1140){document.getElementById('pyhlt-16002-626221053-place').innerHTML='<ins class=adsbygoogle style=display:inline-block;width:336px;height:280px  data-ad-client=ca-pub-1925104690687996  data-ad-slot=5196807437 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=1019&&betterads_screen_width<1140){document.getElementById('pyhlt-16002-626221053-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=5196807437 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=768&&betterads_screen_width<1019){document.getElementById('pyhlt-16002-626221053-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=5196807437 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width<768){document.getElementById('pyhlt-16002-626221053-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=5196807437 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}</script></div></div></div><div id=search-4 class=" h-ni w-nt primary-sidebar-widget widget widget_search"><form role=search method=get class="search-form clearfix" action=http://www.linuxandubuntu.com> <input type=search class=search-field placeholder=Search... value name=s title="Search for:" autocomplete=off> <input type=submit class=search-submit value=Search></form></div><div id=pyhlt-3 class=" sidebar-ads h-ni w-nt primary-sidebar-widget widget widget_pyhlt"><div class="pyhlt pyhlt-clearfix  pyhlt-align-center pyhlt-column-1"><div id=pyhlt-16000-757522377 class="pyhlt-container pyhlt-type-code " itemscope itemtype=https://schema.org/WPAdBlock data-adid=16000 data-type=code><div id=pyhlt-16000-757522377-place></div><script>var betterads_screen_width=document.body.clientWidth;betterads_el=document.getElementById('pyhlt-16000-757522377');if(betterads_el.getBoundingClientRect().width){betterads_el_width_raw=betterads_el_width=betterads_el.getBoundingClientRect().width;}else{betterads_el_width_raw=betterads_el_width=betterads_el.offsetWidth;}var size=["125","125"];if(betterads_el_width>=728)betterads_el_width=["728","90"];else if(betterads_el_width>=468)betterads_el_width=["468","60"];else if(betterads_el_width>=336)betterads_el_width=["336","280"];else if(betterads_el_width>=300)betterads_el_width=["300","250"];else if(betterads_el_width>=250)betterads_el_width=["250","250"];else if(betterads_el_width>=200)betterads_el_width=["200","200"];else if(betterads_el_width>=180)betterads_el_width=["180","150"];if(betterads_screen_width>=1140){document.getElementById('pyhlt-16000-757522377-place').innerHTML='<ins class=adsbygoogle style=display:inline-block;width:336px;height:280px  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8811004412 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=1019&&betterads_screen_width<1140){document.getElementById('pyhlt-16000-757522377-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8811004412 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=768&&betterads_screen_width<1019){document.getElementById('pyhlt-16000-757522377-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8811004412 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width<768){document.getElementById('pyhlt-16000-757522377-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8811004412 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}</script></div></div></div><div id=recent-posts-4 class=" h-ni w-nt primary-sidebar-widget widget widget_recent_entries"><div class="section-heading sh-t2 sh-s1"><span class=h-text>Recent Posts</span></div><ul><li> <a href=http://www.linuxandubuntu.com/home/zorin-os-15>Zorin OS 15 More Beautiful &#038; Useful Than Ever</a></li><li> <a href=http://www.linuxandubuntu.com/home/kali-linux-stuck-at-black-screen-on-boot>[Fixed] Kali Linux Stuck At Black Screen On Boot</a></li><li> <a href=http://www.linuxandubuntu.com/home/linux-mint-19-2-tina-released>Linux Mint 19.2 &#8220;Tina&#8221; Released</a></li><li> <a href=http://www.linuxandubuntu.com/home/deepin-os-first-distro-to-bring-cloud-sync-option>Deepin OS &#8211; First Distro To Bring Cloud Sync Option</a></li><li> <a href=http://www.linuxandubuntu.com/home/elasticsearch-databases-attacked-botnets>Cyberattack on Elasticseach Databases turns DBs into Zombies/Botnets</a></li><li> <a href=http://www.linuxandubuntu.com/home/critical-vulnerability-found-in-ad-inserter>Critical Vulnerability Found In Ad Inserter WordPress Plugin</a></li><li> <a href=http://www.linuxandubuntu.com/home/ubuntu-to-provide-nvidia-drivers-update-to-ubuntu-lts-users>Ubuntu To Provide NVIDIA Drivers Updates To Ubuntu LTS Users</a></li><li> <a href=http://www.linuxandubuntu.com/home/septor-linux-for-surfing-internet-anonymously>Septor Linux For Surfing Internet Anonymously</a></li></ul></div><div id=pyhlt-2 class=" sidebar-ads h-ni w-nt primary-sidebar-widget widget widget_pyhlt"><div class="pyhlt pyhlt-clearfix  pyhlt-align-center pyhlt-column-1"><div id=pyhlt-15993-1322766888 class="pyhlt-container pyhlt-type-code " itemscope itemtype=https://schema.org/WPAdBlock data-adid=15993 data-type=code><div id=pyhlt-15993-1322766888-place></div><script>var betterads_screen_width=document.body.clientWidth;betterads_el=document.getElementById('pyhlt-15993-1322766888');if(betterads_el.getBoundingClientRect().width){betterads_el_width_raw=betterads_el_width=betterads_el.getBoundingClientRect().width;}else{betterads_el_width_raw=betterads_el_width=betterads_el.offsetWidth;}var size=["125","125"];if(betterads_el_width>=728)betterads_el_width=["728","90"];else if(betterads_el_width>=468)betterads_el_width=["468","60"];else if(betterads_el_width>=336)betterads_el_width=["336","280"];else if(betterads_el_width>=300)betterads_el_width=["300","250"];else if(betterads_el_width>=250)betterads_el_width=["250","250"];else if(betterads_el_width>=200)betterads_el_width=["200","200"];else if(betterads_el_width>=180)betterads_el_width=["180","150"];if(betterads_screen_width>=1140){document.getElementById('pyhlt-15993-1322766888-place').innerHTML='<ins class=adsbygoogle style=display:inline-block;width:300px;height:600px  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8856775759 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=1019&&betterads_screen_width<1140){document.getElementById('pyhlt-15993-1322766888-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8856775759 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width>=768&&betterads_screen_width<1019){document.getElementById('pyhlt-15993-1322766888-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8856775759 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}else if(betterads_screen_width<768){document.getElementById('pyhlt-15993-1322766888-place').innerHTML='<ins class=adsbygoogle style="display:inline-block;width:'+betterads_el_width[0]+'px;height:'+betterads_el_width[1]+'px"  data-ad-client=ca-pub-1925104690687996  data-ad-slot=8856775759 ></ins>';(adsbygoogle=window.adsbygoogle||[]).push({});}</script></div></div></div><div id=newsletter-pack-2 class=" h-ni w-nt primary-sidebar-widget widget widget_newsletter-pack"><style>#bsnp-403949697.bs-newsletter-pack input.bsnp-input:focus{border-color:#1abc9c  !important}#bsnp-403949697.bs-newsletter-pack input.bsnp-input:focus+.bsnp-icon{color:#1abc9c  !important}#bsnp-403949697.bs-newsletter-pack.bsnp-t1:before,
#bsnp-403949697.bs-newsletter-pack .bsnp-button{background-color:#1abc9c !important}</style><div id=bsnp-403949697 class="bs-shortcode bs-newsletter-pack bsnp-mailchimp bsnp-st-widget bsnp-t1 bsnp-s4 "><div class=bsnp-bc><div class="bsnp-title heading-typo">Subscribe to our newsletter</div><div class=bsnp-desc>Sign up here to get the latest news, updates and special offers delivered directly to your inbox.</div><form action="https://linuxandubuntu.us9.list-manage.com/subscribe/post?u=3761308f7eb276b97211d6a10&id=1de79363d5" method=post name=mc-embedded-subscribe-form class="bsnp-form clearfix " target=_blank><div class="bsnp-inputs-wrap bsnp-clearfix bsnp-2-row"><div class="bsnp-field-w bsnp-field-input-w"><input name=EMAIL type=email placeholder="Enter your email address" class="bsnp-input "><i class="bsnp-icon fa fa-envelope"></i></div><div class="bsnp-field-w bsnp-field-button-w"><button class=bsnp-button name=subscribe type=submit>Subscribe</button></div></div></form><div class=bsnp-after>You can unsubscribe at any time</div><div class='bsnp-si  bsnp-si-t1 bsnp-si-s1'><div class="  better-studio-shortcode bsc-clearfix better-social-counter style-name not-colored in-4-col"><ul class="social-list bsc-clearfix"><li class="social-item facebook" > <a href = "https://www.facebook.com/linuxandubuntuofficial" target = "_blank" > <i class="item-icon bsfi-facebook" ></i><span class=item-name > Facebook </span> </a></li><li class="social-item twitter" > <a href = "https://twitter.com/linuxandubuntu" target = "_blank" > <i class="item-icon bsfi-twitter" ></i><span class=item-name > Twitter </span> </a></li><li class="social-item youtube" > <a href = "https://youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg" target = "_blank" > <i class="item-icon bsfi-youtube" ></i><span class=item-name > Youtube </span> </a></li><li class="social-item instagram" > <a href = "https://instagram.com/mohdsohail_123" target = "_blank" > <i class="item-icon bsfi-instagram" ></i><span class=item-name > Instagram </span> </a></li></ul></div></div></div></div></div><div id=categories-2 class=" h-ni w-t primary-sidebar-widget widget widget_categories"><div class="section-heading sh-t2 sh-s1"><span class=h-text>Categories</span></div><form action=http://www.linuxandubuntu.com method=get><label class=screen-reader-text for=cat>Categories</label><select name=cat id=cat class=postform ><option value=-1>Select Category</option><option class=level-0 value=942>Arch Linux</option><option class=level-0 value=3828>Backup data</option><option class=level-0 value=3507>CentOS</option><option class=level-0 value=2968>Debian</option><option class=level-0 value=3823>Deepin OS</option><option class=level-0 value=2012>Fedora</option><option class=level-0 value=165>Games</option><option class=level-0 value=7>Gnome</option><option class=level-0 value=649>Hacking with Kali Linux</option><option class=level-0 value=3489>Kali Linux</option><option class=level-0 value=1358>Learn Bash</option><option class=level-0 value=3826>Learn Git</option><option class=level-0 value=1024>Learn Linux</option><option class=level-0 value=166>Learn Python</option><option class=level-0 value=3270>Linux</option><option class=level-0 value=162>Linux Distributions</option><option class=level-0 value=1213>Linux Mint</option><option class=level-0 value=597>Linux tools</option><option class=level-0 value=164>Linux Tutorials</option><option class=level-0 value=1627>LMMS</option><option class=level-0 value=1214>MX Linux</option><option class=level-0 value=161>MySQL series</option><option class=level-0 value=778>New</option><option class=level-0 value=292>News</option><option class=level-0 value=3832>Nextcloud</option><option class=level-0 value=3696>Nvidia</option><option class=level-0 value=1340>Programming</option><option class=level-0 value=160>Raspberry Pi Series</option><option class=level-0 value=163>Reviews</option><option class=level-0 value=3078>Security</option><option class=level-0 value=159>Setup web server</option><option class=level-0 value=1775>Ubuntu</option><option class=level-0 value=982>Ubuntu Budgie</option><option class=level-0 value=1>Uncategorized</option><option class=level-0 value=3618>Zorin OS</option> </select></form> <script>(function(){var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){dropdown.parentNode.submit();}}
dropdown.onchange=onCatChange;})();</script> </div></aside></div></div></div></main></div><footer id=site-footer class="site-footer full-width"><div class=footer-social-icons><div class=content-wrap><div class=container><div class="  better-studio-shortcode bsc-clearfix better-social-counter style-big-button colored in-5-col"><ul class="social-list bsc-clearfix"><li class="social-item facebook"> <a href = "https://www.facebook.com/linuxandubuntuofficial" class=item-link target = "_blank" > <i class="item-icon bsfi-facebook" ></i><span class=item-name > Facebook</span> <span class=item-title-join > Join us on Facebook</span> </a></li><li class="social-item twitter"> <a href = "https://twitter.com/linuxandubuntu" class=item-link target = "_blank" > <i class="item-icon bsfi-twitter" ></i><span class=item-name > Twitter</span> <span class=item-title-join > Join us on Twitter</span> </a></li><li class="social-item youtube"> <a href = "https://youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg" class=item-link target = "_blank" > <i class="item-icon bsfi-youtube" ></i><span class=item-name > Youtube</span> <span class=item-title-join > Join us on Youtube</span> </a></li><li class="social-item pinterest"> <a href = "http://www.pinterest.com/linuxandubuntu" class=item-link target = "_blank" > <i class="item-icon bsfi-pinterest" ></i><span class=item-name > Pinterest</span> <span class=item-title-join > Join us on Pinterest</span> </a></li><li class="social-item linkedin"> <a href = "https://www.linkedin.com/in/mohdsohail" class=item-link target = "_blank" > <i class="item-icon bsfi-linkedin" ></i><span class=item-name > Linkedin</span> <span class=item-title-join > Follow us</span> </a></li><li class="social-item rss"> <a href = "http://www.linuxandubuntu.com/feed/rss" class=item-link target = "_blank" > <i class="item-icon bsfi-rss" ></i><span class=item-name > RSS</span> <span class=item-title-join > Subscribe our RSS</span> </a></li></ul></div></div></div></div><div class="footer-widgets light-text"><div class=content-wrap><div class=container><div class=row><div class=col-sm-4><aside id=sidebar-footer-1 class=sidebar role=complementary aria-label="Footer - Column 1 Sidebar" itemscope=itemscope itemtype=http://schema.org/WPSideBar><div id=text-3 class=" h-ni w-bg w-bg-2c3e50 w-t footer-widget footer-column-1 widget widget_text"><div class="section-heading sh-t2 sh-s2"><span class=h-text>About LinuxAndUbuntu</span></div><div class=textwidget><div class=paragraph>​​LinuxAndUbuntu.com  focuses on open source projects but  specific on debian based distributions. We also give value to other linux distributions.</div></div></div></aside></div><div class=col-sm-4><aside id=sidebar-footer-2 class=sidebar role=complementary aria-label="Footer - Column 2 Sidebar" itemscope=itemscope itemtype=http://schema.org/WPSideBar><div id=text-9 class=" h-ni w-bg w-bg-2c3e50 w-t footer-widget footer-column-2 widget widget_text"><div class="section-heading sh-t2 sh-s2"><span class=h-text>Links</span></div><div class=textwidget><div class=paragraph><a title href=http://www.ubuntu.com/ target=_blank rel="noopener noreferrer">Ubuntu.com</a></div><div><a href=https://linuxmint.com/ target=_blank rel="noopener noreferrer">Linux Mint</a></div><div><a title href=http://www.linuxandubuntu.com/home/category/linux-tutorials target=_blank rel="noopener noreferrer">Tutorials &amp; HowTos</a></div></div></div></aside></div><div class=col-sm-4><aside id=sidebar-footer-3 class=sidebar role=complementary aria-label="Footer - Column 3 Sidebar" itemscope=itemscope itemtype=http://schema.org/WPSideBar><div id=text-10 class=" h-ni w-bg w-bg-2c3e50 w-t footer-widget footer-column-3 widget widget_text"><div class="section-heading sh-t2 sh-s2"><span class=h-text>More From LinuxAndUbuntu</span></div><div class=textwidget><div class=paragraph><a href=http://www.linuxandubuntu.com/advertise/ target=_blank rel="noopener noreferrer">Advertise</a></div><div><a href=http://www.linuxandubuntu.com/become-a-regular-writer/ target=_blank rel="noopener noreferrer">Become a LinuxAndUbuntu writer</a></div><div><a href=http://www.linuxandubuntu.com/privacy-policy/ target=_blank rel="noopener noreferrer">Privacy Policy</a></div></div></div></aside></div></div></div></div></div><div class=copy-footer><div class=content-wrap><div class=container><div class="row footer-copy-row"><div class="copy-1 col-lg-6 col-md-6 col-sm-6 col-xs-12"> © 2019 - All Rights Reserved.</div><div class="copy-2 col-lg-6 col-md-6 col-sm-6 col-xs-12"> No content from this website can be reproduced in any format without written permission from LinuxAndUbuntu.</div></div></div></div></div></footer></div><div class="bs-wrap-gdpr-law bs-wrap-gdpr-law-close"><div class=bs-gdpr-law><p> This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish. <a class=bs-gdpr-accept href=# data-cookie=show>Accept</a><a class=bs-gdpr-more href=http://www.linuxandubuntu.com/privacy-policy/>Read More</a></p></div></div> <span class=back-top><i class="fa fa-arrow-up"></i></span><div id=txyEPEZwrQPP class=WfgKEImJDjab style="background:#dddddd;z-index:9999999; "></div> <script>/*<![CDATA[*/var anOptions={"anOptionChoice":"2","anOptionStats":"1","anOptionAdsSelectors":"","anOptionCookie":"1","anOptionCookieLife":"30","anPageRedirect":"","anPermalink":"undefined","anOptionModalEffect":"fadeAndPop","anOptionModalspeed":"350","anOptionModalclose":true,"anOptionModalOverlay":"rgba( 0,0,0,0.8 )","anAlternativeActivation":false,"anAlternativeElement":"","anAlternativeText":"<p><strong>AdBlock detected!<\/strong><\/p>\n<p>Please add <a href=\"http:\/\/www.linuxandubuntu.com\">www.linuxandubuntu.com<\/a>\u00a0to your adblocking whitelist or disable your adblocking software.<\/p>\n","anAlternativeClone":"2","anAlternativeProperties":"","anOptionModalShowAfter":0,"anPageMD5":"","anSiteID":0,"modalHTML":"<div class=\"WfgKEImJDjab-default\">\n\t<h1 style=\"\">Adblocker detected! Please consider reading this notice.<\/h1>\n\t<p>We've detected that you are using AdBlock Plus or some other adblocking software which is preventing the page from fully loading.<\/p>\n<p>We don't have any banner, Flash, animation, obnoxious sound, or popup ad. We do not implement these annoying types of ads!<\/p>\n<p>We need money to operate the site, and almost all of it comes from our online advertising.<\/p>\n<p><strong>Please add <a title=\"LinuxAndUbuntu\" href=\"http:\/\/www.linuxandubuntu.com\" target=\"_blank\" rel=\"noopener\">www.linuxandubuntu.com<\/a> to your ad blocking whitelist or disable your adblocking software.<\/strong><\/p>\n<p>If you do not want to disable your adblocker, just close this popup and keep browsing the site.<\/p>\n<p>Thanks for visiting!<\/p>\n<\/div>\n<a class=\"close-modal close-WfgKEImJDjab\">&#215;<\/a>"}/*]]>*/</script><div id=adsense class=an-sponsored style="position:absolute; z-index:-1; height:1px; width:1px; visibility: hidden; top: -1px; left: 0;"><img class=an-advert-banner alt=sponsored src=data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-42740043-3','auto');ga('send','pageview');</script>  <script>var sc_project=10160336;var sc_invisible=1;var sc_security="10341dd9";</script> <script
src=https://www.statcounter.com/counter/counter.js
async></script> <noscript><div class=statcounter><a title="Web Analytics Made Easy - StatCounter" href=https://statcounter.com/ target=_blank><img class=statcounter src=https://c.statcounter.com/10160336/0/10341dd9/1/ alt="Web Analytics Made Easy - StatCounter"></a></div></noscript> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init','1622359727778105');fbq('track','PageView');</script> <noscript><img height=1 width=1 style=display:none src="https://www.facebook.com/tr?id=1622359727778105&ev=PageView&noscript=1"></noscript><meta name=msvalidate.01 content=25896BA42459FDD824EF025608171717> <script>var verifyCallback=function(response){alert(response);};var onloadCallback=function(){if(jQuery('#woo_recaptcha_1').length){grecaptcha.render('woo_recaptcha_1',{'sitekey':'6LdsoK0UAAAAAHILc8yP37NhmBNvr0j4FONYEU2G',});}
if(jQuery('#woo_recaptcha_2').length){grecaptcha.render('woo_recaptcha_2',{'sitekey':'6LdsoK0UAAAAAHILc8yP37NhmBNvr0j4FONYEU2G',});}};</script> <script src='https://www.google.com/recaptcha/api.js?onload=onloadCallback&render=explicit' async defer></script> <div id=insert_ads_vi_consent_popup_wrapper style="display: none;"><p>Click below to consent to the use of the cookie technology provided by vi (video intelligence AG) to personalize content and advertising. For more info please access <a target=_blank href=https://www.vi.ai/legals>vi's website</a>.</p><div id=insert_ads_vi_consent_popup_actions_wrapper><input id=insert_ads_vi_consent_popup_disagree_btn type=button value="I do not accept" onclick=insert_ads_vi_consent_popup_disagree()><input id=insert_ads_vi_consent_popup_agree_btn  type=button value="I accept" onclick=insert_ads_vi_consent_popup_agree()></div><div id=insert_ads_vi_consent_popup_links_wrapper><a href=https://www.vi.ai/purposes target=_blank>Show purposes</a><a href=https://www.vi.ai/vendors target=_blank>Show vendors</a></div><input id=insert_ads_vi_consent_popup_is_eu type=hidden value><input id=insert_ads_vi_consent_popup_url type=hidden value=http://www.linuxandubuntu.com><input id=insert_ads_vi_consent_popup_auth type=hidden value=d5ae3028c2><input id=insert_ads_vi_consent_popup_vendor_list_version type=hidden value=1><input id=insert_ads_vi_consent_popup_vendor_list_purposes type=hidden value=000000000000000000000000><input id=insert_ads_vi_consent_popup_vendor_list_vendors type=hidden value=999></div><div id=insert_ads_vi_consent_popup_overlay style="display: none;"></div><span id=insert_ads_vi_consent_popup_settings_button onclick=insert_ads_vi_consent_popup_settings() unselectable=on style="display: none;">Privacy settings</span><script>/*<![CDATA[*/var bs_pagination_loc={"loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>"};/*]]>*/</script> <script>/*<![CDATA[*/var publisher_theme_global_loc={"page":{"boxed":"full-width"},"header":{"style":"style-2","boxed":"full-width"},"ajax_url":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","loading":"<div class=\"bs-loading\"><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><div><\/div><\/div>","translations":{"tabs_all":"All","tabs_more":"More","lightbox_expand":"Expand the image","lightbox_close":"Close"},"lightbox":{"not_classes":""},"main_menu":{"more_menu":"enable"},"top_menu":{"more_menu":"enable"},"skyscraper":{"sticky_gap":30,"sticky":true,"position":"after-header"},"share":{"more":true},"refresh_googletagads":"1","notification":{"subscribe_msg":"By clicking the subscribe button you will never miss the new articles!","subscribed_msg":"You're subscribed to notifications","subscribe_btn":"Subscribe","subscribed_btn":"Unsubscribe"}};var publisher_theme_ajax_search_loc={"ajax_url":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","previewMarkup":"<div class=\"ajax-search-results-wrapper ajax-search-no-product ajax-search-fullwidth\">\n\t<div class=\"ajax-search-results\">\n\t\t<div class=\"ajax-ajax-posts-list\">\n\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t<span>Posts<\/span>\n\t\t\t<\/div>\n\t\t\t<div class=\"posts-lists\" data-section-name=\"posts\"><\/div>\n\t\t<\/div>\n\t\t<div class=\"ajax-taxonomy-list\">\n\t\t\t<div class=\"ajax-categories-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Categories<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"categories\"><\/div>\n\t\t\t<\/div>\n\t\t\t<div class=\"ajax-tags-columns\">\n\t\t\t\t<div class=\"clean-title heading-typo\">\n\t\t\t\t\t<span>Tags<\/span>\n\t\t\t\t<\/div>\n\t\t\t\t<div class=\"posts-lists\" data-section-name=\"tags\"><\/div>\n\t\t\t<\/div>\n\t\t<\/div>\n\t<\/div>\n<\/div>","full_width":"1"};/*]]>*/</script> <div class="rh-cover noscroll gr-6 no-login-icon" > <span class=rh-close></span><div class="rh-panel rh-pm"><div class=rh-p-h></div><div class=rh-p-b><div class="rh-c-m clearfix"></div><form role=search method=get class=search-form action=http://www.linuxandubuntu.com> <input type=search class=search-field placeholder=Search... value name=s title="Search for:" autocomplete=off> <input type=submit class=search-submit value=></form><div class="  better-studio-shortcode bsc-clearfix better-social-counter style-button not-colored in-4-col"><ul class="social-list bsc-clearfix"><li class="social-item facebook"><a href = "https://www.facebook.com/linuxandubuntuofficial" target = "_blank" > <i class="item-icon bsfi-facebook" ></i><span class=item-title > Likes </span> </a></li><li class="social-item twitter"><a href = "https://twitter.com/linuxandubuntu" target = "_blank" > <i class="item-icon bsfi-twitter" ></i><span class=item-title > Followers </span> </a></li><li class="social-item youtube"><a href = "https://youtube.com/channel/UCq1rZSfOlhl1poyvRx-sYrg" target = "_blank" > <i class="item-icon bsfi-youtube" ></i><span class=item-title > Subscribers </span> </a></li><li class="social-item instagram"><a href = "https://instagram.com/mohdsohail_123" target = "_blank" > <i class="item-icon bsfi-instagram" ></i><span class=item-title > Followers </span> </a></li><li class="social-item pinterest"><a href = "http://www.pinterest.com/linuxandubuntu" target = "_blank" > <i class="item-icon bsfi-pinterest" ></i><span class=item-title > Followers </span> </a></li><li class="social-item rss"><a href = "http://www.linuxandubuntu.com/feed/rss" target = "_blank" > <i class="item-icon bsfi-rss" ></i><span class=item-title > Subscribe </span> </a></li></ul></div></div></div></div> <script src=https://c0.wp.com/p/jetpack/7.7.2/_inc/build/photon/photon.min.js></script> <script src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201939'></script> <script>var thirsty_global_vars={"home_url":"\/\/www.linuxandubuntu.com","ajax_url":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"recommends","link_prefixes":{"1":"recommends"},"post_id":"16382","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/86e9b.js></script> <script>var pollsL10n={"ajax_url":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/e0a8b.js></script> <script src=https://c0.wp.com/p/jetpack/7.7.2/_inc/build/lazy-images/js/lazy-images.min.js></script> <script src=https://c0.wp.com/c/5.2.3/wp-includes/js/comment-reply.min.js></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/3bdc5.js></script> <script>var ajax_object={"nonce":"0df182104a","ajaxurl":"http:\/\/www.linuxandubuntu.com\/wp-admin\/admin-ajax.php"};</script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/6eaa0.js></script> <script src=https://c0.wp.com/c/5.2.3/wp-includes/js/wp-embed.min.js></script> <script src='https://www.google.com/recaptcha/api.js?ver=5.2.3'></script> <script src=http://www.linuxandubuntu.com/wp-content/cache/minify/7920f.js></script> <script>/*<![CDATA[*/EnlighterJS_Config={"selector":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"language":"generic","theme":"godzilla","indent":2,"hover":"hoverEnabled","showLinenumbers":true,"rawButton":true,"infoButton":true,"windowButton":true,"rawcodeDoubleclick":false,"grouping":true,"cryptex":{"enabled":false,"email":"mail@example.tld"}};!function(){var a=function(a){var b="Enlighter Error: ";console.error?console.error(b+a):console.log&&console.log(b+a)};return window.addEvent?"undefined"==typeof EnlighterJS?void a("Javascript Resources not loaded yet!"):"undefined"==typeof EnlighterJS_Config?void a("Configuration not loaded yet!"):void window.addEvent("domready",function(){EnlighterJS.Util.Init(EnlighterJS_Config.selector.block,EnlighterJS_Config.selector.inline,EnlighterJS_Config)}):void a("MooTools Framework not loaded yet!")}();;/*]]>*/</script> <script>var pyhlt=function(a){"use strict";return{init:function(){0==pyhlt.ads_state()&&pyhlt.blocked_ads_fallback()},ads_state:function(){return void 0!==window.better_ads_adblock},blocked_ads_fallback:function(){var e=[];a(".pyhlt-container").each(function(){if("image"==a(this).data("type"))return 0;e.push({element_id:a(this).attr("id"),ad_id:a(this).data("adid")})}),e.length<1||jQuery.ajax({url:'http://www.linuxandubuntu.com/wp-admin/admin-ajax.php',type:"POST",data:{action:"better_ads_manager_blocked_fallback",ads:e},success:function(e){var t=JSON.parse(e);a.each(t.ads,function(e,t){a("#"+t.element_id).html(t.code)})}})}}}(jQuery);jQuery(document).ready(function(){pyhlt.init()});</script> <script src=https://stats.wp.com/e-201939.js async=async defer=defer></script> <script>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:7.7.2',blog:'164016613',post:'16382',tz:'5.5',srv:'www.linuxandubuntu.com'}]);_stq.push(['clickTrackerInit','164016613','16382']);</script> </body></html>